Interaction with LIFX Lamps (with V2.0 Firmware)

Posted on
Thu Feb 05, 2015 10:06 am
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Interaction with LIFX Lamps (with V2.0 Firmware)

This post is an update on the situation with using the Autolog LIFX Controller with LIFX lamps running the new V2.0 firmware.

First off, if you have any problems reload the plugin and if you are running LIFX-HTTP in a separate Terminal window, then stop and restart it.

I have been conscious that since upgrading my LIFX lamps to firmware v2.0 that they haven't quite been behaving themselves (thanks to manwithavan for the heads-up :) ); the status that my plugin shows in Indigo doesn't always fully reflect the status of the lamps, although this may correct itself when the lamps are next polled.

I have now determined that the status being returned to the plugin from LIFX-HTTP reflects the state of the lamp at point in time the status is returned . Previously, if say the lamp was on 100% brightness and I asked LIFX-HTTP to set it to 50% (Say with a dim duration of 5 seconds) then LIFX-HTTP would return 50% as the brightness. Now it returns say 92% which (as far as I can tell after doing a fair bit of testing) reflects the status of the LIFX lamp at the point in time that the status was returned (e.g. start of the dim from 100% to 50%).

Another "feature" is that turning the LIFX lamp off may leave it on 1% - so it will still show 'on' in Indigo and the LIFX iPhone app. I am still trying to understand why this and what the exact circumstances are that cause it.

I am going to have to re-think exactly how to handle this because it is a fairly fundamental difference to how it was previously working.

However, in the longer term, a potential upside is that it may prove a benefit in that I may be able to get Indigo to more accurately reflect the status of a dimming or brightening lamp. This could be especially useful on a long duration dim or brighten (say early morning sunrise simulation).

So the options at the moment are:
  1. to not upgrade the LIFX Lamps (probably unrealistic - I know I wanted mine updated)
  2. set durations to 0.1 (not ideal) [NOTE: I discovered a bug in that it won't allow 0.0 :oops: ]
  3. Be aware of the situation and use the LIFX iPhone app to correct any anomalies that don't get sorted on the next plugin polling of the LIFX lamps

I'll keep this thread updated with progress but it will take a little while (no ETA) to sort it out. :)

Please post any feedback in the Autolog LIFX Discussion thread. :)
Last edited by autolog on Thu Feb 05, 2015 1:59 pm, edited 1 time in total.

Posted on
Wed Feb 11, 2015 5:54 am
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

i am still working on a solution to this and making some steady progress :)

This post on Github goes someway to explain the current status - in summary it appears that LIFX-HTTP is not yet 100% compatible with the V2.0 firmware and it may be a while before it is :(

I am doing some work arounds so that my plugin makes some assumptions as to what the status of the LIFX lamps are.

Personally, I don't expose my LIFX lamps to the web and I haven't signed them up to the LIFX Cloud Account as I am happy to control them locally (via Indigo or the LIFX App) and remotely via Indigo only (not that I really have a requirement for that).

Hopefully I will have V3.0.0 of my plugin available within a week or so :)

Posted on
Sun Mar 15, 2015 3:46 am
manwithavan offline
User avatar
Posts: 73
Joined: Jan 14, 2014
Location: Melbourne Australia

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

Not sure if this is related to Firmware 2.0, but the plugin only works once or twice for me now before failing with errors, I then need to restart the plugin to regain to control.
This is the error that comes up, any suggestions?

Thanks

Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 1 (char 1)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 1 (char 1)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 3 (char 3)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 3 (char 3)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 5 (char 5)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 5 (char 5)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 5 (char 5)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 5 (char 5)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 6 (char 6)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting , delimiter: line 1 column 12 (char 12)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 5 (char 5)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 3 (char 3)'
Autolog LIFX Error StandardError detected in 'handleLifxHttpResponse'. Line '1883' has error='Expecting object: line 1 column 1 (char 1)'

Posted on
Sun Mar 15, 2015 5:13 pm
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

I am testing a revised version that is better able to handle the LIFX-HTTP interaction with the V2.0 firmware. It is still not quite 100% but I hope to make it available soon.

The basic issue is that LIFX-HTTP needs to be updated to handle the V2.0 firmware and the developer hasn't had the time to get round to doing it yet. My temporary work around is to make the LIFX Controller plugin more state aware and try and depend less on the erroneous status that LIFX-HTTP is returning. It does mean that if the LIFX lamps are altered outside of the LIFX Controller plugin that it can take a while for the states to agree. As the only way that the LIFX Controller plugin can determine the state is to query LIFX-HTTP and LIFX-HTTP is returning inaccurate states it makes it rather problematic :?

I will try and sort this out soon (I have been finishing a revised version of my Squeezebox Controller plugin which I will be releasing shortly). :)

Posted on
Sun Mar 15, 2015 6:29 pm
manwithavan offline
User avatar
Posts: 73
Joined: Jan 14, 2014
Location: Melbourne Australia

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

Gotcha. Thanks! :)

Posted on
Sun Mar 15, 2015 8:41 pm
SSteve offline
User avatar
Posts: 63
Joined: Sep 12, 2012
Location: Sierra Foothills, California

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

autolog wrote:
I am testing a revised version that is better able to handle the LIFX-HTTP interaction with the V2.0 firmware. It is still not quite 100% but I hope to make it available soon.


Thanks a lot for working on this. I have held off on updating my LIFX bulbs to 2.0 just to avoid problems with Indigo.

Posted on
Fri Apr 24, 2015 4:23 am
manwithavan offline
User avatar
Posts: 73
Joined: Jan 14, 2014
Location: Melbourne Australia

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

Does this help in any way?

https://github.com/tatey/lifx-http-client-ruby

Would love to get those pesky LIFX lamps back into Indigo.

Posted on
Fri Apr 24, 2015 5:04 am
manwithavan offline
User avatar
Posts: 73
Joined: Jan 14, 2014
Location: Melbourne Australia

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

Found a way to bodge them back in with applescript via this app:

http://peacockmedia-software.blogspot.c ... -your.html

Posted on
Fri Apr 24, 2015 5:14 am
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

Well done in finding a solution that works for you :)

I am sorry I still haven't been able to fix the LIFX plugin but it is so dependant on the LIFX-HTTP program which still isn't fixed :(

My temporary work arounds work after a fashion but it is still possible that lights will show the wrong state - I don't think it is really suitable for release and I am struggling to work around this problem.

As soon as LIFX-HTTP is updated I will release an update. :)

Posted on
Thu Jun 11, 2015 7:46 pm
manwithavan offline
User avatar
Posts: 73
Joined: Jan 14, 2014
Location: Melbourne Australia

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

This!:

http://www.reddit.com/r/lifx/comments/3 ... published/

https://github.com/lifx/lifx-protocol-docs

Does this get the plugin back on track? I hope so. My Frankenfix doesn't work reliably.

Posted on
Fri Jun 12, 2015 1:02 am
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

Thanks for the heads-up. :D

Having had a quick read of the documents, it looks promising.

I'll take a look at it and see what I can do. :)

Posted on
Thu Jul 23, 2015 10:37 am
Indy_Larry offline
Posts: 134
Joined: Dec 03, 2013
Location: Indianapolis

Re: Interaction with LIFX Lamps (with V2.0 Firmware)


Larry

Insteon, Z Wave, Hue, Sonos

Posted on
Thu Jul 23, 2015 10:51 am
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Interaction with LIFX Lamps (with V2.0 Firmware)

I have a revised LIFX V3 Plugin in Alpha Testing at the moment using the Local LAN Protocol :)

It seems to be working well as far as turning on / off / dimming & brightening is concerned.
I am just putting the finishing touches to being able to define colours for the lamps.

I hope to be able to publish it soon.
PM me for a link to the Alpha if you are interested :)

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest