Autolog LIFX Controller Discussion

Posted on
Wed Dec 31, 2014 5:22 am
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

DU Lou wrote:
... Any thoughts?

Yes - it's a bug :oops:

I am working on a fix and will upload a new version when I have fixed it :)

Posted on
Wed Dec 31, 2014 11:26 am
DU Lou offline
Posts: 260
Joined: Mar 08, 2012
Location: Florida

Re: Autolog LIFX Controller Discussion

No problem Jon. Looking forward to the next iteration! :)
~Lou


Sent from my iPad using Tapatalk HD

Posted on
Thu Jan 01, 2015 3:33 pm
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

Next iteration has arrived - see this post :D

Hopefully duration handling is improved - it is in my setup. :)

Posted on
Thu Jan 01, 2015 3:35 pm
DU Lou offline
Posts: 260
Joined: Mar 08, 2012
Location: Florida

Re: Autolog LIFX Controller Discussion

Great! I should be able to test in the next 24-48 hours and provide feedback. Thanks. ~Lou


Sent from my iPhone using Tapatalk

Posted on
Mon Feb 02, 2015 4:47 pm
manwithavan offline
User avatar
Posts: 73
Joined: Jan 14, 2014
Location: Melbourne Australia

Re: Autolog LIFX Controller Discussion

Thanks for the plugin Autolog, I've been loving using it.
Until today.
Foolishly updated my bulbs to firmware 2.0 and it seems to have broken the plugin... Think it'll be possible to get the plugin working again with the new firmware? :(

http://updates.lifx.co/

Posted on
Mon Feb 02, 2015 4:55 pm
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

Thanks for the heads-up on this :)

I have just spent this evening updating my LIFX lamps to V2.0 and having read your post, checked the plugin and yes there does appear to be an error of some sort :(

It is nearly 23:00 in the UK, so realistically this will have to wait until tomorrow morning (UK time) until I can look at it.

I will do my best to fix it ASAP assuming it isn't a problem with LIFX-HTTP. :)

Posted on
Mon Feb 02, 2015 5:16 pm
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

I have had a very quick look at the issue. :)

As a first step - try reloading the plugin. If you are running LIFX-HTTP in a separate Terminal window, then stop and restart it.

This seems to give back some semblance of control (at least on my system) i.e. the plugin isn't detecting an error which it was before and I can turn lights on and off.

I think there maybe one or two other oddities which I will look at tomorrow morning. :)

Posted on
Mon Feb 02, 2015 5:32 pm
manwithavan offline
User avatar
Posts: 73
Joined: Jan 14, 2014
Location: Melbourne Australia

Re: Autolog LIFX Controller Discussion

Why didn't I try that first? :oops:

Thanks for responding so fast!

Posted on
Tue Feb 03, 2015 11:54 am
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

Having played with the lamps a bit today - there appears to be a small issue with the plugin's interaction with LIFX-HTTP.

For example, if I set a lamp brightness to 50%, the lamp gets set correctly to 50% but LIFX-HTTP returns a lower value (say 35%) which my plugin then shows as the dimming value as it believes what LIFX-HTTP is telling it. When the next polling occurs the value is (normally) corrected.

So I am not sure what to do about this at the moment - it isn't a show-stopper and I tempted to let the dust settle on the V2.0 change before spending too much time sorting it out (even if that is possible?). In fact that's what I will do unless I get any feedback that suggests it is a major problem :lol:

Posted on
Tue Feb 03, 2015 6:38 pm
manwithavan offline
User avatar
Posts: 73
Joined: Jan 14, 2014
Location: Melbourne Australia

Re: Autolog LIFX Controller Discussion

No biggy. Thanks for having a look at it.

Posted on
Fri Jul 31, 2015 7:31 am
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

Just posted an updated version of the LIFX Plugin that now supports LIFX Lamps running V2 firmware.

See the announcement of the new LIFX V3.0.5 Plugin.

It is much more responsive and runs locally and natively and no longer requires the use of LIFX-HTTP making setup a lot easier. :D

Posted on
Fri Jul 31, 2015 7:37 am
manwithavan offline
User avatar
Posts: 73
Joined: Jan 14, 2014
Location: Melbourne Australia

Re: Autolog LIFX Controller Discussion

Brilliant! Thanks :D

Posted on
Fri Jul 31, 2015 9:08 pm
Indy_Larry offline
Posts: 134
Joined: Dec 03, 2013
Location: Indianapolis

Re: Autolog LIFX Controller Discussion

Hi Jon,

Sorry been a really busy week at work :x. I wanted to let you know I've been using it and it has been working great. But I've only been doing simple on/off commands. I'll do some more complex commands next week. Thanks for all of your hard work on this plugin.

Larry

Larry

Insteon, Z Wave, Hue, Sonos

Posted on
Mon Feb 22, 2016 4:40 pm
gtreece offline
Posts: 169
Joined: Sep 26, 2011

Re: Autolog LIFX Controller Discussion

Should this plugin be working correctly with the Color 1000 bulbs? I can change hue and brightness, and I can set it to white and brightness, but I am not able to change the kelvin of white.

Edit:
For clarification, I can enter different kelvin values in an action for a bulb, but the bulb doesn't actually change to that kelvin value.

Posted on
Mon Feb 22, 2016 5:10 pm
autolog offline
Posts: 2435
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

The plugin hasn't been tested with a Color 1000 bulb as I haven't got one.

I will take a look at it tomorrow (Tuesday) and see if I can spot anything. :)

Page 4 of 12 1, 2, 3, 4, 5, 6, 7 ... 12

Who is online

Users browsing this forum: No registered users and 0 guests