Trouble connecting more then one DS18B20 - Onewire

Posted on
Mon Nov 18, 2019 1:43 pm
Sam offline
Posts: 33
Joined: Aug 22, 2016

Trouble connecting more then one DS18B20 - Onewire

Hi,
I have a some trouble connecting more than one ds18b20 to one-wire. One at a time goes well and the temperature is displayed, so I know the sensors are ok but I don't get several to work at the same time.
I have followed the instruction "piBeacon: 5- connect sonsors to the rPi" but no luck. What I understand, the others will be loaded as slaves automatically?

Also chosen "add new ONEWIRE sensors as they get detected" in the current rpi.

I use RPi 3B + with Buster. Image 2019-09-05, Plugin 7.114.319

/Sam

Posted on
Tue Nov 19, 2019 9:52 am
kw123 offline
User avatar
Posts: 6900
Joined: May 12, 2013
Location: Dallas, TX

Re: Trouble connecting more then one DS18B20 - Onewire

2 sections:
1. hardware setup

2. software

hardware:
- you should only use one resistor
- the cables should not be too long
Screen Shot 2019-11-19 at 09.37.06.png
Screen Shot 2019-11-19 at 09.37.06.png (44.27 KiB) Viewed 191 times

when using LONG cable you need to use 2 cables for the signal wire: one to and one back. it should be a star config all wires go back to the central point
DO NOT use twisted pair for signal& V+ you could do twisted pair signal&Ground and V+&ground
also if you have multiple sensor lowering the resistor value might help.

check out this site:https://www.raspberrypi.org/forums/viewtopic.php?t=167896 for the cabling discussion

But before you do that, check first the software side::
do terminal
ssh pi@ ..
then
Code: Select all
cat /sys/bus/w1/devices/w1_bus_master1/w1_master_slaves

you should see something like this when multiple sensors are connected properly and working
28-800000035f50
28-8000000137c1
28-800000013d47
28-0416b39944ff
28-0316b5db4bff
28-031500c05bff

if they are poorly connected you could see names that do not start w 28-

if you do see multiple correct entries then we have a software / config issue.

Karl

Posted on
Tue Nov 19, 2019 11:13 am
Sam offline
Posts: 33
Joined: Aug 22, 2016

Re: Trouble connecting more then one DS18B20 - Onewire

Hi Carl,

Thanks for your reply..

I do see both of my sensors but not in plugin..
When i create a new device in plugin only 28-041633a06eff is shown.

Code: Select all
pi@RPi:~ $ cat /sys/bus/w1/devices/w1_bus_master1/w1_master_slaves
28-04163364f0ff
28-041633a06eff
pi@RPi:~ $


/Sam

Posted on
Tue Nov 19, 2019 3:58 pm
kw123 offline
User avatar
Posts: 6900
Joined: May 12, 2013
Location: Dallas, TX

Re: Trouble connecting more then one DS18B20 - Onewire

ok so not hardware..

could you send me .. may be email is best: karlwachs me com

1. parameters file from rpi (mask the userid..)

2. switch on debug sensors on indigo and let it run, send the lines onewire related ..

3. on rpi
Code: Select all
cd  ibeacon
tail -F temp/messageSend
(capital F)
and send the lines with onewire

Karl

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest