[LOCKED] Latest Version 0.2.07 - Critical bugfix...

Posted on
Fri Aug 26, 2016 2:00 pm
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

[LOCKED] Latest Version 0.2.07 - Critical bugfix...

Hey to all ALPHA testers,

I think I've realized what the issue is with nredarwin. I don't appear to have updated the sys.path to include the new module so iTravel doesn't know where to look. It's a bit of a newbie error I'm afraid :roll:

My system path already includes the path to the plugin nredarwin module but I didn't add the path to automatically for other systems that installed the iTravel plugin. Ooops :shock:

Anyway - I think it's fixed now so try installing this new version ( 0.2.07) which will automatically update the system path to include the nredarwin folder. THERE IS NO NEED TO INSTALL NREDARWIN modules separately. This plugin contains Richard's module with some simple updates to work with Indigo 6 using Python 2.6 (rather than the expected 2.7).

You can download the new version from this link:


What's new in version 0.2.07?

This update is critical and mandatory for all users

1. Plugin won't install because nredarwin isn't installed properly.

Error message is similar to :

    Installing and enabling plugin iTravel v0.2.05
    Loading plugin "iTravel 0.2.05"
    Starting plugin "iTravel 0.2.05" (pid 10528)
    iTravel You must install nredarwin before using this plugin - check forum for details
    iTravel Error Error in plugin execution InitializeMain:

    Traceback (most recent call last):
    File "plugin.py", line 53, in <module>
    SystemExit: 0


Resolved. Included plugin module path in sys.path automatically on initial launch........

As always, if something doesn't seem quite right, please let me know. Thanks for your support!

Regards

Mike

Posted on
Fri Aug 26, 2016 2:12 pm
mwoodage offline
Posts: 71
Joined: Dec 19, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Sorry Mike, still no joy for me, see the attached pic,
Attachments
Screen Shot 2016-08-26 at 21.06.44 copy.png
Screen Shot 2016-08-26 at 21.06.44 copy.png (53.04 KiB) Viewed 1802 times

Posted on
Fri Aug 26, 2016 3:28 pm
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Martin

Very strange - never seen that. Might end up being a question for Matt and Jay - I'll ask them. In the meantime you could do the following:

    1. Disable the plugin from the menu (you've got that option at least)
    2. Delete the file /Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/com.corporatechameleon.nationalRail.indiPref
    3. Delete the file /Library/Application Support/Perceptive Automation/Indigo 6/Plugins (Disabled)/iTravel.indigoPlugin to remove the current installation of iTravel
    4. If that doesn't exist then you may find the plugin file in /Library/Application Support/Perceptive Automation/Indigo 6/Plugins/iTravel.indigoPlugin
    5. These commands delete the current configuration file and the install and start the install from scratch
    6. Download the plugin again from the link above
    7. Reinstall as usual

This should hopefully delete the old install and put in the new version from scratch. When you install it I fully expect it to display the config dialog properly - it may just be confused (corrupted) from the first install. Then you can enter your key and carry on.

If this doesn't work I'll review it in the morning after I've contacted Matt and Jay :)

Aren't ALPHAs just the best :) Honestly, just think that all of these experience will make it really easy for others in the future!

Thanks for your support

Mike

Posted on
Fri Aug 26, 2016 3:40 pm
mwoodage offline
Posts: 71
Joined: Dec 19, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Hi Mike, thanks for the detailed reply.
Interesting the file Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/com.corporatechameleon.nationalRail.indiPref did not exist, and is still not there when i re-install.
I'm assuming that missing file is whats causing the issue?

More than happy to keep testing, i'm just sorry that i keep sending you problems :)

Martin

Posted on
Sat Aug 27, 2016 3:28 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

mwoodage wrote:
Hi Mike, thanks for the detailed reply.
Interesting the file Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/com.corporatechameleon.nationalRail.indiPref did not exist, and is still not there when i re-install.
I'm assuming that missing file is whats causing the issue?

More than happy to keep testing, i'm just sorry that i keep sending you problems :)

Martin


Martin

That's really good information. Now I've just got to work out why it's missing. I'll probably have to ask Matt & Jay on that one.

Was there any information in the log file I mentioned? ISomething is happening during the initiation on your system that isn't happening on mine.

Can you download this version https://www.dropbox.com/s/qxdit7nt4ka18hn/iTravel.indigoPluginMW.zip?dl=0 which is specially designed for you. It automatically switches on debugging and displays some information when you install the new version.

Can you try the following:

1. Delete the files (if they exist) in the following places:

    /Library/Application Support/Perceptive Automation/Indigo 6/Plugins/iTravel.indigoPlugin
    /Library/Application Support/Perceptive Automation/Indigo 6/Plugins (Disabled)/iTravel.indigoPlugin
    /Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/com.corporatechameleon.nationalRail.indiPref

This will remove iTravel and preferences from your system completely.

2. Then download this version https://www.dropbox.com/s/qxdit7nt4ka18hn/iTravel.indigoPluginMW.zip?dl=1 which is specially designed for you.

3. Install the plugin in the normal way - Selecting install from the dialog box that appears to ask if you want to install version 0.2.14

4. Keep a close eye on the log for messages/errors

My questions are:

a) Do you see any messages in the log (error or iTravel or otherwise)? Can you cut and paste a copy of the Indigo Event Log showing what's happening during install for me into a reply to this post?

b) Does the dialog appear asking if you want to install iTravel?

c) After installation - do any of the following files reappear?

    /Library/Application Support/Perceptive Automation/Indigo 6/Plugins/iTravel.indigoPlugin
    /Library/Application Support/Perceptive Automation/Indigo 6/Plugins (Disabled)/iTravel.indigoPlugin
    /Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/com.corporatechameleon.nationalRail.indiPref

d) Can you create an iTravel device. i.e. when you create a device and click on the type dropdown, does iTravel appear in the list?

Any responses to these questions would be really useful. You noting that the preferences file didn't exist has helped a lot.

Please don't worry about raising problems - that's the fun of the ALPHA stage. When it works iTravel is worth it :-)

Regards

Mike

Posted on
Sat Aug 27, 2016 4:09 am
mwoodage offline
Posts: 71
Joined: Dec 19, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Hi Mike,
Still no joy, i've tried removing all the itravel files in the system. I've noted below the files that were there and the ones that weren't.

/Library/Application Support/Perceptive Automation/Indigo 6/Plugins/iTravel.indigoPlugin - Removed
/Library/Application Support/Perceptive Automation/Indigo 6/Plugins (Disabled)/iTravel.indigoPlugin - Not there
/Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/com.corporatechameleon.nationalRail.indiPref - Not There

I also restarted indigo and the server, iTravel was gone from the Plugin's list so then installed the version you posted v0.2.14. I was asked if i wanted to install so clicked yes.

This appeared in the log:-
2016-08-27 10:51:11.920 Application Installing and enabling plugin iTravel v0.2.14
2016-08-27 10:51:11.921 Application Loading plugin "iTravel 0.2.14"
2016-08-27 10:51:11.923 Application Starting plugin "iTravel 0.2.14" (pid 13341)
2016-08-27 10:51:12.131 iTravel You must install nredarwin before using this plugin - check forum for details
2016-08-27 10:51:12.132 iTravel Error Error in plugin execution InitializeMain:

Traceback (most recent call last):
File "plugin.py", line 57, in <module>
SystemExit: 0

2016-08-27 10:51:12.132 Application Stopping plugin "iTravel 0.2.14" (pid 13341)

After Install:-
/Library/Application Support/Perceptive Automation/Indigo 6/Plugins/iTravel.indigoPlugin - Installed
/Library/Application Support/Perceptive Automation/Indigo 6/Plugins (Disabled)/iTravel.indigoPlugin - not installed
/Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/com.corporatechameleon.nationalRail.indiPref - not installed

No joy with creating an iTravel device, noting appears in the drop down menu.

Other things i've spotted - i have a file in the /Library/Application Support/Perceptive Automation/Indigo 6/Preferences/Plugins/ folder called
com.corporatechameleon.nestplugBeta.indiPref - this is the only one with your name on it - could it be affecting the installation of the Travel file?

The plugin i'm downloading and installing was created in Aug 18th - am i getting the right plugin? It says v0.2.14 when i install it.

We'll get there, happy to keep trying :) are others having the same trouble?

Cheers
Martin
Attachments
Screen Shot 2016-08-27 at 11.05.25 copy.png
Screen Shot 2016-08-27 at 11.05.25 copy.png (139.32 KiB) Viewed 1703 times

Posted on
Sat Aug 27, 2016 5:14 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Martin

That's really helpful. It's clear that it can't find the module nredarwin inside the plugin. I think I can fix that ok.

Give me an hour and I'll upload the fix. Strange that it can't find it but hey - that's Macs for you :)

Mike

Posted on
Sat Aug 27, 2016 6:19 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Ok... I've had a long think about it and there are a couple of things I'd like you to try. I think we are getting there but there are a couple of things I hadn't thought of that could be causing the issue.

1. suds and functools modules not included in overall python install. nredarwin depends on these python modules which i thought were standard but might not be on all system setups. If it's missing it will appear to throw an error that it can't find nredarwin where in actuality it can't find suds or functools which are requried inside the nredarwin module and will be looked for when nredarwin is imported. So we need to check if they're there and if not install them. It's really the same as installing PIL.

The steps are:

    a) Open a Terminial Window (/Applications/Utilities/Terminal

    b) At the $ prompt type sudo pip2.6 install suds followed by ENTER (if it can't find pip2.6 just use pip as the command instead - whatever worked for PIL)

    c) Type your password if requested followed by ENTER

    d) After a few moments it should either i) Install suds (version suds-0.4 I think) and return the $ prompt or ii) return the message requirement already satisfied (use --upgrade to upgrade): suds in /Library/Python/2.6/site-packages

    e) Now let's check they're present

    f) At the $ prompt type python followed by ENTER (it should return with:

    Python 2.6.9 (unknown, Oct 23 2015, 19:19:20)
    [GCC 4.2.1 Compatible Apple LLVM 7.0.0 (clang-700.0.59.5)] on darwin
    Type "help", "copyright", "credits" or "license" for more information.

    or something like that

    g) Now type import suds followed by ENTER

    h) Now type from suds.client import Client followed by ENTER

    i) It should simply return the python prompt '>>>' each time

    j) Now type from functools import partial followed by ENTER

    k) Now type import logging followed by ENTER

    l) Finally type import os followed by ENTER

    m) In each case you should be rewarded with the '>>>' prompt which shows it's there

    If you get an error we'll need to install the missing piece the same way as we did with suds. i.e. sudo pip install functools

    To exit back to the $ prompt type exit() followed by ENTER

If you didn't use pip and used easy_install , pip2.6 or macports when you installed PIL then use that instead.

When you've done all of this and got some results let me know. If it all returns ok then let's try again to install the package.

To do this I'd like you to do the following.

    1. From your Download folder delete anything that concerns iTravel... any plugins, zip files, folders, etc.... (I noticed that your plugin was actually called iTravel-5.indigoPlugin which implies you have multiple copies of the zip file and plugin in your Downloads folder. It's good practice to remove these before you download a new install as copies can cause issues especially when looking for modules

    2. Delete the files that you deleted previously from the Indigo Plugins and Preferences folders

    3. Now download this version of iTravel https://www.dropbox.com/s/ef3t9fs2q2jhb8n/iTravel.indigoPlugin.zip?dl=1 - this is version 0.2.08

    4. When it's downloaded - open the zip file and click on the iTravel.indigoPlugin file to install it

    5. Indigo will probably note that you're downgrading your install - that's fine just say Yes

    6. Then let's see what happens - check the log and let me know of any messages. Hopefully you'll get the config dialog now! If not we'll get some really useful information :)

Thanks for being so patient. I know that we're very close - it's just a system configuration and this experience means I'll be much better placed to help others.

Regards

Mike

Posted on
Sat Aug 27, 2016 7:33 am
mwoodage offline
Posts: 71
Joined: Dec 19, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Hi Mike,
Followed it to the letter and still no joy.
I've copied the extract from the terminal info below, i'm showing as having Python 2.7 but i've installed 2.6 as well. I think this is where the problem lies. I've tried several times to install Python 2.6.9 and it installs, going through all the information and ending with process completed, but i can't get sudo pip2.6 install suds to work - however sudo pip install suds does?

Last login: Sat Aug 27 14:00:32 on ttys001
Martins-Mini:~ martinwoodage$ sudo pip2.6 install suds
Password:
sudo: pip2.6: command not found
Martins-Mini:~ martinwoodage$ sudo pip install suds
The directory '/Users/martinwoodage/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/Users/martinwoodage/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting suds
Downloading suds-0.4.tar.gz (104kB)
100% |████████████████████████████████| 112kB 1.9MB/s
Installing collected packages: suds
Running setup.py install for suds ... done
Successfully installed suds-0.4
Martins-Mini:~ martinwoodage$ python
Python 2.7.10 (default, Oct 23 2015, 19:19:21)
[GCC 4.2.1 Compatible Apple LLVM 7.0.0 (clang-700.0.59.5)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import suds
>>> from suds.client import Client
>>> from functools import partial
>>> import logging
>>> import os
>>> exit
Use exit() or Ctrl-D (i.e. EOF) to exit
>>> exit()
Martins-Mini:~ martinwoodage$


The plugin install process has moved on a bit, it now shows this:-
2016-08-27 14:07:59.825 Application Downgrading plugin iTravel to older version 0.2.08 (previous version moved to trash)
2016-08-27 14:07:59.871 Application Loading plugin "iTravel 0.2.08"
2016-08-27 14:07:59.874 Application Starting plugin "iTravel 0.2.08" (pid 19311)
2016-08-27 14:08:00.446 iTravel * Darwin present *
2016-08-27 14:08:00.447 iTravel ** Couldn't find suds module - check forums for install process for your system **
2016-08-27 14:08:00.447 iTravel Error Error in plugin execution InitializeMain:

Traceback (most recent call last):
File "plugin.py", line 66, in <module>
SystemExit: 4

I'm sure its something i'm doing wrong with the Python install - but i'm not that skilled with Python so will need some help.

Cheers Mike
Martin

Posted on
Sat Aug 27, 2016 8:52 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Ok Martin - I can see the problem now I think... Great feedback

You're using 2.7 python by default in the terminal window and indigo uses 2.6 only at the moment. That's probably the way that it was set up by Apple on your original install. That's why you're having a problem because Indigo doesn't know where to find the modules and pip is automatically installing them under python 2.7 and not 2.6!

What we need to do is make python 2.6 your standard 'go to place for these particular installs' not 2.7 so indigo can find what it needs... The great news is that it's found Darwin!

You need to install pip2.6 as this will force installs into the 2.6 libraries (not 2.7 which it will do by default) when needed. It won't affect anything else on your system.

Try the following:

    Open a Terminal Window

    At the $ prompt type sudo easy_install-2.6 pip followed by ENTER

    pip2.6 should now be automatically installed

    Now install suds with the command sudo pip2.6 install suds followed by ENTER

    Now try functools with the command sudo pip2.6 install functools followed by ENTER - this may fail but its ok

    At the final $ prompt type python2.6 (the 2.6 is very important)

    You should get a response like:

    Code: Select all
    Mac-mini:~ Michael$ python2.6
    --> NOTE NUMBER --> Python 2.6.9 [/u](unknown, Oct 23 2015, 19:19:20) (my comments added)
    [GCC 4.2.1 Compatible Apple LLVM 7.0.0 (clang-700.0.59.5)] on darwin
    Type "help", "copyright", "credits" or "license" for more information.
    >>>

    Now try import suds
    Now try import functools
    Now try from suds.client import Client
    Now try from functools import partial

    Code: Select all
    >>>import suds
    >>> from suds.client import Client
    >>> import functools
    >>> from functools import partial
    >>> exit()

    and close the terminal window.

    Delete and then try and install the plugin again (version 0.2.08) like you did before....

It should now find the modules in the right places and run! Hopefully :)

Regards

Mike

Posted on
Sat Aug 27, 2016 8:54 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

BTW you're not the only one with this problem.... Apple doesn't make life easy... Give me a PC anytime and you don't get these issues! :twisted:

M

Posted on
Sat Aug 27, 2016 9:31 am
mwoodage offline
Posts: 71
Joined: Dec 19, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Quick post - its worked!! I've got the Configure iTravel screen up. i'll fill in the details and report back :)

Thanks so much for you help,
Martin

Posted on
Sat Aug 27, 2016 9:34 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

mwoodage wrote:
Quick post - its worked!! I've got the Configure iTravel screen up. i'll fill in the details and report back :)

Thanks so much for you help,
Martin


:D :D :D :D

I'll be updating the forum and manual right now!

Mike

Posted on
Sat Aug 27, 2016 10:06 am
mwoodage offline
Posts: 71
Joined: Dec 19, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

Its working :D :D :D :D :D :D
Just building a page now for Tiverton to London paddington - i'll post a pic when i've got it set up.

Thanks so much for helping me out and building a great plugin, i really appreciate the time its taken out of your day today - thank you.
Martin

Posted on
Sat Aug 27, 2016 10:22 am
Chameleon offline
Posts: 611
Joined: Oct 04, 2014

Re: Latest Version 0.2.07 - Critical bugfix...

mwoodage wrote:
Its working :D :D :D :D :D :D
Just building a page now for Tiverton to London paddington - i'll post a pic when i've got it set up.

Thanks so much for helping me out and building a great plugin, i really appreciate the time its taken out of your day today - thank you.
Martin


Great - I wondered if you might have to reinstall PILLOW but you didn't so that's great....

There will be some great enhancements in the future...

Regards

Mike

Who is online

Users browsing this forum: No registered users and 0 guests