Fixed: Unable to begin with fresh install

User avatar
Hackencrash
Posts: 251
Joined: Wed Dec 16, 2015 7:05 am
Location: UK

Fixed: Unable to begin with fresh install

Post by Hackencrash »

After my Mac SSD failed, I reinstalled Indigo 7.4 and piBeacon v7.118.340 onto a fresh install of Catalina.

With this fresh install, I am unable to get things started with piBeacon. The event log is flooded with piBeacon Errors, far too many to mention and occasionally the plugin restarts.

When I go into the plugin Configure... dialogue, I am unable to save any options as I get "Error validating fields" at the bottom, yet no fields are shown highlighted with errors.

The event log states: "indigo server userid or password not configured in config and security level is set to digest or basic"

I have put in the user ID and Password in these fields and set to Digest. I have tried different values here and can't get it to save any configuration at all to get rid of these errors.

What is the user field here? Is this the username that you configure in the Indigo Server connection dialogue box under Remote Access or is this the user for the Mac? I've tried both.

Remote access using the iPhone app, etc. works OK and all my other Indigo plugins work. The user ID that is set in Indigo is also a Catalina admin user ID with same password, but not the ID I login to the Mac with.

I cannot do anything and have spent hours on this - please help.
Last edited by Hackencrash on Thu Mar 26, 2020 8:12 am, edited 1 time in total.
User avatar
kw123
Posts: 8705
Joined: Sun May 12, 2013 4:44 pm
Location: Dallas, TX
Contact:

Re: Unable to begin with fresh install

Post by kw123 »

please post the FIRST error message.
the userID and password is used by the RPIs to RESTfull connect w http to indigo

And yes starting from scratch is one thing I am not testing. I need to set that up on a separate system, will try overnight ... but my test license is not working --> Matt Jay?

Karl
User avatar
Hackencrash
Posts: 251
Joined: Wed Dec 16, 2015 7:05 am
Location: UK

Re: Unable to begin with fresh install

Post by Hackencrash »

Code: Select all

   piBeacon                        myLogSet setting parameters -- logFileActive= indigo; logFile= /Library/Application Support/Perceptive Automation/Indigo 7.4/Logs/com.karlwachs.piBeacon/plugin.log;  debug plugin:[]   RPI#:-1
   piBeacon Error                  Error in plugin execution UiValidate:

Traceback (most recent call last):
  File "plugin.py", line 9446, in validatePrefsConfigUi
KeyError: key userIdOfServer not found in dict
User avatar
kw123
Posts: 8705
Joined: Sun May 12, 2013 4:44 pm
Location: Dallas, TX
Contact:

Re: Unable to begin with fresh install

Post by kw123 »

Hackencrash: try latest version posted: 7.118.343

had a really weird issue (besides the key userIdOfServer not found in dict)

had to add copy.deepcoy() for a parameter in a function call:

Code: Select all

def test(a,default={}):
   out = default  ## replace w copy.deepcopy(default)
  ...  read out from file a if exist ....
   return out
abc = test("filename" )
abc = "xyz"
def = test("filename2")
was overwriting "default" in the second call to test with the previous value, ==> abc == def == "xyz"

..still don't understand why

Karl
User avatar
Hackencrash
Posts: 251
Joined: Wed Dec 16, 2015 7:05 am
Location: UK

Re: Unable to begin with fresh install

Post by Hackencrash »

copy.deepcopy() - not had that issue myself!

Yep - that seems to have fixed it... well I can save my config anyway and I'm now not getting 100's of errors so I'm guessing everything is OK.

Thank you!
User avatar
Hackencrash
Posts: 251
Joined: Wed Dec 16, 2015 7:05 am
Location: UK

Re: Fixed: Unable to begin with fresh install

Post by Hackencrash »

Been working solidly for 7 hours, glad to have this invaluable plugin back - I depend on it!

Marked as fixed - thank you 8)
Post Reply

Return to “piBeacon”