RFXCOM error after upgrade - isUS not found in Dict (SOLVED)

Posted on
Sat Oct 07, 2023 5:50 am
mike_c offline
Posts: 37
Joined: Oct 03, 2013

RFXCOM error after upgrade - isUS not found in Dict (SOLVED)

I started to write a request for help. but managed to solve the issue. I thought I would write some brief notes here in case others face a similar issue.

I've been running RFXCOM plugin (v 1.4.0) for a number of years. This connects to a RFXtrx 433 to control a collection of Somfy blinds. Normal processing ensues - Indigo control on a schedule / via control pages along with the remote for each blind as a manual override.

For a while now (in honesty it's been 12 months+) the following warning can be found when starting indigo server:
Code: Select all
Warning plugin "RFXCOM 1.4.0" may not be compatible with next Indigo release without an update

In preparation for an upcoming Indigo upgrade breaking the integration to the blinds (and me getting grief from the rest of the family that the blinds no longer work), I applied the available upgrade (to version 3.0.2) via the Download New Version menu item. However, after applying the upgrade and seeing the successful startup messages, the following error was displayed when trying to control a blind:
Code: Select all
RFXCOM Error    'key isUS not found in dict'

After the usual google-foo (no joy), I started writing this post but thought I'd try one more thing. I opened up the plugin zip file, and did a recursive grep for isUS. I found two entries which I commented out, reloaded the plugin and ... all working. For reference isUS can be found in:
./RFXCOM.indigoPlugin/Contents/Server Plugin/Devices.xml (I left this file as it did not appear to call upon this value)
./RFXCOM.indigoPlugin/Contents/Server Plugin/RFXTRX.py (commented out line 616 to 624 and 660 to 661).

As I am UK based, I just commented out the python code (including the nested statements). If US based, I assume you would need to ensure the conditional statements ARE run (respecting python's indentation).

Hope that this may be of help to someone now or in the future.

Posted on
Sat Oct 07, 2023 9:41 am
jay (support) offline
Site Admin
User avatar
Posts: 18277
Joined: Mar 19, 2008
Location: Austin, Texas

Re: RFXCOM error after upgrade - isUS not found in Dict (SOL

Looking at the current code, isUS should always be True or False, but never missing. It's likely that at some point it wasn't part of the device definition and whoever added it didn't take this into account. I think that if you just edit the device config and save it again that would solve the problem.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests