Error when loading plugin on windows system

Posted on
Tue Aug 15, 2023 11:20 am
durosity offline
User avatar
Posts: 4375
Joined: May 10, 2012
Location: Newcastle Upon Tyne, Ye Ol' England.

Error when loading plugin on windows system

I've been trying to get this to work with one of my windows systems but to very limited success. I've installed plugin 0.9.16 on Indigo, and then 0.9.15 of the Windows Communicator software from the github releases pages which seems to be the latest version there, but each time I try to connect I get this error (extract from log)

Code: Select all
2023-08-15 18:04:13,539 DEBUG [0] [1] App - :: Version Received:   0.9.16
2023-08-15 18:04:13,555 DEBUG [0] [1] App - :: Current App Version:   15
2023-08-15 18:04:13,555 DEBUG [0] [1] App - :: Last Digit Version Equals:   16
2023-08-15 18:04:13,555 INFO [0] [1] App - ---------------Update is Required.  Please download and Update your PC's Software-------------
2023-08-15 18:04:42,246 DEBUG [0] [1] App - Show Window selected.
2023-08-15 18:04:54,909 INFO [0] [1] MainWindow - ClickConnect Run.
2023-08-15 18:04:54,909 INFO [0] [1] MainWindow - Connecting to:System.Windows.Controls.TextBox: 192.168.1.10:9123 and :http://192.168.1.10:9123/StartupConnect/
2023-08-15 18:04:54,909 DEBUG [0] [1] MainWindow - --------Response Status Received:{'COMMAND': '', 'COMMAND2': '', 'COMMAND3': '', 'COMMAND4': ''}
2023-08-15 18:04:54,909 DEBUG [0] [1] MainWindow - --------Headers Recevied:IndigoPluginVersion: 0.9.16


Now I do get a connection to my indigo server if I browse to the URL:

Code: Select all
Error response
Error code: 501

Message: Unsupported method ('GET').

Error code explanation: HTTPStatus.NOT_IMPLEMENTED - Server does not support this operation.


(I believe the error to be expected considering it's not designed to be connected to via a browser)

And I do get a new device created in Indigo itself for the PC, but only the Hostname, datetime stamp, online status and IP address, but all the other fields are blank.

This system is running windows 11 22H2

Any ideas? I'm hoping it's just the release on Github is out of date and I've just missed an obvious update somewhere :D

Computer says no.

Posted on
Tue Aug 15, 2023 3:13 pm
GlennNZ offline
User avatar
Posts: 1579
Joined: Dec 07, 2014
Location: Central Coast, Australia

Error when loading plugin on windows system

Hi

That looks as expected - well except the version reminder - but that is only reminder not critical. Should be able to then press save and continue in the Windows software finalising the connection. The windows software (which I’m running on 8,10 and 11) should minimise to the taskbar and should remain there.

The fact it connects, creates device, fills some of the state fields - without error. Suggests that everything is okay.

I’ll track down the Windows update (which may or may not exist…and is just this connect message currently). When I updated for python3 I believe I got my version numbers out of sync accidentally (2 one is windows, 3 is Mac) hence this connection message.

Glenn


Sent from my iPad using Tapatalk

Posted on
Tue Aug 15, 2023 5:02 pm
durosity offline
User avatar
Posts: 4375
Joined: May 10, 2012
Location: Newcastle Upon Tyne, Ye Ol' England.

Re: Error when loading plugin on windows system

Ah, that’s interesting! Odd thing is though no commands I send across get processed. I presumed it was because the controller was out of date, but I guess there must be another reason. I’ll have another look at it tomorrow!


Sent from my iPhone using Tapatalk Pro

Computer says no.

Posted on
Wed Aug 16, 2023 12:29 am
GlennNZ offline
User avatar
Posts: 1579
Joined: Dec 07, 2014
Location: Central Coast, Australia

Re: Error when loading plugin on windows system

Hi

Following on from earlier reply, your Windows logging all looks correct, even though seen to missing bit that follows and would be more useful

Should see something like this:

Code: Select all
2023-08-16 16:19:56,405 INFO [0] [1] MainWindow - ClickConnect Run.
2023-08-16 16:19:56,406 INFO [0] [1] MainWindow - Connecting to:System.Windows.Controls.TextBox: 192.168.1.19:9123 and :http://192.168.1.19:9123/StartupConnect/
2023-08-16 16:19:56,409 DEBUG [0] [1] MainWindow - --------Response Status Received:{'COMMAND': '', 'COMMAND2': '', 'COMMAND3': '', 'COMMAND4': ''}
2023-08-16 16:19:56,409 DEBUG [0] [1] MainWindow - --------Headers Recevied:IndigoPluginVersion: 0.10.15
IPAddress: 192.168.1.46
Content-Type: text/html
Date: Wed, 16 Aug 2023 06:19:55 GMT
Server: BaseHTTP/0.6 Python/3.10.2
2023-08-16 16:19:56,411 DEBUG [0] [1] MainWindow - -------- Version Received:0.10.15
2023-08-16 16:19:56,411 DEBUG [0] [1] MainWindow - -------- Current App Version:16
2023-08-16 16:19:56,412 DEBUG [0] [1] MainWindow - ---------- Last Digit Version Equals:15
2023-08-16 16:19:56,412 INFO [0] [1] MainWindow - Received this response from server:{'COMMAND': '', 'COMMAND2': '', 'COMMAND3': '', 'COMMAND4': ''}
2023-08-16 16:19:57,057 INFO [0] [1] MainWindow - Received Response:
2023-08-16 16:19:57,077 INFO [0] [1] MainWindow - Connection Successful
2023-08-16 16:19:58,122 INFO [0] [1] MainWindow - SaveSettings Called


& then after a very short period of time a update from Indigo --> Windows PC, like this
Code: Select all
2023-08-16 16:20:02,889 DEBUG [0] [1] App - Hostname set to:         Msk-MainPC
2023-08-16 16:20:02,910 DEBUG [0] [1] App - CPU Usage set to:         0%
2023-08-16 16:20:02,912 DEBUG [0] [1] App - Memory Available set to:      21617MB
2023-08-16 16:20:02,924 DEBUG [0] [1] App - Foreground App Set to:         SpaceXRemoteMain
2023-08-16 16:20:02,925 DEBUG [0] [1] App - IdleTime: IdleTime Seconds:      2
2023-08-16 16:20:02,925 DEBUG [0] [1] App - IdleTime: Minutes:         0
2023-08-16 16:20:02,926 DEBUG [0] [1] App - Username Returned as:         @e
2023-08-16 16:20:02,926 DEBUG [0] [1] App - upTime Before Truncate =      6.91266472222222
2023-08-16 16:20:02,926 DEBUG [0] [1] App - upTime: GetTickCount64 used, equals:   24885593
2023-08-16 16:20:02,928 DEBUG [0] [1] App - upTime =            6.913
2023-08-16 16:20:02,929 DEBUG [0] [1] App - SendInfotoIndigo Called.
2023-08-16 16:20:02,938 DEBUG [0] [1] App - :: Response Status Received:      {'COMMAND': '', 'COMMAND2': '', 'COMMAND3': '', 'COMMAND4': ''}
2023-08-16 16:20:02,944 DEBUG [0] [1] App - Information sent to Indigo....
2023-08-16 16:20:02,945 DEBUG [0] [1] App - :: Response from Server:   
2023-08-16 16:20:02,951 DEBUG [0] [1] App - checkCommand Called with data:{'COMMAND': '', 'COMMAND2': '', 'COMMAND3': '', 'COMMAND4': ''}
2023-08-16 16:20:03,081 DEBUG [0] [1] App - :: Received Command: Json: COMMAND:   COMMAND2:   COMMAND3:   COMMAND4
2023-08-16 16:20:03,081 DEBUG [0] [1] App - No COMMAND found exiting checkCommands


There was a updated Indigo Plugin 0.10.15, the python3 fork - which I hadn't released, have now:
Its here:

Along with an updated Windows PC installer (change my odd colour scheme, and few library updates)
https://github.com/Ghawken/IndigoPlugin ... e/releases

If commands are not working - check the debug logging of Windows Program - will show what is being received.
& Check have disabled command sending in the Windows Config Setting
"Disable Process Commands"

Posted on
Wed Aug 16, 2023 8:15 am
durosity offline
User avatar
Posts: 4375
Joined: May 10, 2012
Location: Newcastle Upon Tyne, Ye Ol' England.

Re: Error when loading plugin on windows system

Aha yes the new release has fixed the connection issue, and it’s all behaving itself as expected! I’m excited for the options this will afford me!


Sent from my iPhone using Tapatalk Pro

Computer says no.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest