Issues with 7.2.7 to 7.3.0 upgrade

Posted on
Wed Jul 22, 2020 8:12 am
gt3mike offline
Posts: 158
Joined: Dec 31, 2017
Location: Colorado

Issues with 7.2.7 to 7.3.0 upgrade

Upgraded a well-functioning 7.2.7 plugin to 7.3 and experienced a couple of issues. Let me know if I should raise any of this as an issue in Github.

The upgrade started OK.

Jul 22, 2020 at 7:24:44 AM
Stopping plugin Lutron RRA2/Caséta (pid 843)
Lutron RRA2/Caséta Shutting down Lutron
Stopped plugin Lutron RRA2/Caséta
Upgrading plugin Lutron RRA2/Caséta to newer version 7.3.0 (previous version moved to trash)
Loading plugin "Lutron RRA2/Caséta 7.3.0"
Starting plugin "Lutron RRA2/Caséta 7.3.0" (pid 4093)
Started plugin "Lutron RRA2/Caséta 7.3.0"
Lutron RRA2/Caséta Starting up Lutron
Lutron RRA2/Caséta Converting to multiple gateway system
Lutron RRA2/Caséta Creating new IP Gateway device @ 192.168.0.4:23
Lutron RRA2/Caséta IP Gateway device complete
Lutron RRA2/Caséta Basement - Basement Keypad - Button 023.02 - On: Added Gateway property
Lutron RRA2/Caséta Basement - Basement Keypad - Button 023.04 - Off: Added Gateway property
Lutron RRA2/Caséta Basement - Motion Sensor 77: Added Gateway property
Lutron RRA2/Caséta Basement - Switch 71 - Basement Main Lights: Added Gateway property
Lutron RRA2/Caséta Basement - Switch 73 - Basement Perimeter Lights: Added Gateway property

(snippng pages of added gateway property messages)

Lutron RRA2/Caséta Master Closet - Dimmer 34 - Ceiling Light: Added Gateway property
Lutron RRA2/Caséta Master Closet - Motion Sensor 62: Added Gateway property
Lutron RRA2/Caséta Office Lights: Added Gateway property
Lutron RRA2/Caséta Welcome Home Button: Added Gateway property


Then this happened

Lutron RRA2/Caséta Error keypadButtonPress Trigger House Off - Exit Lights if dark (1224547049) missing buttonID: com.jimandnoreen.indigoplugin.lutron-radiora2 : (dict)
componentID : 5 (string)
deviceID : 3 (string)
Lutron RRA2/Caséta Error keypadButtonPress Trigger House Off - Exit Lights if not dark (1738087678) missing buttonID: com.jimandnoreen.indigoplugin.lutron-radiora2 : (dict)
componentID : 5 (string)
deviceID : 3 (string)
Lutron RRA2/Caséta Error keypadButtonPress Trigger House Off - Master Bedroom Fan Off (425977963) missing buttonID: com.jimandnoreen.indigoplugin.lutron-radiora2 : (dict)
componentID : 5 (string)
deviceID : 3 (string)


Startup finished, and then I got an error

Lutron RRA2/Caséta Lutron IP Gateway: Running IP Start
Lutron RRA2/Caséta Lutron IP Gateway: Connecting via IP to 192.168.0.4:23

Jul 22, 2020 at 7:30:05 AM
Lutron RRA2/Caséta Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 1922, in sendRawCommand
KeyError: key gateway not found in dict


At this point the Indigo Client became unresponsive and began hogging CPU, so I killed it

Indigo Cocoa client disconnected
Indigo Cocoa client connected


It was still hogging CPU, so I restarted the plugin. It didn't stop smoothly, and the "missing buttonid messages are sill there.

Jul 22, 2020 at 7:35:10 AM
Disabling plugin "Lutron RRA2/Caséta 7.3.0"
Stopping plugin "Lutron RRA2/Caséta 7.3.0" (pid 4093)

Jul 22, 2020 at 7:35:25 AM
Error process (pid 4093) failed to quit after polite request -- forcing it to quit now
Stopped plugin "Lutron RRA2/Caséta 7.3.0"


Jul 22, 2020 at 7:35:44 AM
Enabling plugin "Lutron RRA2/Caséta 7.3.0"
Starting plugin "Lutron RRA2/Caséta 7.3.0" (pid 4184)
Started plugin "Lutron RRA2/Caséta 7.3.0"
Lutron RRA2/Caséta Starting up Lutron
Lutron RRA2/Caséta Lutron IP Gateway: Running IP Start
Lutron RRA2/Caséta Lutron IP Gateway: Connecting via IP to 192.168.0.4:23
Lutron RRA2/Caséta Error keypadButtonPress Trigger House Off - Exit Lights if dark (1224547049) missing buttonID: com.jimandnoreen.indigoplugin.lutron-radiora2 : (dict)
componentID : 5 (string)
deviceID : 3 (string)
Lutron RRA2/Caséta Error keypadButtonPress Trigger House Off - Exit Lights if not dark (1738087678) missing buttonID: com.jimandnoreen.indigoplugin.lutron-radiora2 : (dict)
componentID : 5 (string)
deviceID : 3 (string)
Lutron RRA2/Caséta Error keypadButtonPress Trigger House Off - Master Bedroom Fan Off (425977963) missing buttonID: com.jimandnoreen.indigoplugin.lutron-radiora2 : (dict)
componentID : 5 (string)
deviceID : 3 (string)


Plugin seems to be working - I tried a couple of things that would fire triggers and they worked.

Jul 22, 2020 at 7:37:59 AM
Trigger Master Bath Sink On
Trigger Master Bath Shower On

Jul 22, 2020 at 7:38:18 AM
Trigger MBR Suite Off - Fan Off
Trigger Master Bath Shower Off


Then I started getting these errors every 10 minutes. These are continuing

Jul 22, 2020 at 7:40:00 AM
Lutron RRA2/Caséta Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 1922, in sendRawCommand
KeyError: key gateway not found in dict


Jul 22, 2020 at 7:50:00 AM
Lutron RRA2/Caséta Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 1922, in sendRawCommand
KeyError: key gateway not found in dict


Jul 22, 2020 at 8:00:00 AM
Lutron RRA2/Caséta Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 1922, in sendRawCommand
KeyError: key gateway not found in dict


Also just got this one. Don't know what is causing this one either.

Jul 22, 2020 at 8:00:31 AM
Lutron RRA2/Caséta Error Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
File "plugin.py", line 1050, in runConcurrentThread
File "plugin.py", line 1094, in _processCommand
File "plugin.py", line 1233, in _cmdDeviceChange
IndexError: list index out of range

Lutron RRA2/Caséta Error plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)


Any suggestions on any of this? Please let me know if you'd like me to log any of it in GitHub. .

Posted on
Wed Jul 22, 2020 8:36 am
FlyingDiver offline
User avatar
Posts: 4303
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Issues with 7.2.7 to 7.3.0 upgrade

Looks like there's some issues with triggers not getting updated properly. Edit all your (Lutron plugin) triggers and make sure they're configured correctly. Then restart the plugin and see what new errors you get. Let me know what kinds of triggers had issues. I'm not sure the plugin can change existing triggers, so that might have to remain a manual correction.

Same for any schedules or action groups that execute Lutron plugin actions. They need to be updated too.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Jul 22, 2020 8:38 am
gt3mike offline
Posts: 158
Joined: Dec 31, 2017
Location: Colorado

Re: Issues with 7.2.7 to 7.3.0 upgrade

I went in and added back the button to the three broken triggers. I got an error when I saved them, but now the plugin stops and starts up cleanly.

Interestingly, the second and third press triggers for that particular button were correctly tied to the button. It is just the first press triggers that lost their linkage to that button.

Also, this is the only button device that experienced this issue. I can tell from the name of the button device that it was created a long time ago, before the versions of the plugin that automatically created devices. So it is entirely possible that there was a problem with the setup of this button and/or the trigger that happened a long time ago.

Posted on
Wed Jul 22, 2020 8:43 am
gt3mike offline
Posts: 158
Joined: Dec 31, 2017
Location: Colorado

Re: Issues with 7.2.7 to 7.3.0 upgrade

Just got this error. Not sure of the frequency yet. Hard to tell what device/trigger/etc this is related to..

Jul 22, 2020 at 8:40:00 AM
Lutron RRA2/Caséta Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 1922, in sendRawCommand
KeyError: key gateway not found in dict

Posted on
Wed Jul 22, 2020 8:54 am
gt3mike offline
Posts: 158
Joined: Dec 31, 2017
Location: Colorado

Re: Issues with 7.2.7 to 7.3.0 upgrade

Update - the "gateway not found in dict" error is happening every 10 minutes.

Posted on
Wed Jul 22, 2020 8:55 am
FlyingDiver offline
User avatar
Posts: 4303
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Issues with 7.2.7 to 7.3.0 upgrade

You've got a scheduled event sending a raw command every 10 minutes, I think. Well, doing some kind of command, which eventually goes through that routine.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Jul 22, 2020 9:04 am
gt3mike offline
Posts: 158
Joined: Dec 31, 2017
Location: Colorado

Re: Issues with 7.2.7 to 7.3.0 upgrade

I'll take a look.

It looks like none of my RR2 keypad button press triggers have a gateway identified. Should they? The triggers seem to be working fine without it.

Posted on
Wed Jul 22, 2020 9:05 am
FlyingDiver offline
User avatar
Posts: 4303
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Issues with 7.2.7 to 7.3.0 upgrade

gt3mike wrote:
I'll take a look.

It looks like none of my RR2 keypad button press triggers have a gateway identified. Should they? The triggers seem to be working fine without it.


It's probably triggering on any matching button from any gateway. Specifying the correct gateway would be a good thing.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Jul 22, 2020 9:10 am
gt3mike offline
Posts: 158
Joined: Dec 31, 2017
Location: Colorado

Re: Issues with 7.2.7 to 7.3.0 upgrade

FlyingDiver wrote:
You've got a scheduled event sending a raw command every 10 minutes, I think. Well, doing some kind of command, which eventually goes through that routine.

Interesting. It looks like I have a very old (Jan 2018) scheduled action called Lutron Heartbeat. The action is to send a raw command of "?TIMECLOCK,17,2" and the gateway property isn't populated. I'm guessing that's what's causing it.

I may have been having trouble with the connection dropping at the time. If I search, I'll probably find a post about it in this forum. :) I wonder if I still need it?

Posted on
Wed Jul 22, 2020 9:14 am
FlyingDiver offline
User avatar
Posts: 4303
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Issues with 7.2.7 to 7.3.0 upgrade

Action 2 is "Get Sunrise Time". But if you're not using the return value somehow, I don't see the point.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Jul 22, 2020 9:21 am
gt3mike offline
Posts: 158
Joined: Dec 31, 2017
Location: Colorado

Re: Issues with 7.2.7 to 7.3.0 upgrade


Posted on
Thu Jul 23, 2020 9:51 am
gt3mike offline
Posts: 158
Joined: Dec 31, 2017
Location: Colorado

Re: Issues with 7.2.7 to 7.3.0 upgrade

Here's another new error:

Jul 23, 2020 at 9:24:11 AM
Error device "Group 006 - Master Closet" state key onOffState not defined (ignoring update request)


This closet has a dimmer and an occupancy/vacancy sensor that turns the dimmer on and off. Indigo knows about them, but it doesn't do anything with them other than monitor their status. The Indigo devices were both automatically created by an earlier version of the plugin, and they both seem to be properly configured (including gateways).

Any idea what this is about?

Posted on
Thu Jul 23, 2020 10:30 am
FlyingDiver offline
User avatar
Posts: 4303
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Issues with 7.2.7 to 7.3.0 upgrade

Hmm. The auto-create process creates "room group" devices as well as the sensor devices. These devices are used when you have multiple occupancy sensors in the same room/area where they're all to be handled as one virtual sensor. Are you attempting to set the status state of those devices? If it's at all reproducible, then turning on debug logging for that event would be useful.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Jul 23, 2020 10:40 am
gt3mike offline
Posts: 158
Joined: Dec 31, 2017
Location: Colorado

Re: Issues with 7.2.7 to 7.3.0 upgrade

I don't do anything with the sensor, dimmer, or room group in Indigo. They are only there because they were auto created (which I'm not complaining about - auto create is great).

I bumped up the log level and walked into the closet. Here's the output.

Code: Select all
Jul 23, 2020 at 10:33:57 AM
   Lutron RRA2/Caséta Debug       New logLevel = 5

Jul 23, 2020 at 10:34:33 AM
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: 30 characters read:
~DEVICE,62,2,3
~GROUP,6,3,3

   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = 'GNET> ~DEVICE,62,2,3
~GROUP,6,3,3
'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: msg = 'GNET> ~DEVICE,62,2,3
'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = '~GROUP,6,3,3
'
   Lutron RRA2/Caséta Threaddebug Received command: GNET> ~DEVICE,62,2,3 from Gateway 1882186919
   Lutron RRA2/Caséta Threaddebug Received a Device message: GNET> ~DEVICE,62,2,3
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: 50 characters read:
~OUTPUT,34,1,100.00
~OUTPUT,34,29,10
~OUTPUT,34,
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = '~GROUP,6,3,3
~OUTPUT,34,1,100.00
~OUTPUT,34,29,10
~OUTPUT,34,'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: msg = '~GROUP,6,3,3
'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = '~OUTPUT,34,1,100.00
~OUTPUT,34,29,10
~OUTPUT,34,'
   Lutron RRA2/Caséta Threaddebug Received command: ~GROUP,6,3,3 from Gateway 1882186919
   Lutron RRA2/Caséta Debug       Received a Group message:  ~GROUP,6,3,3
   Lutron RRA2/Caséta Debug       groupTriggerCheck: group: 6, gateway: 1882186919, status: 3
[color=#FF0000]   Error                           device "Group 006 - Master Closet" state key onOffState not defined (ignoring update request)
[/color]   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: 13 characters read:
30,1,100.00

   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = '~OUTPUT,34,1,100.00
~OUTPUT,34,29,10
~OUTPUT,34,30,1,100.00
'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: msg = '~OUTPUT,34,1,100.00
'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = '~OUTPUT,34,29,10
~OUTPUT,34,30,1,100.00
'
   Lutron RRA2/Caséta Threaddebug Received command: ~OUTPUT,34,1,100.00 from Gateway 1882186919
   Lutron RRA2/Caséta Threaddebug Received an Output message: ~OUTPUT,34,1,100.00
   Lutron RRA2/Caséta Debug       Received: Dimmer Master Closet - Dimmer 34 - Ceiling Light level set to 100.0
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = '~OUTPUT,34,29,10
~OUTPUT,34,30,1,100.00
'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: msg = '~OUTPUT,34,29,10
'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = '~OUTPUT,34,30,1,100.00
'
   Lutron RRA2/Caséta Threaddebug Received command: ~OUTPUT,34,29,10 from Gateway 1882186919
   Lutron RRA2/Caséta Threaddebug Received an Output message: ~OUTPUT,34,29,10
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = '~OUTPUT,34,30,1,100.00
'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: msg = '~OUTPUT,34,30,1,100.00
'
   Lutron RRA2/Caséta Threaddebug Lutron IP Gateway: self.buffer = ''
   Lutron RRA2/Caséta Threaddebug Received command: ~OUTPUT,34,30,1,100.00 from Gateway 1882186919
   Lutron RRA2/Caséta Threaddebug Received an Output message: ~OUTPUT,34,30,1,100.00

Posted on
Thu Jul 23, 2020 10:43 am
FlyingDiver offline
User avatar
Posts: 4303
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Issues with 7.2.7 to 7.3.0 upgrade

OK, I'll look at that. In the mean time, just delete the groups since you're not using them.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Who is online

Users browsing this forum: No registered users and 0 guests