IndigoServer Using > 100% of CPU ???

Posted on
Thu Jul 16, 2020 8:52 am
SearchCz offline
Posts: 20
Joined: Sep 18, 2019

IndigoServer Using > 100% of CPU ???

I've been running Indigo on my Mac Mini(s) for a long time ... maybe 15 years now. Many software versions and more than one Mini. But I just experienced something new (and weird and undesirable) for the first time.

My Late 2014 Mac mini running indigo 7.4.1 on Mac OS 10.15.5 has been incredibly laggy lately. ( I do use it for other things ). Very frustrating, especially with delayed response to mouse movement and interaction. So I checked the activity monitor, and saw the CPU% for IndigoServer at 206% ! I stopped and restarted the server, and it is now at 7.7%. Any idea why it would climb so high, and what I can do to avoid this in the future.

I have 8 plugins running right now, so maybe I'll try deactivating any non-essentials to see if that helps.

Posted on
Thu Jul 16, 2020 9:19 am
matt (support) offline
Site Admin
User avatar
Posts: 20083
Joined: Jan 27, 2003
Location: Texas

Re: IndigoServer Using > 100% of CPU ???

Most of the time when this happens it is Indigo Server's internal email client either trying to send or receive/scan emails. If that is failing or not working correctly for some reason (ISP changed authentication rules, etc.), then the email client can spin off into the weeds and use 100% CPU. Do you see any email related errors in the Event Log and does the progress bar at the bottom-left of Main Window show it is trying to send or scan emails?

If this ends up being the issue then we recommend using the Better Email plugin. It uses python's email client instead which has proven to be more reliable.

Image

Posted on
Thu Jul 16, 2020 12:59 pm
SearchCz offline
Posts: 20
Joined: Sep 18, 2019

Re: IndigoServer Using > 100% of CPU ???

Checked the logs ... didn't see an email problem. But my Harmony Hub plugin was throwing errors left and right! Disabled & reloaded the plugin and everything seems fine now. 0.5% CPU, 35.7 MB memory. Nice and tidy.

Posted on
Thu Jul 16, 2020 2:44 pm
FlyingDiver offline
User avatar
Posts: 4308
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: IndigoServer Using > 100% of CPU ???

SearchCz wrote:
Checked the logs ... didn't see an email problem. But my Harmony Hub plugin was throwing errors left and right! Disabled & reloaded the plugin and everything seems fine now. 0.5% CPU, 35.7 MB memory. Nice and tidy.


If you have some log files showing the errors, please post them in the Harmony Hub forum so I can catch those errors.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Fri Jul 17, 2020 3:17 pm
SearchCz offline
Posts: 20
Joined: Sep 18, 2019

Re: IndigoServer Using > 100% of CPU ???

So, it happened again. Indigo Server using 207% CPU. No errors in the log. Next likely suspect?

Posted on
Fri Jul 17, 2020 3:58 pm
matt (support) offline
Site Admin
User avatar
Posts: 20083
Joined: Jan 27, 2003
Location: Texas

Re: IndigoServer Using > 100% of CPU ???

In the Activity Monitor are any other processes also showing high CPU (like a different Indigo plugin process)?

Image

Posted on
Fri Jul 17, 2020 8:56 pm
SearchCz offline
Posts: 20
Joined: Sep 18, 2019

Re: IndigoServer Using > 100% of CPU ???

No sir, but ... my HomeKit bridge plugin crapped out again and had to be “repaired”. Also had to remove that bridge from my homekit setup, add it back in, and place all my devices Into their respective rooms.

Indigo serverCPU usage currently at. 0.5%.

8 instances of IndigoPluginHost running at between 0.1 and 1.7 percent CPU.

I have 5 plugins activated, so I’m guessing the other 3 are For core services like email?

My active plugins:
* Harmony Hub
* HomeKit Bridge
* Hue Lights
* MyQ
* NOAA Weather

Posted on
Sat Jul 18, 2020 12:02 am
matt (support) offline
Site Admin
User avatar
Posts: 20083
Joined: Jan 27, 2003
Location: Texas

Re: IndigoServer Using > 100% of CPU ???

Not email, but yes there are some internal plugins Indigo runs.

Image

Posted on
Mon Jul 20, 2020 10:50 am
SearchCz offline
Posts: 20
Joined: Sep 18, 2019

Re: IndigoServer Using > 100% of CPU ???

Today I noticed the IndigoServer process climbing from107% to 150% to 205% ... then back to 0.5% all on its own.

Posted on
Mon Jul 20, 2020 11:11 am
matt (support) offline
Site Admin
User avatar
Posts: 20083
Joined: Jan 27, 2003
Location: Texas

Re: IndigoServer Using > 100% of CPU ???

Brief runs up to high CPU utilization are normal. How long was it pegged at 200%+?

Image

Posted on
Mon Jul 20, 2020 2:01 pm
SearchCz offline
Posts: 20
Joined: Sep 18, 2019

Re: IndigoServer Using > 100% of CPU ???

less than a minute I would guess. it was brief.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests