Not deleting message after processing

Posted on
Mon Jun 29, 2020 3:28 pm
ryanbuckner offline
Posts: 330
Joined: Oct 08, 2011

Not deleting message after processing

I'm using POP gmail with SSL successfully but when it processes the message it is not marked as read or deleted as set in the options.

Here's the log:


This is me unchecking and rechecking the Delete option in the config -

Code: Select all
Jun 29, 2020 at 5:19:13 PM
   Better Email Threaddebug        getDeviceConfigUiValues: no change, already populated
   Better Email Debug              validateDeviceConfigUi
   Better Email Debug              Better Email POP: Stopping device
   Better Email Debug              Better Email POP: shutting down
   Better Email Threaddebug        Better Email POP: Device Version is up to date
   Better Email Debug              Better Email POP: Starting device (popAccount)
   Better Email Debug              Better Email POP: Connecting to POP Server
   Better Email Debug              :Better Email POP No messages to process
   Better Email Debug              Better Email POP: Logged out from POP server
   Better Email Threaddebug        getDeviceConfigUiValues: no change, already populated
   Better Email Debug              validateDeviceConfigUi
   Better Email Debug              Better Email POP: Stopping device
   Better Email Debug              Better Email POP: shutting down
   Better Email Threaddebug        Better Email POP: Device Version is up to date
   Better Email Debug              Better Email POP: Starting device (popAccount)
   Better Email Debug              Better Email POP: Connecting to POP Server
   Better Email Debug              :Better Email POP No messages to process
   Better Email Debug              Better Email POP: Logged out from POP server


Code: Select all
Jun 29, 2020 at 5:24:19 PM
   Better Email Debug              Better Email POP: Connecting to POP Server
   Better Email Debug              Better Email POP: Fetching Message # 1
   Better Email Debug              Better Email POP: Parsing message GmailId17301f5635674eb9
   Better Email Debug              Better Email POP: Received Message Subject:
   Better Email Debug              Better Email POP: Received Message From:
   Better Email Debug              Better Email POP: Received Message To:
   Better Email Debug              Better Email POP: Received Message Date:
   Better Email Threaddebug        Better Email POP: checkMsgs: Decoding multipart message
   Better Email Threaddebug           found type: multipart/alternative
   Better Email Threaddebug           found type: text/plain
   Better Email Threaddebug        Better Email POP: checkMsgs: Updating states on server: [{'value': '"Buckner, Ryan" <ryanbuckner@gmail.com>', 'key': 'messageFrom'}, {'value': '"indigobucknerpop@gmail.com" <indigobucknerpop@gmail.com>', 'key': 'messageTo'}, {'value': 'REMOVED FOR PRIVACY', 'key': 'messageText'}, {'value': 'GmailId17301f5635674eb9', 'key': 'lastMessage'}]
   Better Email Debug              triggerCheck: Checking Triggers for Device Better Email POP (131015986)
   Better Email Debug                 Checking Trigger Health Declaration Email Scan (1013203776), stringMatch
   Better Email Debug                    Checking Device State messageFrom for string: "Buckner, Ryan" <ryanbuckner@gmail.com>
   Better Email Debug                    Executing Trigger Health Declaration Email Scan (1013203776)
Last edited by ryanbuckner on Mon Jun 29, 2020 3:36 pm, edited 1 time in total.

Posted on
Mon Jun 29, 2020 3:32 pm
FlyingDiver offline
User avatar
Posts: 4260
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Not marking message as read (or deleting)

What happens the next time you scan? Does it trigger again? Post screen shot of device config dialog.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Jun 29, 2020 7:51 pm
ryanbuckner offline
Posts: 330
Joined: Oct 08, 2011

Re: Not deleting message after processing

Next time it runs it ignores the email.

Here's the config:
Attachments
Screen Shot 2020-06-29 at 9.50.33 PM.png
Screen Shot 2020-06-29 at 9.50.33 PM.png (177.75 KiB) Viewed 229 times

Posted on
Mon Jun 29, 2020 7:54 pm
FlyingDiver offline
User avatar
Posts: 4260
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Not deleting message after processing

ryanbuckner wrote:
Next time it runs it ignores the email.

Here's the config:


That's what I would have expected if you didn't have the delete option selected. Did you change that after the first time it was scanned? If it was already read once, it won't process it at all, so it won't get deleted.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Mon Jun 29, 2020 8:14 pm
ryanbuckner offline
Posts: 330
Joined: Oct 08, 2011

Re: Not deleting message after processing

The delete option has always been selected. I toggled it off --> on to show in the log.

Posted on
Mon Jun 29, 2020 8:44 pm
FlyingDiver offline
User avatar
Posts: 4260
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Not deleting message after processing

ryanbuckner wrote:
The delete option has always been selected. I toggled it off --> on to show in the log.


So it's always acted this way? I've tested this before, but never with POP on Gmail. Gmail is weird. Have you tried using IMAP instead of POP?

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Jun 30, 2020 5:37 am
ryanbuckner offline
Posts: 330
Joined: Oct 08, 2011

Re: Not deleting message after processing

This was my first install of the plugin, so it's new to me. I can try IMAP and let you know.

Posted on
Tue Jun 30, 2020 5:39 am
FlyingDiver offline
User avatar
Posts: 4260
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Not deleting message after processing

In general, I don't recommend Gmail for use with this plugin. Google doesn't use standard IMAP or POP servers - their mail storage is proprietary and uses custom software for the IMAP and POP interface.

It mostly works, but it's just wonky some times.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests