Updates not working token not renewing

Posted on
Mon Jun 29, 2020 4:17 am
mat offline
Posts: 768
Joined: Nov 25, 2010
Location: Cambridgeshire - UK

Updates not working token not renewing

Morning,

Noticed a couple of days ago that indigo not updating status of my car. Deleted and reinstalled from store, deleted pref file but still getting the following error. Has anyone seen this before and know a fix please?

Thanks

Mat

Code: Select all
   Tesla EV Control                Fetching vehicles...
   Tesla EV Control Debug          Token expired - renewing oauth token for 44 days...
   Tesla EV Control Debug          Pre-JSON: {"response":"authorization_required_for_txid_`7dae98f7938a12bb2772c4fed6fc078c`"}
   Tesla EV Control Error          'created_at'
   Tesla EV Control Error          Error creating connection
   Tesla EV Control Error          Plugin version: 1.0.19
   Tesla EV Control Debug          Traceback (most recent call last):
  File "plugin.py", line 139, in getVehicles
    connection = teslajson.Connection(self.pluginPrefs['username'],self.pluginPrefs['password'])
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Tesla Control.indigoPlugin/Contents/Server Plugin/teslajson.py", line 68, in __init__
    treply = self.get('vehicles')
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Tesla Control.indigoPlugin/Contents/Server Plugin/teslajson.py", line 74, in get
    return self.post(command, None)
  File "/Library/Application Support/Perceptive Automation/Indigo 7.4/Plugins/Tesla Control.indigoPlugin/Contents/Server Plugin/teslajson.py", line 82, in post
    self.expiration = auth['created_at'] + auth['expires_in'] - 86400  #45 days minus 24 hours
KeyError: 'created_at'

   Tesla EV Control Error          Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 435, in runConcurrentThread
  File "plugin.py", line 146, in getVehicles
UnboundLocalError: local variable 'connection' referenced before assignment

   Tesla EV Control Error          plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)

Late 2018 mini 10.14

Posted on
Mon Jul 06, 2020 12:51 am
mat offline
Posts: 768
Joined: Nov 25, 2010
Location: Cambridgeshire - UK

Re: Updates not working token not renewing

Doh, wrong password

Late 2018 mini 10.14

Posted on
Sat Jul 11, 2020 2:49 am
howartp offline
Posts: 4243
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Updates not working token not renewing

mat wrote:
Doh, wrong password

Excellent, that's the kind of error I like fixing!

I came to reply saying I'll look at this tonight!

Peter

Posted on
Mon Jul 27, 2020 5:11 pm
rjds offline
Posts: 5
Joined: Jul 24, 2020

Re: Updates not working token not renewing

This started happening on 7/23 after reboot

2020-07-27 17:18:35.902 Tesla EV Control Error plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
2020-07-27 17:18:45.903 Tesla EV Control Fetching vehicles...
2020-07-27 17:18:47.083 Tesla EV Control Error <urlopen error [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:590)>
2020-07-27 17:18:47.085 Tesla EV Control Error Error creating connection
2020-07-27 17:18:47.085 Tesla EV Control Error Plugin version: 1.0.19
2020-07-27 17:18:47.086 Tesla EV Control Error Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
File "plugin.py", line 435, in runConcurrentThread
File "plugin.py", line 146, in getVehicles
UnboundLocalError: local variable 'connection' referenced before assignment

Posted on
Tue Jul 28, 2020 1:32 am
howartp offline
Posts: 4243
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Updates not working token not renewing

Good morning.

I presume you’ve checked your password is still correct and working as above?

Peter


Sent from my iPhone using Tapatalk Pro

Posted on
Wed Jul 29, 2020 10:09 am
rjds offline
Posts: 5
Joined: Jul 24, 2020

Re: Updates not working token not renewing

yeah username and password.

-removed the plug in
-reinstalled over blue iris over current install
-reinstalled plugin and reset username and password
same database

Posted on
Wed Jul 29, 2020 11:18 am
rjds offline
Posts: 5
Joined: Jul 24, 2020

Re: Updates not working token not renewing

i just restored a backup from 7/12 when that was still working and got this....

Started plugin "Tesla EV Control 1.0.19"
Tesla EV Control Fetching vehicles...
Waiting for external plugins to intialize
Tesla EV Control Error <urlopen error [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:590)>
Tesla EV Control Error Error creating connection
Tesla EV Control Error Plugin version: 1.0.19
Tesla EV Control Error Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
File "plugin.py", line 435, in runConcurrentThread
File "plugin.py", line 146, in getVehicles
UnboundLocalError: local variable 'connection' referenced before assignment

Posted on
Wed Jul 29, 2020 11:19 am
howartp offline
Posts: 4243
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Updates not working token not renewing

What OS are you on?


Sent from my iPhone using Tapatalk Pro

Posted on
Sat Aug 01, 2020 10:48 pm
jstewart30 offline
Posts: 15
Joined: Jul 03, 2014

Re: Updates not working token not renewing

Not to hijack the thread but I just wanted to echo that I'm getting the same error as @rjds, started a few days ago out of the blue. I'm running OS 10.12.6 if that helps. Nothing changed that I can think of between when it worked and when this started. Tried disabling and re-enabling the plugin with no improvement.

Tesla EV Control Error <urlopen error [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:590)>
Tesla EV Control Error Error creating connection
Tesla EV Control Error Plugin version: 1.0.19
Tesla EV Control Error Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
File "plugin.py", line 435, in runConcurrentThread
File "plugin.py", line 146, in getVehicles
UnboundLocalError: local variable 'connection' referenced before assignment

Tesla EV Control Error plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)

Posted on
Sun Aug 02, 2020 2:41 am
howartp offline
Posts: 4243
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Updates not working token not renewing

I have two plugins that this has started happening on at same time.

Both users are on Sierra which is known to not support the latest SSL protocols.

My suspicion is that Tesla and Verisure have turned off support for connecting with old versions of the SSL protocol, which therefore rules out connecting from anything less than High Sierra.

OR, an OSX update has turned off the old SSL protocol in Sierra as well.


Sent from my iPhone using Tapatalk Pro

Posted on
Sun Aug 02, 2020 7:16 pm
jstewart30 offline
Posts: 15
Joined: Jul 03, 2014

Re: Updates not working token not renewing

Yep, can confirm th the issue went away when I upgraded to High Sierra 10.13. Thanks!

Posted on
Sun Aug 02, 2020 9:33 pm
howartp offline
Posts: 4243
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Updates not working token not renewing

jstewart30 wrote:
Yep, can confirm th the issue went away when I upgraded to High Sierra 10.13. Thanks!

Great, thanks for reporting back!


Sent from my iPhone using Tapatalk Pro

Posted on
Wed Aug 05, 2020 1:50 pm
rjds offline
Posts: 5
Joined: Jul 24, 2020

Re: Updates not working token not renewing

Ill try that. I am on SIERRA

Posted on
Thu Aug 06, 2020 7:31 pm
rjds offline
Posts: 5
Joined: Jul 24, 2020

Re: Updates not working token not renewing

I can confimafter upgrading from SIERRA to Mojave IT WORKS!

Thanks!

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests

cron