About to dive in....

Posted on
Sat May 23, 2020 10:45 am
jalves offline
Posts: 592
Joined: Jun 16, 2013

About to dive in....

I'm about to dive into this plug-in. To be frank, I'm a bit confused with the installation instructions posted. I'm still relatively new to the Pi but have figured out a lot of stuff, including how to image an sd card (using Balencia on my Mac) , configuring the Pi to connect to my wifi, ssh, VNC, etc. Reading the instructions though I see a lot of stuff that sms to duplicate those efforts. That leaves me a bit confused about exactly what steps I need to do if I've already got a functioning Pi and just want to add the iBeacon.

My questions, please assume I'm using either a PiZeroW, or a Pi 4B if that matters and I'v set it up for SSH and VNC connections plus already established my location and wifi connections:
    Can I just start with a current rasberrian (Buster) OS already installed?
    If so, what packages (and from where) do I download the needed files to make the beacon function work?
    Are there any things that I have to watch for when taking this shortcut?

Running Indigo 7.4.1 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.6
Jeff

Posted on
Sat May 23, 2020 10:59 am
kw123 offline
User avatar
Posts: 7141
Joined: May 12, 2013
Location: Dallas, TX

Re: About to dive in....

1. I strongly recommend you download the preconfigured SSD posted on the pibeacon page
there is a section on how to make the SSD, if you use your own you will need to install a bunch of libs - described in how to ..SSD

2. you can set your wifi info on the preconfigured SSD so that the RPI auto connects to your Wifi, check the post for that

3. insert the ssd and start the RPI.
and find the IP# of the RPI

4. ssh to the PRI and set your password ( > passwd to set it) default is pibeacon and in sudo raspi-config set your timezone.
reboot

5. in the plugin
in config set basic parameters: userid of indigo, and allow new beacons, you can leave most at default
then in menu "initial setup of RPI .."
there you enter the IP# user id password of your RPI
save

The rest should be automatic

the plugin will maintain software versions on the RPI (not the OSS)
it will update configs etc on the RPI

if setup correctly you should see a lot of beacons pop up. - People that walk by w a tracker on their key etc..

Then you should switch off accept new beacons in config.

How to determine which is your beacon, see the discussion topic in pibeacon.

And I also strongly suggest to have at least 2 RPI that "see" each other = in range of bluetooth of each other

Basically follow post #,1,2,3,4,5,... in that sequence at https://forums.indigodomo.com/viewforum.php?f=187

Hope that helps.

Karl

Posted on
Sat May 23, 2020 11:15 am
jalves offline
Posts: 592
Joined: Jun 16, 2013

Re: About to dive in....

Thanks Karl. I'll give it a go.

Running Indigo 7.4.1 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.6
Jeff

Posted on
Sun Jun 07, 2020 10:00 am
jalves offline
Posts: 592
Joined: Jun 16, 2013

Re: About to dive in....

Sigh. Well I've tried following these instructions (and linked pages) as described and am failing badly.
    I've dowloaded the latest disk image from the PiBeacon 3 thread link. I unzipped that file as instructed and get the resulting "2020-02-25-pibeacon-buster.img" file

    Followed the instructions in the PiBeacon 2 thread to create the SSD. Carefully performed each step in number 1 on that page and all commands have executed properly with no errors reported.

    Inserted the resulting SSD card into my Pi (a 3B), connected it to the LAN with a cat5 cable, my monitor via HDMI, and to USB keyboard & mouse. Power on and I get the Standard Pi splash screen followed almost immediately by a kernel panic.
This leaves me unable to get any further. I've repeated the steps several times with different SSD cards, different Pi's, and even re-downloaded the image. All to no avail.

Running Indigo 7.4.1 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.6
Jeff

Posted on
Wed Jun 10, 2020 7:21 am
jalves offline
Posts: 592
Joined: Jun 16, 2013

Re: About to dive in....

Trying further trouble shooting on this, I've been able to get an earlier version of the SD card image to load on the pi but it never connects to the (wired) internet.

Running Indigo 7.4.1 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.6
Jeff

Posted on
Wed Jun 10, 2020 8:37 am
jalves offline
Posts: 592
Joined: Jun 16, 2013

Re: About to dive in....

Noticing that I seem to be having trouble properly formatting the SD card. I'm using Catalina (10.15.5) and when I execute the terminal command to format the sd card I get:
Code: Select all
Jeff1@yensid ~ % sudo newfs_msdos -F 16 /dev/disk6

newfs_msdos: warning: /dev/disk6 is not a character device
512 bytes per physical sector
newfs_msdos: warning: sectors/FAT limits sectors to 4194721, clusters to 65534
newfs_msdos: warning: FAT type limits file system to 4194144 sectors
/dev/disk6: 4193536 sectors in 65524 FAT16 clusters (32768 bytes/cluster)
bps=512 spc=64 res=1 nft=2 rde=512 mid=0xf0 spf=256 spt=32 hds=255 hid=0 drv=0x00 bsec=4194144
newfs_msdos: /dev/disk6: wipefs_wipe(): Input/output error
Jeff1@yensid ~ %


The notes say that this command can take as long as an hour, yet this completes(?) in just a few seconds.

Running Indigo 7.4.1 on a 27" iMac (mid-2017), 40G memory, 1T Fusion Drive, OS X 10.15.6
Jeff

Posted on
Thu Jun 11, 2020 7:53 am
kw123 offline
User avatar
Posts: 7141
Joined: May 12, 2013
Location: Dallas, TX

Re: About to dive in....

A) The comment about an hour is for the following statement.. copy to ssd.. if you use a USB3 and a fast SSD it can finish in ~5 minutes

B)the format statement takes ~ 5-30 secs

C) the error message >> /dev/disk6: wipefs_wipe(): Input/output error<<
- check if you have it on read only
- is disk 6 the right number?
- the ssd might be bad / cable might be bad ..

Thats what I would check

Karl

Page 1 of 1

Who is online

Users browsing this forum: Google [Bot] and 0 guests

cron