Better E-mail deleting all messages off server?

Posted on
Fri May 15, 2020 4:48 pm
guitarfreak offline
Posts: 10
Joined: Jan 17, 2017

Better E-mail deleting all messages off server?

So recently, I've noticed that all of my messages in my gmail inbox are being deleted, which I am using as the e-mail server for better e-mail. They're gone, poof, nowhere to be found in any email folder, deleted or otherwise. I'm not entirely sure that it is better e-mail causing the issue other than gmail support says that a 3rd party client could be the cause of the issue and BE is the only 3rd party client I'm using. Furthermore, I've noticed that in my log there is an error related to better e-mail which further leads me to suspect BE as the cause of the issue. Any help would be appreciated!
Attachments
Screenshot 2020-05-15 14.55.47.png
Screenshot 2020-05-15 14.55.47.png (43.48 KiB) Viewed 201 times

Posted on
Fri May 15, 2020 6:12 pm
FlyingDiver offline
User avatar
Posts: 4124
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Better E-mail deleting all messages off server?

You really shouldn't be using the same email address for Indigo as you use for your regular email. The plugin is for email specifically for Indigo, not for"you".

In any case, what the plugin does with the email that it's scanned is set in the device configuration dialog, as below. What are your settings?
Attachments
Screen Shot 2020-05-15 at 8.11.15 PM.png
Screen Shot 2020-05-15 at 8.11.15 PM.png (258.06 KiB) Viewed 185 times

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Fri May 15, 2020 6:12 pm
FlyingDiver offline
User avatar
Posts: 4124
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Better E-mail deleting all messages off server?

guitarfreak wrote:
Furthermore, I've noticed that in my log there is an error related to better e-mail which further leads me to suspect BE as the cause of the issue. Any help would be appreciated!


That error just means the connection was unexpectedly closed, not that there was an error processing the messages. If that's happening a lot, turn off IDLE processing and set an appropriate poll interval. I don't think Gmail does IDLE properly. In fact, I really recommend NOT using Gmail for the plugin as it's IMAP support is buggy.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Fri May 15, 2020 8:58 pm
guitarfreak offline
Posts: 10
Joined: Jan 17, 2017

Re: Better E-mail deleting all messages off server?

thank you for the help, it's not my primary e-mail address that I'm using, but a secondary G-mail one. I exhausted all of my other imap e-mails after not being able to get them to work so finally settled on gmail... which is working fine, other than this specific issue and the connection issue I mentioned.

It does appear it was set to delete all messages after processed so I've changed that setting which hopefully fixes the issue.

I'm unclear why you need to have an outgoing and incoming server for BE to work? I'm only using it to be able to e-mail notifications and have no current need for e-mail scanning but the plug-in requires it to be set up.

Posted on
Fri May 15, 2020 9:32 pm
FlyingDiver offline
User avatar
Posts: 4124
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Better E-mail deleting all messages off server?

guitarfreak wrote:
I'm unclear why you need to have an outgoing and incoming server for BE to work? I'm only using it to be able to e-mail notifications and have no current need for e-mail scanning but the plug-in requires it to be set up.


No, I don't think it does. You should be able to send using an SMTP Server device, and no need for an IMAP or POP device at all.

Are you getting an error when you send (using an SMTP device) when you don't have an IMAP device enabled? What's the error?

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sat May 16, 2020 5:48 am
guitarfreak offline
Posts: 10
Joined: Jan 17, 2017

Re: Better E-mail deleting all messages off server?

yes, when I originally set it up, I only set it up with an outgoing server device, but it wouldn't function and the documentation says that it requires both an ingoing and outgoing server...

Posted on
Sat May 16, 2020 6:52 am
FlyingDiver offline
User avatar
Posts: 4124
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Better E-mail deleting all messages off server?

guitarfreak wrote:
yes, when I originally set it up, I only set it up with an outgoing server device, but it wouldn't function and the documentation says that it requires both an ingoing and outgoing server...


The wiki says if you want to both send and receive, then you need both a sending device (SMTP) and a receiving device (IMAP or POP). If you only want to send, then you only need the SMTP device.

I just tested it with only an SMTP device enabled and it worked fine. If you are getting different results, please enable debug logging, attempt to send an email, and post the logs.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests