Can't "Comm Enable" a ZWave Device

Posted on
Mon Mar 23, 2020 8:39 pm
aldera offline
User avatar
Posts: 113
Joined: Aug 30, 2016
Location: Michigan, USA

Can't "Comm Enable" a ZWave Device

Hello,

I have a GE light switch that has been working well for years. In fact, I've never had a zwave device go bad in over 9 years. However, this particular switch has stopped working as a zwave device. I can physically turn it on/off at the switch itself. I've tried the following:

1. Removed and reset power to the switch.
2. Reloaded the ZWave Interface (Interfaces>>ZWave>>Reload).
3. Shutdown the server and restarted it.
4. Enable Indigo Communications - I can check/uncheck the checkbox on the "Edit Devices" screen (second graphic) I can't enable the "Comm Enabled" checkbox on the main Indigo screen. The device itself is grayed out on the main screen.
5. Tried to resync the device via the "Sync" screen. The "Sync using node" dropdown box is grayed out. (see first graphic)

I haven't tried excluding and including it. I don't want to redo all the triggers and control display pages if I can avoid it.

Are there any other things I could try first? Thank you for any input!
Attachments
pix2.jpg
Sync Device "window"
pix2.jpg (72.51 KiB) Viewed 138 times
pix1.jpg
Edit Device "window"
pix1.jpg (46.68 KiB) Viewed 138 times

Posted on
Tue Mar 24, 2020 9:25 am
jay (support) offline
Site Admin
User avatar
Posts: 16108
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Can't "Comm Enable" a ZWave Device

The selector being grayed out means that the node at ID 36 is no longer in the Z-Stick. Did you exclude it without re-including it?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Tue Mar 24, 2020 11:03 am
howartp offline
Posts: 3935
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Can't "Comm Enable" a ZWave Device

Excluding / including isn’t an issue - you don’t lose triggers etc.

Those are tied to the ‘device’ in Indigo, not to the node or physical instance.

Use Zwave > start inclusion and include it again so it gets a new node ID. Then edit your device as per the screenshot and pick the new node id instead of the missing node.


Sent from my iPhone using Tapatalk Pro

Posted on
Tue Mar 24, 2020 1:53 pm
aldera offline
User avatar
Posts: 113
Joined: Aug 30, 2016
Location: Michigan, USA

Re: Can't "Comm Enable" a ZWave Device

jay (support) wrote:
The selector being grayed out means that the node at ID 36 is no longer in the Z-Stick. Did you exclude it without re-including it?


I never excluded it. However, I was trying to exclude another device. I don't know how the switch ended up getting excluded unless the wife happened to hit the light switch at the same time that I was trying to exclude the other device. Very weird.

Posted on
Tue Mar 24, 2020 1:55 pm
aldera offline
User avatar
Posts: 113
Joined: Aug 30, 2016
Location: Michigan, USA

Re: Can't "Comm Enable" a ZWave Device

howartp wrote:
Excluding / including isn’t an issue - you don’t lose triggers etc.

Those are tied to the ‘device’ in Indigo, not to the node or physical instance.

Use Zwave > start inclusion and include it again so it gets a new node ID. Then edit your device as per the screenshot and pick the new node id instead of the missing node.


Thanks for the response. I did end up including it again and setting the new node to my old triggers and control pages. Thank again.

Ralph

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest