HomeSeer Leak Sensor (HS-LS100+) Tamper Detection Issue

Posted on
Tue Nov 19, 2019 10:03 am
hannt offline
Posts: 25
Joined: Jul 08, 2011

HomeSeer Leak Sensor (HS-LS100+) Tamper Detection Issue

Just purchased a HomeSeer Leak Sensor (HS-LS100+) to monitor for a water leak in our bonus room. The water detection function seems to be working as expected, but there appears to be an issue with tamper detection. Every time the device is moved (tampered with), Indigo reports a leak detected. I believe the Notification Type and/or Notification Event/State fields are being decoded incorrectly. Here are snippets from the log file:

Water Sensed:
Z-Wave received "Leak Sensor Bonus Room" status update is on
Z-Wave Watcher Debug Raw command received (Node 35): 01 0F 00 04 00 23 09 71 05 00 00 00 FF 05 02 00 52
Z-Wave Watcher Debug Raw command received (Node 35): 01 0A 00 04 00 23 04 30 03 FF 06 1C

Device Moved:
Z-Wave received "Leak Sensor Bonus Room" status update is on
Z-Wave Watcher Debug Raw command received (Node 35): 01 0F 00 04 00 23 09 71 05 00 00 00 FF 07 09 00 5B
Z-Wave Watcher Debug Raw command received (Node 35): 01 0A 00 04 00 23 04 30 03 FF 08 12

Here's what I believe to be the decode:

Water Sensed - 71 05 00 00 00 FF 05 02 00
    0x71 COMMAND_CLASS_NOTIFICATION
    0x05 NOTIFICATION_REPORT
    0x00 V1 Alarm Type (Not Implemented)
    0x00 V1 Alarm Level (Not Implemented)
    0x00 Reserved
    0xFF Notification Status (Unsolicited report is activated)
    0x05 Notification Type (Water Alarm)
    0x02 Notification Event / State (Water Leak Detected)

    0x00 (0 00 00000)
      0 Sequence (No “Sequence Number” field is appended after the “Event / State Parameter” field)
      00 Reserved
      00000 Event / State Parameters Length (0)

Water Sensed - 30 03 FF 06
    0x30 COMMAND_CLASS_SENSOR_BINARY
    0x03 SENSOR_BINARY_REPORT
    0XFF Sensor Value (Water Present)
    0X06 Sensor Report (Water)

Device Moved - 71 05 00 00 00 FF 07 09 00
    0x71 COMMAND_CLASS_NOTIFICATION
    0x05 NOTIFICATION_REPORT
    0x00 V1 Alarm Type (Not Implemented)
    0x00 V1 Alarm Level (Not Implemented)
    0x00 Reserved
    0xFF Notification Status (Unsolicited report is activated)
    0x07 Notification Type (Home Security)
    0x09 Notification Event / State (Tampering, product moved)

    0x00 (0 00 00000)
      0 Sequence (No “Sequence Number” field is appended after the “Event / State Parameter” field)
      00 Reserved
      00000 Event / State Parameters Length (0)

Device Moved - 30 03 FF 08
    0x30 COMMAND_CLASS_SENSOR_BINARY
    0x03 SENSOR_BINARY_REPORT
    0XFF Sensor Value (Device Tamper)
    0X08 Sensor Report (Tamper)

With the tamper function disabled (config parameter 18 with a value of 0), water detection still works as expected and tamper detection is in fact disabled. This is how I have it configured for now, but I would like to turn tamper detection back on at some point.

Thanks,

-Tommy

Posted on
Tue Nov 19, 2019 12:14 pm
Dual offline
Posts: 131
Joined: Feb 05, 2019

Re: HomeSeer Leak Sensor (HS-LS100+) Tamper Detection Issue

Same. I also disabled tamper. Even closing a cupboard door would set off the tamper for a detector under the sink.


Sent from my iPhone using Tapatalk

Posted on
Tue Nov 19, 2019 2:10 pm
matt (support) offline
Site Admin
User avatar
Posts: 19439
Joined: Jan 27, 2003
Location: Texas

Re: HomeSeer Leak Sensor (HS-LS100+) Tamper Detection Issue

Can you copy/paste Indigo's Event Log sync results for your LS100+? Based on the definition I believe it should be working correctly, so I wonder if the model ID on yours doesn't match Indigo's definition (thus the definition isn't being used).

Image

Posted on
Tue Nov 19, 2019 3:39 pm
hannt offline
Posts: 25
Joined: Jul 08, 2011

Re: HomeSeer Leak Sensor (HS-LS100+) Tamper Detection Issue

I forgot to mention that Indigo created both devices (Leak Sensor and Tamper) as expected.

Here are the sync results when I included it into the network:

Code: Select all
2019-11-18 14:49:19.022   Z-Wave   started controller inclusion mode
2019-11-18 14:49:25.872   Z-Wave   controller included module: 035 - Binary Sensor (routing)
2019-11-18 14:49:25.875   Z-Wave   stopped controller inclusion mode
2019-11-18 14:49:29.358   Z-Wave   Syncing - started for "035 - Binary Sensor (routing)"
2019-11-18 14:49:29.379   Z-Wave   Syncing - retrieved module neighbors list: 1, 2, 3, 4, 6, 7, 13, 14, 15, 16, 21, 24
2019-11-18 14:49:29.380   Z-Wave   Syncing - assigning return route to "035 - Binary Sensor (routing)"
2019-11-18 14:49:30.002   Z-Wave   Syncing - assigned return route
2019-11-18 14:49:30.596   Z-Wave   Syncing - retrieved manufacture and model names: HomeSeer - 000C, Leak Sensor (HS-LS100+) - 0201000A
2019-11-18 14:49:30.876   Z-Wave   Syncing - retrieved protocol version 4.61, app version 1.03
2019-11-18 14:49:31.447   Z-Wave   Syncing - retrieved class hierarchy: Routing Slave : Binary Sensor : Binary Sensor (routing) (04 : 20 : 01, base 30)
2019-11-18 14:49:31.448   Z-Wave   Syncing - retrieved command classes: 80v1 84v2 85v1 86v1 55v1 59v1 5Av1 5Ev1 9Fv1 20v1 70v1 71v1 6Cv1 30v1 31v5 72v1 73v1 7Av1
2019-11-18 14:49:31.448   Z-Wave   Syncing - retrieved encrypt commands: - none -
2019-11-18 14:49:31.448   Z-Wave   Syncing - retrieved capabilities: routing, battery, beaming, waking
2019-11-18 14:49:31.733   Z-Wave   Syncing - retrieved wake interval of 0 minutes
2019-11-18 14:49:31.763   Z-Wave   Syncing - device "035 - Binary Sensor (routing)" wake interval changed to 60 minutes
2019-11-18 14:49:32.333   Z-Wave   Syncing - retrieved group 1 associations: []
2019-11-18 14:49:32.618   Z-Wave   Syncing - retrieved group 2 associations: []
2019-11-18 14:49:32.901   Z-Wave   Syncing - added group 1 association to interface
2019-11-18 14:49:33.185   Z-Wave   Syncing - retrieved battery level of 100%
2019-11-18 14:49:33.435   Z-Wave   Syncing - created device "035 - Leak Sensor"
2019-11-18 14:49:33.455   Z-Wave   Syncing - created device "035 - Tamper"
2019-11-18 14:49:33.463   Z-Wave   Syncing - complete
2019-11-18 14:49:33.793   Z-Wave   sent "035 - Leak Sensor" status request
2019-11-18 14:49:34.077   Z-Wave   received "035 - Leak Sensor" status update battery level 100%
2019-11-18 14:49:34.361   Z-Wave   sent "035 - Tamper" status request
2019-11-18 14:49:40.536   Z-Wave   Indigo Device "035 - Leak Sensor" Z-Wave Properties:
Indigo Z-Wave Version: 7.4.0
Node ID: 35
Model: Leak Sensor (HS-LS100+)
Model ID: 0201000A
Manufacturer: HomeSeer
Manufacturer ID: 000C
Protocol Version: 4.61
Application Version: 1.03
Model Definition Version: 1
Library Type: 3
Class Name: Binary Sensor (routing)
Class Hierarchy: 04 : 20 : 01
Command Class Base: 30
Command Versions: 80v1 84v2 85v1 86v1 55v1 59v1 5Av1 5Ev1 9Fv1 20v1 70v1 71v1 6Cv1 30v1 31v5 72v1 73v1 7Av1
Encryption Status: Not Supported
Multi-Endpoint Types: - none -
Multi-Endpoint Classes: - none -
Multi-Instance Counts: - none -
Features: routing, battery, beaming, waking
Neighbors: 1, 2, 3, 4, 6, 7, 13, 14, 15, 16, 21, 24
Associations: 1:[1] 2:[]
Config Values: - none -

Posted on
Tue Nov 19, 2019 4:12 pm
matt (support) offline
Site Admin
User avatar
Posts: 19439
Joined: Jan 27, 2003
Location: Texas

Re: HomeSeer Leak Sensor (HS-LS100+) Tamper Detection Issue

Thanks – we'll have this working correctly in the next release (7.4.1).

Image

Posted on
Wed Nov 20, 2019 4:02 pm
hannt offline
Posts: 25
Joined: Jul 08, 2011

Re: HomeSeer Leak Sensor (HS-LS100+) Tamper Detection Issue

Thanks, Matt!

Posted on
Mon Dec 02, 2019 2:13 pm
hannt offline
Posts: 25
Joined: Jul 08, 2011

Re: HomeSeer Leak Sensor (HS-LS100+) Tamper Detection Issue

I found another issue with the same HomeSeer Leak Sensor. When creating and syncing the device in Indigo, 2 virtual devices were setup: a leak sensor and a tamper sensor. However, there are really 3 virtual sensors in this device where the third is a temperature sensor that measures the temperature of the water that may have leaked. I imagine this would help in determining if hot water is leaking or if cold water is leaking.

It seems that Indigo is ignoring the temperature reports. The following command repeated three times (or similar) was showing up periodically in the logs:

Code: Select all
Z-Wave Watcher Debug            Raw command received (Node 35): 01 0C 00 04 00 23 06 31 05 01 2A 02 3A F5
Z-Wave Watcher Debug            Raw command received (Node 35): 01 0C 00 04 00 23 06 31 05 01 2A 02 3A F5
Z-Wave Watcher Debug            Raw command received (Node 35): 01 0C 00 04 00 23 06 31 05 01 2A 02 3A F5

(No response or acknowledgement from server)

23 Node 35
06 Command is 6 bytes long
31 COMMAND_CLASS_SENSOR_MULTILEVEL
05 SENSOR_MULTILEVEL_REPORT
01 Sensor Type of Air temperature
2A (001 01 010)
   Precision 001: 1 Decimal Place
   Scale: 01: Fahrenheit (F)
   Size 010: 2 Bytes
023A  Value of 570 (57.0º F)

Yeah, we let it get kinda cold in the Bonus Room when it's not in use. :wink:

Thanks!

-Tommy

Posted on
Wed Dec 04, 2019 3:53 pm
matt (support) offline
Site Admin
User avatar
Posts: 19439
Joined: Jan 27, 2003
Location: Texas

Re: HomeSeer Leak Sensor (HS-LS100+) Tamper Detection Issue

Hi Tommy – Thanks, we'll look into adding that.

Image

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests