error messages in log

Posted on
Sat Sep 21, 2019 1:14 am
agame offline
Posts: 258
Joined: Jul 13, 2017
Location: Melbourne, Australia

error messages in log

I've been using the plugin with great success for a few months now (thanks!).

today my log is full of a repeating error message:

Code: Select all
Traceback (most recent call last):
  File "plugin.py", line 129, in runConcurrentThread
  File "plugin.py", line 351, in set_device_states
ValueError: invalid literal for int() with base 10: ''

   8 Channel Network Relay Error   plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   8 Channel Network Relay Error   Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 129, in runConcurrentThread
  File "plugin.py", line 351, in set_device_states
ValueError: invalid literal for int() with base 10: ''

   8 Channel Network Relay Error   plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   8 Channel Network Relay Error   Error in plugin execution runConcurrentThread:


but the relay does seem to be working!

everything has been totally stable from inception. ButI assume this was triggered after I made some config changes yesterday (remaming outputs, adding one relay and deleting another, correcting the relay number on another). I've noticed that adding a relay to an existing device group seems to be creating a new device group, rather than extending the exisiting one.

any ideas? I haven't tried deleting and recreating all the devices yet, I guess that is next.

Posted on
Sat Sep 21, 2019 5:56 pm
agame offline
Posts: 258
Joined: Jul 13, 2017
Location: Melbourne, Australia

Re: error messages in log

In the absence of any suggestions I've now deleted all the devices (didn't help); deleted and reinstalled the plugin and its preference file (didn't help), and tried to create a new device.

So a completely clean install of the plugin, even before devices are created, is generating the error message trail as above.

creating a new device generates the following additional error messages:


Code: Select all
Traceback (most recent call last):
  File "plugin.py", line 129, in runConcurrentThread
  File "plugin.py", line 351, in set_device_states
ValueError: invalid literal for int() with base 10: ''

   8 Channel Network Relay Error   plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Error (client)                  _sendClosedConfigUi3() caught exception: LowLevelBadParameterError
   8 Channel Network Relay Error   Error in plugin execution UiClosed3:

Traceback (most recent call last):
  File "plugin.py", line 119, in closedDeviceFactoryUi
  File "plugin.py", line 351, in set_device_states
ValueError: invalid literal for int() with base 10: ''

   8 Channel Network Relay Error   Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 129, in runConcurrentThread
  File "plugin.py", line 351, in set_device_states
ValueError: invalid literal for int() with base 10: ''

   8 Channel Network Relay Error   plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Error (client)                  doPluginDeviceFactory requires at least one root device
   8 Channel Network Relay Error   Error in plugin execution runConcurrentThread:


need some help!

Posted on
Sun Sep 22, 2019 4:51 am
agame offline
Posts: 258
Joined: Jul 13, 2017
Location: Melbourne, Australia

Re: error messages in log

Well problem solved...or at least worked around.
There was an old test device (sprinkler control) lurking that I hadn't deleted, once this was gone the errors also disappeared.

What the root cause was ... not sure.

now to rebuild all my linkages aaagh.

Posted on
Sun Sep 22, 2019 1:20 pm
TwitchCaptain offline
User avatar
Posts: 91
Joined: Dec 13, 2016
Location: San Francisco

Re: error messages in log

Glad you figured it out. I'll try to get some time on this codebase soon. It hasn't seen any love in a long time...

-captain

Posted on
Sun Sep 22, 2019 4:19 pm
agame offline
Posts: 258
Joined: Jul 13, 2017
Location: Melbourne, Australia

Re: error messages in log

no worries, thanks for responding.
and aside from this glitch the plugin has been tremendously useful, I've got 3 more relays in a drawer!

I have a feeling that the root cause has something to do with the way the plugin unexpectedly started spawning additional relays as 'freestanding' devices (ie/ not appearing on the tabs of the parent device I was editing) making it possible to delete the parent device unwittingly leaving an orphaned child. Could be completely wrong.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests