No pytz

Posted on
Fri Aug 30, 2019 5:37 pm
bjmouton offline
Posts: 19
Joined: Jul 23, 2017

Re: No pytz

Well, all that box does is run Indigo & it's been doing it for quite some time without any issues until now.
Know what they say about if it's not broken, don't fix it. I actually have been contemplating upgrading to a newest MAC Mini, so I suppose the time is finally right.
Hopefully all will go well once I get running with a new box.

I truly appreciate your quick responses & willingness to assist.

Posted on
Tue Sep 03, 2019 5:15 pm
bjmouton offline
Posts: 19
Joined: Jul 23, 2017

Re: No pytz

I have upgraded my home automation box. I am now able to launch the config box and enter my Twilio account info (copied & pasted field text from Twilio web page), but it is not accepting it. Any suggestions?
Attachments
Screen Shot 2019-09-03 at 18.03.32.png
Screen Shot 2019-09-03 at 18.03.32.png (39.43 KiB) Viewed 186 times
Screen Shot 2019-09-03 at 18.04.37.png
Screen Shot 2019-09-03 at 18.04.37.png (60.92 KiB) Viewed 186 times

Posted on
Tue Sep 03, 2019 5:57 pm
FlyingDiver offline
Posts: 3595
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: No pytz

Debug log please.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Sep 03, 2019 6:13 pm
bjmouton offline
Posts: 19
Joined: Jul 23, 2017

Re: No pytz

Code: Select all
Enabling plugin "Twilio 7.2.0"
   Starting plugin "Twilio 7.2.0" (pid 1258)
   Started plugin "Twilio 7.2.0"
   Twilio                          Starting Twilio
   Twilio Warning                  accountSID and/or authToken not set
   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Twilio Error                    Error in plugin execution UiValidate:

Traceback (most recent call last):
  File "plugin.py", line 155, in validatePrefsConfigUi
KeyError: key updateFrequency not found in dict

   Twilio Error                    Error in plugin execution UiValidate:

Traceback (most recent call last):
  File "plugin.py", line 155, in validatePrefsConfigUi
KeyError: key updateFrequency not found in dict

   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
   Twilio Error                    Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
  File "plugin.py", line 74, in runConcurrentThread
AttributeError: 'Plugin' object has no attribute 'twilioClient'

   Twilio Error                    plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)

Posted on
Tue Sep 03, 2019 6:21 pm
FlyingDiver offline
Posts: 3595
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: No pytz


joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Sep 03, 2019 6:39 pm
bjmouton offline
Posts: 19
Joined: Jul 23, 2017

Re: No pytz

SUCCESS!!

Thank you very much for your assistance & patience!

Billy

Posted on
Fri Sep 06, 2019 10:20 pm
bjmouton offline
Posts: 19
Joined: Jul 23, 2017

Re: No pytz

Worked OK for few days, then quit working for no apparent reason. Log capture :

Code: Select all
  Twilio Error                    Error in plugin execution ExecuteAction:

Traceback (most recent call last):
  File "plugin.py", line 256, in sendSMSAction
  File "plugin.py", line 265, in sendSMS
  File "/Library/Application Support/Perceptive Automation/Indigo 7.3/Plugins/Twilio.indigoPlugin/Contents/Server Plugin/twilio/rest/api/v2010/account/message/__init__.py", line 92, in create
  File "/Library/Application Support/Perceptive Automation/Indigo 7.3/Plugins/Twilio.indigoPlugin/Contents/Server Plugin/twilio/base/version.py", line 205, in create
  File "/Library/Application Support/Perceptive Automation/Indigo 7.3/Plugins/Twilio.indigoPlugin/Contents/Server Plugin/twilio/base/version.py", line 47, in request
  File "/Library/Application Support/Perceptive Automation/Indigo 7.3/Plugins/Twilio.indigoPlugin/Contents/Server Plugin/twilio/base/domain.py", line 46, in request
  File "/Library/Application Support/Perceptive Automation/Indigo 7.3/Plugins/Twilio.indigoPlugin/Contents/Server Plugin/twilio/rest/__init__.py", line 124, in request
  File "/Library/Application Support/Perceptive Automation/Indigo 7.3/Plugins/Twilio.indigoPlugin/Contents/Server Plugin/twilio/http/http_client.py", line 68, in request
  File "/Library/Application Support/Perceptive Automation/Indigo 7.3/IndigoPluginHost.app/Contents/Resources/PlugIns/requests/sessions.py", line 587, in send
  File "/Library/Application Support/Perceptive Automation/Indigo 7.3/IndigoPluginHost.app/Contents/Resources/PlugIns/requests/adapters.py", line 481, in send
ConnectionError: HTTPSConnectionPool(host='api.twilio.com', port=443): Max retries exceeded with url: /2010-04-01/Accounts/ACea1e6926097bb7b2098a988e4d6fbff4/Messages.json (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x10bf15190>: Failed to establish a new connection: [Errno 8] nodename nor servname provided, or not known',))

Posted on
Sat Sep 07, 2019 6:00 am
FlyingDiver offline
Posts: 3595
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: No pytz

That looks like some sort of DNS lookup error. Were you having internet connection issues?

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Sat Sep 07, 2019 6:42 am
bjmouton offline
Posts: 19
Joined: Jul 23, 2017

Re: No pytz

That was it. I had been running the box on my desktop via wifi only, I then relocated it to my A/V rack where it normally resides, when I did so I plugged in the wired ethernet connection and that connection did not have DNS servers specified.

Once again, thanks for your help!

Who is online

Users browsing this forum: No registered users and 0 guests