sshToRPI Error

Posted on
Tue Nov 27, 2018 2:46 pm
rhanson offline
Posts: 145
Joined: Apr 30, 2013

sshToRPI Error

Karl,

I've been using piBeacon for years without issue. Went today to set up a new Pi, and I'm getting this error in the log every few seconds:

Code: Select all
   piBeacon                        sshToRPI in Line '13443' has error=''Popen' object does not support indexing'


Debug lines:

Code: Select all
   piBeacon                         sbin/ping  -c 1 -W 40 -o 192.168.6.100 return-code: 0
   piBeacon                        rebootSSH.exp rPi# 1
/usr/bin/expect '/Library/Application Support/Perceptive Automation/Indigo 7.2/Plugins/piBeacon.indigoPlugin/Contents/Server Plugin/rebootSSH.exp'  pi ##correct-password## assword 192.168.6.100 15  &
["assword"? Is that like Seinfeld's assman?]
   piBeacon                        sshToRPI in Line '13443' has error=''Popen' object does not support indexing'
   piBeacon                        last updates were not successful wait, then try again
   piBeacon                        rpiUpdateThread executing  {'fileToSend': 'rebootSSH.exp', 'endAction': 'repeatUntilFinished', 'tries': 7, 'exeTime': 1543351213.549131, 'pi': 1, 'type': 'ssh'}
   piBeacon                        rpiUpdateThread executing  {'fileToSend': 'rebootSSH.exp', 'endAction': 'repeatUntilFinished', 'tries': 7, 'exeTime': 1543351213.549131, 'pi': 1, 'type': 'ssh'}


Data points:
- configured pi correctly (including timezone, etc)
- able to ssh from the Indigo machine terminal (and other machines) to the pi without issue
- password is correct in the config
- new Pi's MAC address correctly appears in the dropdown list of Pis
- Indigo device for the new pi has not been created
- didn't feel like looking at line 13443, figured you would know best
- pi scripts are running on the pi (master, receiveGPIOcommands, beaconloop, copyToTemp)
- installLibs.py is not running
- stopped/restarted plugin
- stopped/restarted whole indigo server
- plugin version 7.94.250
- Indigo 7.2.0

Any ideas?

How do I delete a pi (whose device doesn't yet exist) and start over?

Posted on
Tue Nov 27, 2018 3:30 pm
kw123 offline
User avatar
Posts: 6252
Joined: May 12, 2013
Location: Dallas, TX

Re: sshToRPI Error

the line # 13443 is:>> if len(ret[1]) > 0: <<
but ret = subprocess.Popen(cmd, shell=True, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
missing .communicate().. hence the Popen error

This happens only for certain commands (ie reboot ) only when done manually or program update to RPi

fixed in 7.95.251

don't know why ".communicate()." disappeared

Karl

assman: some prompts are Password some password .. hence assword .. long enough and works.. :lol:
had a plugin "mother" (.. does not work any more vendor website is gone) and you could add some f words behind that one

Posted on
Tue Nov 27, 2018 3:32 pm
kw123 offline
User avatar
Posts: 6252
Joined: May 12, 2013
Location: Dallas, TX

sshToRPI Error

>> How do I delete a pi (whose device doesn't yet exist) and start over?:
in initial setup delete userid and or password and set to off & save that should do it

or just edit that PI# in initial setup, set the new configs and save

Karl

Posted on
Thu Nov 29, 2018 3:26 am
rhanson offline
Posts: 145
Joined: Apr 30, 2013

Re: sshToRPI Error

Thanks for the patch. Success! :-)

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest