Setting up iCloud Servers...

Posted on
Wed Oct 17, 2018 3:36 pm
Gman34798 offline
Posts: 45
Joined: Jun 10, 2018

Setting up iCloud Servers...

So I have installed the plug-in, created an IMAP & SMPT device and configured them with the settings from the Apple support website.
I'm getting what you see in the event log...any thoughts??

Thanks and great work on this plug-in!
Attachments
Screen Shot 2018-10-17 at 5.32.48 PM.png
Screen Shot 2018-10-17 at 5.32.48 PM.png (44.14 KiB) Viewed 452 times
Screen Shot 2018-10-17 at 5.31.19 PM.png
Screen Shot 2018-10-17 at 5.31.19 PM.png (129.55 KiB) Viewed 452 times

Posted on
Wed Oct 17, 2018 3:37 pm
FlyingDiver offline
Posts: 2619
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Setting up iCloud Servers...

What OS version are you running?

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Oct 17, 2018 7:46 pm
Gman34798 offline
Posts: 45
Joined: Jun 10, 2018

Re: Setting up iCloud Servers...

MacOS Sierra
Ver. 10.12.6

Latest version of Indigo.

Posted on
Wed Oct 17, 2018 7:52 pm
FlyingDiver offline
Posts: 2619
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Setting up iCloud Servers...

I suspect that this might be another manifestation of the deprecated TLS issue with Sierra (and earlier). Looks like Apple is ahead of the pack for email servers.

Do you get the same error with the other authentication methods?

If that's what it is, the only solutions I know of are to upgrade to High Sierra or later, or use a different email provider.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Oct 18, 2018 7:51 am
FlyingDiver offline
Posts: 2619
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Setting up iCloud Servers...

Well, I take that back. I just tested BetterEmail on a 10.12.6 system and it was able to connect to iCloud just fine. So it's not the TLS issue.

Post screenshots of the SMTP device configuration panel, please.

Sending email via the iCloud SMTP servers requires two factor authentication and an app-specific password. Have you set that up?

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Oct 18, 2018 10:10 am
Gman34798 offline
Posts: 45
Joined: Jun 10, 2018

Re: Setting up iCloud Servers...

Thanks Joe,
I will post shots of those 2 dialog boxes once I get home, but I have set up the SMTP and IMAP devices. For the password I used my email and password for my Icloud account...i.e., I did NOT create app specific passwords. Not sure if this has any bearing on the issue or not, but figure it worth mentioning.
I'll post screenshots in a few hours. Again, many thanks!
Greg

Posted on
Thu Oct 18, 2018 10:13 am
FlyingDiver offline
Posts: 2619
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Setting up iCloud Servers...

Gman34798 wrote:
For the password I used my email and password for my Icloud account...i.e., I did NOT create app specific passwords. Not sure if this has any bearing on the issue or not, but figure it worth mentioning.


Well, that's guaranteed to not work. You can't connect to the iCloud servers from any non-Apple applications without using an app-specific password. But you would normally get an authentication error, not the one you got. So something else is going on.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Oct 18, 2018 1:16 pm
Gman34798 offline
Posts: 45
Joined: Jun 10, 2018

Re: Setting up iCloud Servers...

All right Joe,
Attached are screenshots of the IMAP & SMPT setup dialogue boxes and a fresh event log of a trip of the flood sensor.
The password is still not app specific (how do I create an App Specific password)? I can type in one here in each dialogue, but doesn't that password have to be
set up somewhere else for validation when Indigo tries to access said email?

Anyhow, we can deal with the password issue as things progress...in the meantime, have a look and see if you can spot the culprit at hand...
Attachments
Screen Shot 2018-10-18 at 3.08.37 PM.png
Screen Shot 2018-10-18 at 3.08.37 PM.png (229.32 KiB) Viewed 318 times
Screen Shot 2018-10-18 at 3.09.01 PM.png
Screen Shot 2018-10-18 at 3.09.01 PM.png (232.12 KiB) Viewed 318 times
Screen Shot 2018-10-18 at 3.09.41 PM.png
Screen Shot 2018-10-18 at 3.09.41 PM.png (66.78 KiB) Viewed 318 times

Posted on
Thu Oct 18, 2018 1:25 pm
FlyingDiver offline
Posts: 2619
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Setting up iCloud Servers...

For the SMTP server, change the Encryption pop-up to StartTLS.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Oct 18, 2018 3:28 pm
Gman34798 offline
Posts: 45
Joined: Jun 10, 2018

Re: Setting up iCloud Servers...

Ok, now it looks like we've drilled down to the password issue, log shows an authentication error....I see in the SMTP and IMAP setup dialogues where to enter a password, but where else is it necessary?
Attachments
Screen Shot 2018-10-18 at 5.25.35 PM.png
Screen Shot 2018-10-18 at 5.25.35 PM.png (38.29 KiB) Viewed 296 times

Posted on
Thu Oct 18, 2018 3:29 pm
FlyingDiver offline
Posts: 2619
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Setting up iCloud Servers...

Gman34798 wrote:
Ok, now it looks like we've drilled down to the password issue, log shows an authentication error....I see in the SMTP and IMAP setup dialogues where to enter a password, but where else is it necessary?


No where, but it can't be your normal iCloud login password. It has to be an app-specific password. As explained on that support page you were referencing in your first post.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Oct 18, 2018 8:29 pm
Gman34798 offline
Posts: 45
Joined: Jun 10, 2018

Re: Setting up iCloud Servers...

No luck after changing passwords 8)
Attachments
53EBBF04-01AB-42CC-AC4C-AC473BAF0B82.png
53EBBF04-01AB-42CC-AC4C-AC473BAF0B82.png (488.13 KiB) Viewed 263 times

Posted on
Thu Oct 18, 2018 8:32 pm
FlyingDiver offline
Posts: 2619
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Setting up iCloud Servers...

I'm not sure what to tell you. It does work if you correctly obtain an app-specific password for that iCloud account (at appleid.apple.com), and put it in the device configuration dialog. I just did it this morning as a test.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Oct 18, 2018 9:04 pm
Gman34798 offline
Posts: 45
Joined: Jun 10, 2018

Re: Setting up iCloud Servers...

FlyingDiver wrote:
...obtain an app-specific password for that iCloud account (at appleid.apple.com), and put it in the device configuration dialog.


This is what I’m missing. I’ll do this tomorrow and be good to go :D
Will post results once done, thanks for your patience with my ignorance :mrgreen:

Posted on
Fri Oct 19, 2018 12:28 pm
Gman34798 offline
Posts: 45
Joined: Jun 10, 2018

Re: Setting up iCloud Servers...

Thanks again Joe,
Password did the trick!

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest