Problem with 7.2 and old Airfoil plugin

Posted on
Fri Sep 28, 2018 9:45 pm
colovin offline
Posts: 121
Joined: Oct 27, 2009

Problem with 7.2 and old Airfoil plugin

I'm using Airfoil not Airfoil pro. I don't get?? Airfoil Pro, it's overly complicated and Airfoil works just fine for my needs. In 7.2, Airfoil won't run, it says there are two Indigo servers running. According to Activity Monitor there are not two Indigo servers running . . . I had to go back to 7.1.1. How can I get 7.2 to run with Airfoil?

Indigo 7.1.1, OS 10.12.6, MacMini 2.6 GHz Intel Core i7, 16GB ram

Posted on
Sat Sep 29, 2018 10:40 am
jay (support) offline
Site Admin
User avatar
Posts: 15338
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Problem with 7.2 and old Airfoil plugin

[MODERATOR NOTE] moved to open source plugins forum

I'm assuming you're talking about the old (unsupported) Airfoil plugin vs the Airfoil Pro plugin that shipped starting with Indigo 7, so if that's not the case let me know.

The old plugin is no longer supported, so I might be of limited help. What exactly are the errors the you're seeing and where are you seeing them?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sun Sep 30, 2018 12:33 pm
colovin offline
Posts: 121
Joined: Oct 27, 2009

Re: Problem with 7.2 and old Airfoil plugin

I wish I had taken screen shots of the error message and of Activity Monitor. Unfortunately I made the mistake of thinking i could just do a quick install, was heading out to dinner with friends so the mission became get it working again, not taking screen shots. The jest of the error message was that Airfoil could not run because there were two indigo servers running and it could only work with one. Activity Monitor showed only one indigo server running.

7.2 is now working. I deleted 7.1.1, then when into Activity Monitor and shut down the indigo server. Went into system setting and took Indigo off of the log in items. Restarted, launched Activity monitor and killed the indigo server which was running, installed 7.2 . Airfoil is happy.. I'll get back to your if something weird starts happening.

Indigo 7.1.1, OS 10.12.6, MacMini 2.6 GHz Intel Core i7, 16GB ram

Posted on
Sun Sep 30, 2018 1:10 pm
Korey offline
User avatar
Posts: 545
Joined: Jun 04, 2008
Location: Henderson, NV

Re: Problem with 7.2 and old Airfoil plugin

You should take a look at Airfoil Pro, it's a huge upgrade from the old Airfoil plugin, take some time and play with it, it's not overly complicated to use and offers way more features.

--
Korey

Posted on
Sun Sep 30, 2018 3:33 pm
colovin offline
Posts: 121
Joined: Oct 27, 2009

Re: Problem with 7.2 and old Airfoil plugin

Of course weirdness ensued. First bell brought on the double server error which this time I didn't have people waiting on me so I was able to figure out what the problem was. Apparently we now have two folders in the /Library/Application Support/Perceptive Automation with Indigo 7 and now Indigo 7.2. The error was Airfoil was looking for the Indigo Server in the Indigo 7 folder but the server was running from the Indigo 7.2 folder. I've got lots of routines pointed at the Indigo 7 folder. I thought I steered Airfoil to the 7.2 folder but the 2PM bell brought up the server error. I'm back to 7.1.1.

What files do I need to move to the from the Indigo 7.2 folder to the Indigo 7 folder to upgrade to 7.2? How do I get the 7.2 app to point to the 7 folder to launch the Indigo Server? This is a major flub in the upgrade process. I can't tell you how many routines I have pointed to the Indigo 7 folder. I’ll only find out when they fail. Why is 7.2 in it's own folder? It's not 8, it's 7.2. It will take me hours to re-route all the routines to a different folder.

Indigo 7.1.1, OS 10.12.6, MacMini 2.6 GHz Intel Core i7, 16GB ram

Posted on
Sun Sep 30, 2018 6:01 pm
jay (support) offline
Site Admin
User avatar
Posts: 15338
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Problem with 7.2 and old Airfoil plugin

That will not work. You should never assume the directory tree for the Indigo installation as it may change at any time.

This is intentional so that it's easy to switch back to a previous version if so desired. While it may mess with things that you've hard coded, it's hardly a "flub". You'll want to rethink all the "routines" that require hardcoding paths.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sun Sep 30, 2018 7:06 pm
matt (support) offline
Site Admin
User avatar
Posts: 19086
Joined: Jan 27, 2003
Location: Texas

Re: Problem with 7.2 and old Airfoil plugin

If you are needing the actively running installed path from an Indigo executed python script (or plugin), you can do so via:

indigo.server.getInstallFolderPath()

For Indigo 7.2 that would return:

'/Library/Application Support/Perceptive Automation/Indigo 7.2'

and is guaranteed to be correct regardless of which version of Indigo 7+ you are running.

Image

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest