Trigger Device Options Not Showing

Posted on
Thu Jul 12, 2018 7:39 pm
ckeyes888 offline
Posts: 2031
Joined: Nov 26, 2009
Location: Kalispell, MT

Trigger Device Options Not Showing

Have an issue triggering from an X10 remote button device.
I have a number of others defined the exact same way that do show it’s options when setting up a trigger.

Any idea why the device settings won’t show?

Thanks,

Carl
Attachments
E557DCA6-5E95-4352-BCFD-4A1708B773BB.jpeg
E557DCA6-5E95-4352-BCFD-4A1708B773BB.jpeg (43.21 KiB) Viewed 308 times
2C4A8E33-B65D-482F-9FA9-7699C7C06FCD.jpeg
2C4A8E33-B65D-482F-9FA9-7699C7C06FCD.jpeg (41.4 KiB) Viewed 308 times

Posted on
Fri Jul 13, 2018 9:49 am
jay (support) offline
Site Admin
User avatar
Posts: 14771
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Trigger Device Options Not Showing

X10 remotes (as well as Insteon remotes) don't have states like switches do. You have to trigger off the X10 command received from the remote, not from a state change.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Jul 13, 2018 8:51 pm
ckeyes888 offline
Posts: 2031
Joined: Nov 26, 2009
Location: Kalispell, MT

Re: Trigger Device Options Not Showing

Thanks. I did eventually figure that out. What had me going on it was I did have a number of X10 PalmPad button
devices that did show device options in triggers.
I recently reinstalled Indigo after a server change and the options disappeared.
Triggering from device state changes actually worked much better than X10 signal received in that
the particular buttons I’m using always send a number of commands, on and a number of brightens,
on each button press.
Triggering from it’s state simply becoming on kept it from multiple triggers from one press.

Edit: What I ended up doing, which works fine, is defining the button as an appliance module.

Carl

Posted on
Sat Jul 14, 2018 8:18 am
jay (support) offline
Site Admin
User avatar
Posts: 14771
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Trigger Device Options Not Showing

Odd, we haven't touched the X10 code and UI in about 8 years...

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests