Some triggers are in red in trigger list

Posted on
Sun Apr 08, 2018 3:25 pm
george99 offline
Posts: 206
Joined: May 27, 2015

Re: Some triggers are in red in trigger list

I just installed a fresh copy of osx high sierra on an external drive just to see if it was an OS issue. I copied the entire perceptive automation folder to the new install, annd I installed the latest version of indigo.
I am getting the same behavior.

So it is not an OS related issue.

That leaves either a hardware issue, or some issue with my indigo configuration.
I haven't touched the hardware for a long time and it has worked well. There is nothing else running on this mac. It is pretty much a dedicated indigo computer.

I have the following plugins installed, and I am wondering if maybe any of them have any known issues that cause the sluggish behavior and disconnecting:

AD2USB Alarm Interface
Alexa Hue Bridge
Cynical Denon
Cynical SecuritySpy
EPS - Homebridge Buddy
Global Property Manager
Growl
NOAA Weather
Sonos
WUnderground

Posted on
Sun Apr 08, 2018 3:58 pm
howartp offline
Posts: 3331
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Some triggers are in red in trigger list

Is your WiFi connection disabled on your Mac?

(I know you’re using Ethernet - therefore is WiFi turned off, or could/are both connections be live?)


Sent from my iPhone using Tapatalk Pro

Posted on
Sun Apr 08, 2018 4:02 pm
george99 offline
Posts: 206
Joined: May 27, 2015

Re: Some triggers are in red in trigger list

Yes. WiFi is off.
I also tried using WiFi and disconnected the Ethernet but that didn’t work either.

Posted on
Sun Apr 08, 2018 5:30 pm
matt (support) offline
Site Admin
User avatar
Posts: 18615
Joined: Jan 27, 2003
Location: Texas

Re: Some triggers are in red in trigger list

george99 wrote:
Just to add a little more info. When I even try to open control pages from the indigo app in the Mac mini itself, it freezes up and stops responding.
I look in the activity monitor and it shows "indigo 7 (not responding).
Clears up after a minute.
Just seems like something is either wrong with the indigo server or the Mac mini itself.

Try temporarily disabling all of your Plugins. If you can then open (or better yet create a new) Control Page quickly enable the Plugins one-by-one to find the culprit. If it isn't the plugins then we'll dig further into it.

Image

Posted on
Mon Apr 09, 2018 9:00 am
george99 offline
Posts: 206
Joined: May 27, 2015

Re: Some triggers are in red in trigger list

Ok, that didn't help. No change with or without the plugins.
However, I was able to find some consistency in this.
The control page where it seems to happen 90% of the time is my page with a refreshing URL thumbnail of all of my cameras. I have 24 cameras. So it is showing 24 simultaneous refreshing image URLs.
However, while it is loading them, the connection to the indigo server seems like it drops every time after the first 16 cameras are loaded. Then after 16 it disconnects, and then reconnects, and more often than not, the remaining 8 cameras don't ever load.

So I am thinking that there is some type of connection limit. I am using securityspy, so the connections are all to the securityspy server, not to each of the individual IP cameras.
Security spy is on a dedicated macbook pro.

What my guess is that the mac mini (indigo) is reach max connections (16 connections to security spy mac), and then kicking my ipad (indigo touch) out.

Posted on
Mon Apr 09, 2018 10:02 am
citysnaps offline
Posts: 31
Joined: Jul 13, 2016

Re: Some triggers are in red in trigger list

Long shot, and may not apply...

Last week, after a year of trouble-free operation, I had a situation where all of my dimmers were showing red on the Indigo home page along with no acknowledgment errors. Tried rebooting Indigo and Security Spy, with no luck. Ditto with my 2012 Mac Mini. Many times. Tried reconfiguring the Z-Wave network, etc. No luck.

Then I remembered that the Aeotec Gen5 Z-Wave stick sometimes had issues, apparently being sensitive to which USB port it was plugged into (I'm guessing a power issue when it boots up). Shut down the Mac Mini, unplugged the Z-Wave stick, booted up the Mini, plugged in the Z-Wave stick after the Mini was running, started up Indigo and Security Spy, and the problem was gone.

Might be worth a try.

...........................
Brad
Urban photoblog: www.citysnaps.net

Posted on
Mon Apr 09, 2018 11:09 am
george99 offline
Posts: 206
Joined: May 27, 2015

Re: Some triggers are in red in trigger list

Not it, but thanks for trying.

Posted on
Tue Apr 10, 2018 10:50 am
george99 offline
Posts: 206
Joined: May 27, 2015

Re: Some triggers are in red in trigger list

Ok, I did more testing. I think the number is actually 18, not 16, when the iOS app disconnects.

Also, I just took the URLs of my cameras and loaded them directly in an HTML webpage, and they all load with now issue quickly.
So I think that just leaves indigo.

Posted on
Wed Apr 11, 2018 11:38 am
matt (support) offline
Site Admin
User avatar
Posts: 18615
Joined: Jan 27, 2003
Location: Texas

Re: Some triggers are in red in trigger list

Try creating a file named IndigoWebServer.conf here:

 /Library/Application Support/Perceptive Automation/Indigo 7/IndigoWebServer/IndigoWebServer.conf

The file should look like this and be saved as a plain ASCII text (not PDF, .doc, .pages, etc.) file:

Code: Select all
[global]
server.socket_queue_size = 50
server.thread_pool = 80

Next, stop and restart the Indigo Server via the Indigo 7->Stop Server menu item.

Does it behave any differently?

Image

Posted on
Thu Apr 12, 2018 10:15 am
george99 offline
Posts: 206
Joined: May 27, 2015

Re: Some triggers are in red in trigger list

Thanks Matt, unfortunately, no change at all.

Posted on
Thu Apr 12, 2018 10:16 am
george99 offline
Posts: 206
Joined: May 27, 2015

Re: Some triggers are in red in trigger list

BTW, I doubt it is related, but just in case. The Indigo 6 folder is still there from prior to upgrading. Anything there that might conflict?

Posted on
Thu Apr 12, 2018 10:34 am
jay (support) offline
Site Admin
User avatar
Posts: 14659
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Some triggers are in red in trigger list

What are the exact specs of your Mac (model, memory, disk or ssd, network interfaces and which are enabled, etc)?

Unlikely the Indigo 6 install folder has anything to do with the issue, but you can always zip it up (for backup purposes) then delete it.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Apr 12, 2018 10:52 am
george99 offline
Posts: 206
Joined: May 27, 2015

Re: Some triggers are in red in trigger list

Mid 2011 Mac Mini
2.5 Ghz Core i5
8GB 1333 Mhz RAM
AMD Radeon HD 6630 256 MB
HDD 750GB with 720GB Free.

Indigo and SimpleControl Hub are the only 2 things that I use it for and that are running.

Posted on
Thu Apr 12, 2018 11:57 am
matt (support) offline
Site Admin
User avatar
Posts: 18615
Joined: Jan 27, 2003
Location: Texas

Re: Some triggers are in red in trigger list

Can you open the Terminal app and copy/paste in the following then press return:

Code: Select all
cd /Library/Application\ Support/Perceptive\ Automation/Indigo\ 7/IndigoWebServer
ls -al
cat IndigoWebServer.conf


And then copy/paste the Terminal window results into a reply for me.

Image

Posted on
Thu Apr 12, 2018 2:02 pm
jay (support) offline
Site Admin
User avatar
Posts: 14659
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Some triggers are in red in trigger list

george99 wrote:
Mid 2011 Mac Mini
2.5 Ghz Core i5
8GB 1333 Mhz RAM
AMD Radeon HD 6630 256 MB
HDD 750GB with 720GB Free.

Indigo and SimpleControl Hub are the only 2 things that I use it for and that are running.


And your network interfaces and how/if they're being used?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Who is online

Users browsing this forum: No registered users and 0 guests