StandardError detected in 'updateDeviceState'. Line '310

Posted on
Wed Nov 15, 2017 5:34 pm
Different Computers offline
User avatar
Posts: 1846
Joined: Jan 02, 2016
Location: East Coast

StandardError detected in 'updateDeviceState'. Line '310

Code: Select all
   Nanoleaf Error                  StandardError detected in 'updateDeviceState'. Line '310' has error=''ProtocolError' object has no attribute 'reason''
that's a one off error from the log that hasn't recurred & doesn't seem to have stopped anything from happening, but I thought you would want to see it.

SmartThings refugee, so happy to be on Indigo. 10.13.6 on an i5 MBP w/Harmony Hub, Hue, DomoPad, Dynamic URL, Device Extensions, HomeKit Bridge, MatplotLib, Plex, uniFAP, Wunderground, Nanoleaf, LED Simple Effects, Airfoil Pro, Grafana.

Posted on
Thu Nov 16, 2017 5:33 am
autolog offline
Posts: 2428
Joined: Sep 10, 2013
Location: West Sussex

Re: StandardError detected in 'updateDeviceState'. Line '310

Looks like it was a one-off error from the nanoleaf Aurora when requesting its status.

This error shouldn't occur where it did because at that point the Aurora has passed back a success code and therefore the error routines haven't been invoked. :?

If it happens again on a more regular basis, turn on full debugging and the debug logic will catch what is being returned and I can investigate further. :)

Posted on
Sun Nov 19, 2017 7:17 am
Different Computers offline
User avatar
Posts: 1846
Joined: Jan 02, 2016
Location: East Coast

Re: StandardError detected in 'updateDeviceState'. Line '310

I am still seeing these about 2x an hour.
Code: Select all
   Nanoleaf Error                  StandardError detected in 'updateDeviceState'. Line '310' has error=''ProtocolError' object has no attribute 'reason''
Tricky to catch with full debugging because it happens at unpredictable times.

But maybe this helps?
Code: Select all
Nanoleaf                        sent "Wall Art" Set Effect to Classic Visualizer
   Nanoleaf Error                  StandardError detected communicating with NANOLEAF lamp:
   Nanoleaf Error                  Traceback (most recent call last):
   Nanoleaf Error                    File "/Library/Application Support/Perceptive Automation/Indigo 7/Plugins/nanoleaf.indigoPlugin/Contents/Server Plugin/sendReceiveMessages.py", line 105, in run
   Nanoleaf Error                      success, statusMsg, self.globals['nl'][nanoleafDevId]["auroraInfo"] = self.globals['nl'][nanoleafDevId]["aurora"].info
   Nanoleaf Error                    File "/Library/Application Support/Perceptive Automation/Indigo 7/Plugins/nanoleaf.indigoPlugin/Contents/Server Plugin/nanoleaf/aurora.py", line 84, in info
   Nanoleaf Error                      return self.__get()
   Nanoleaf Error                    File "/Library/Application Support/Perceptive Automation/Indigo 7/Plugins/nanoleaf.indigoPlugin/Contents/Server Plugin/nanoleaf/aurora.py", line 37, in __get
   Nanoleaf Error                      errorMsg = e.args[0].reason.message.split('>: ')[1]
   Nanoleaf Error                  AttributeError: 'ProtocolError' object has no attribute 'reason'

SmartThings refugee, so happy to be on Indigo. 10.13.6 on an i5 MBP w/Harmony Hub, Hue, DomoPad, Dynamic URL, Device Extensions, HomeKit Bridge, MatplotLib, Plex, uniFAP, Wunderground, Nanoleaf, LED Simple Effects, Airfoil Pro, Grafana.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests