Condition with minus celcius

Posted on
Tue Oct 10, 2017 12:06 pm
mortenkols offline
Posts: 198
Joined: Oct 29, 2014
Location: Norway

Condition with minus celcius

Im setting up and condition based on the outside temperature. But I can't get it to execute. its working if the temperature is between 0-100 degrees, but when i try between -6 and 7 nothing happen. The outside temp is around 5 degrees now.

What is wrong with my condition ?
Attachments
Skjermbilde 2017-10-10 kl. 20.02.35.png
Skjermbilde 2017-10-10 kl. 20.02.35.png (25.67 KiB) Viewed 1888 times
Skjermbilde 2017-10-10 kl. 20.02.02.png
Skjermbilde 2017-10-10 kl. 20.02.02.png (56.21 KiB) Viewed 1888 times

Posted on
Tue Oct 10, 2017 3:34 pm
matt (support) offline
Site Admin
User avatar
Posts: 20086
Joined: Jan 27, 2003
Location: Texas

Re: Condition with minus celcius

Could the problem be that the "-" in front of the 6 is a hyphen and not a minus/negative sign? Does it work if you change it from -6 to 0 (given then current temperature is around 5 degrees)?

Image

Posted on
Tue Oct 10, 2017 3:41 pm
mortenkols offline
Posts: 198
Joined: Oct 29, 2014
Location: Norway

Re: Condition with minus celcius

yes. it works if I set the condition from 0 to 6. what sign should I use as negative?

Posted on
Tue Oct 10, 2017 3:52 pm
matt (support) offline
Site Admin
User avatar
Posts: 20086
Joined: Jan 27, 2003
Location: Texas

Re: Condition with minus celcius

Just the key to the right of the zero key.

Image

Posted on
Tue Oct 10, 2017 10:57 pm
mortenkols offline
Posts: 198
Joined: Oct 29, 2014
Location: Norway

Re: Condition with minus celcius

I have tryed this ‘-‘ sign.

Posted on
Wed Oct 11, 2017 2:27 pm
matt (support) offline
Site Admin
User avatar
Posts: 20086
Joined: Jan 27, 2003
Location: Texas

Re: Condition with minus celcius

I just tried, and I'm unable to reproduce this problem. Using a negative value for the lower bounds of a between conditional worked correctly here.

Are you accessing the Indigo Server from the Indigo Client (GUI) on the same Mac? I'm wondering if an extra invisible character is getting entered in the edit field before or after the number somehow. That is the only way I can think that it would fail to recognize the entry as a number.

Image

Posted on
Thu Oct 12, 2017 3:53 am
mortenkols offline
Posts: 198
Joined: Oct 29, 2014
Location: Norway

Re: Condition with minus celcius

Im accessing indigo server from a remote macbook air. Indigo server is on a mac mini with no display

Posted on
Thu Oct 12, 2017 6:29 am
matt (support) offline
Site Admin
User avatar
Posts: 20086
Joined: Jan 27, 2003
Location: Texas

Re: Condition with minus celcius

I think that might be the problem. We've had problems with screen sharing inserting invisible characters on the registration code entry dialog, so the same thing might be happening here.

Are you accessing it remotely using the Indigo client, or via screen sharing?

Maybe try copy/pasting the entire value "-6" to see if that gives a different result?

Image

Posted on
Thu Oct 12, 2017 10:51 am
mortenkols offline
Posts: 198
Joined: Oct 29, 2014
Location: Norway

Re: Condition with minus celcius

I have tried indigo client, screen sharing and copy the value you posted. I have also connected mouse and keyboard to the Mac mini server. nothing works.

As you can se from the two pictures, the minus sign changing(longer minus sign) after i save the schedule, if you understand me.
Attachments
Skjermbilde 2017-10-12 kl. 18.51.13.png
Skjermbilde 2017-10-12 kl. 18.51.13.png (53.23 KiB) Viewed 1651 times
Skjermbilde 2017-10-12 kl. 18.50.58.png
Skjermbilde 2017-10-12 kl. 18.50.58.png (59.78 KiB) Viewed 1654 times
Last edited by mortenkols on Thu Oct 12, 2017 10:53 am, edited 1 time in total.

Posted on
Thu Oct 12, 2017 10:52 am
matt (support) offline
Site Admin
User avatar
Posts: 20086
Joined: Jan 27, 2003
Location: Texas

Re: Condition with minus celcius

What version of Indigo are you running?

Image

Posted on
Thu Oct 12, 2017 10:55 am
mortenkols offline
Posts: 198
Joined: Oct 29, 2014
Location: Norway

Re: Condition with minus celcius

se my last post again. I edited it with another picture.

I use 7.0.3

Posted on
Thu Oct 12, 2017 11:05 am
matt (support) offline
Site Admin
User avatar
Posts: 20086
Joined: Jan 27, 2003
Location: Texas

Re: Condition with minus celcius

Get it into the state where it is failing (condition evaluation should be true but isn't working), then choose the Indigo 7->Stop Server menu item and email us (support AT indigodomo DOT com) your database file. We'll try to reproduce it here with your database.

Image

Posted on
Thu Oct 12, 2017 11:17 am
mortenkols offline
Posts: 198
Joined: Oct 29, 2014
Location: Norway

Re: Condition with minus celcius

i have sent the database now.

I think the problem is that the minus sign is changing format.

Posted on
Thu Oct 12, 2017 11:33 am
FlyingDiver offline
User avatar
Posts: 4325
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Condition with minus celcius

Go to System Preferences, Keyboard Panel, Text tab. Check for a substitution there. Also try unchecking the "Use smart quotes and dashes" box.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Oct 12, 2017 12:12 pm
mortenkols offline
Posts: 198
Joined: Oct 29, 2014
Location: Norway

Re: Condition with minus celcius

FlyingDiver wrote:
Go to System Preferences, Keyboard Panel, Text tab. Check for a substitution there. Also try unchecking the "Use smart quotes and dashes" box.


I tried it, but I have the same problem.

Who is online

Users browsing this forum: No registered users and 0 guests