Fortrezz Flood and Temperature Sensor

Forum rules

Questions about hardware that can be controlled by Indigo (but not through the interfaces and plugins listed). If Indigo doesn't support some bit of hardware you're interested in, and you don't find a 3rd Party Plugin for it, add it to this forum. Be sure to include links to as much information as you can find about it.

Note: adding it here does not mean we're going to add it - in fact it's possible one of our 3rd party developers may decide to write a plugin for it. We add hardware/features based on a lot of different factors beyond just having a request for it.

Posted on
Wed Sep 20, 2017 6:44 am
jenwill1 offline
Posts: 150
Joined: Mar 22, 2009
Location: Boerne, Texas

Fortrezz Flood and Temperature Sensor

For a new home I purchased the Fortrezz water valve and leak detectors to protect the wood floors. They include ok and I can trigger the valve to shut but aren't recognized by Indigo 7.04. Thanks !

The latest version of the WV-01 water valve

Indigo Z-Wave Version: 2.0.68
Node ID: 3
Model: Relay Switch
Model ID: 02430300
Manufacturer: FortrezZ
Manufacturer ID: 0084
Protocol Version: 3.40
Application Version: 3.00
Model Definition Version: 0
Library Type: 6
Class Name: Relay Switch
Class Hierarchy: 04 : 10 : 00
Command Class Base: 25
Command Versions: 20v1 70v1 22v1 25v1 86v1 71v1 72v1
Encryption Status: Not Supported
Multi-Endpoint Types: - none -
Multi-Endpoint Classes: - none -
Multi-Instance Counts: - none -
Features: routing, beaming
Neighbors: 2
Associations: - none -
Config Values: - none -

The leak sensor FTS05 is a new Zwave Plus Device

Indigo Z-Wave Version: 2.0.68
Node ID: 13
Model: Notification Sensor
Model ID: 0073000C
Manufacturer: FortrezZ
Manufacturer ID: 0084
Protocol Version: 4.38
Application Version: 0.12
Model Definition Version: 0
Library Type: 6
Class Name: Notification Sensor
Class Hierarchy: 04 : 07 : 01
Command Class Base: 00
Command Versions: 20v1 80v1 84v2 85v1 86v1 71v1 70v1 31v9 72v1 73v1 98v1 59v1 5Av1 5Ev1
Encryption Status: Supported but not Enabled
Multi-Endpoint Types: - none -
Multi-Endpoint Classes: - none -
Multi-Instance Counts: - none -
Features: routing, battery, beaming, security, waking
Neighbors: - none -
Associations: 1:[1] 2:[] 3:[] 4:[] 5:[] 6:[] 7:[] 8:[]
Config Values: - none -

Posted on
Sat Sep 23, 2017 5:07 pm
matt (support) offline
Site Admin
User avatar
Posts: 18419
Joined: Jan 27, 2003
Location: Texas

Re: Fortrezz Flood and Temperature Sensor

Thanks for the details. It looks like the new FTS05 should work the same as the older one, so I'll add beta support for it to the next version of Indigo. I've also added the new model ID for the water valve.

Image

Posted on
Sat Sep 23, 2017 7:18 pm
jenwill1 offline
Posts: 150
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: Fortrezz Flood and Temperature Sensor

Thanks Matt :D

Posted on
Thu Nov 02, 2017 5:28 pm
jenwill1 offline
Posts: 150
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: Fortrezz Flood and Temperature Sensor

Thanks for adding this sensor to Indigo.

I successfully synced and have a temperature and alarm device for each sensor. When i trigger the water alarm by physically placing the sensor contacts in water, status does not change on the alarm device. I have two of these and neither reports anything in the event log when the water alarm is active on the sensor (a sequence of two flashes on the led).

I factory reset, deleted the devices and then synced and created new devices with the same result.

Any ideas to troubleshoot ? Here is the last sync...

Thanks !

Nov 2, 2017, 6:18:33 PM
Z-Wave started controller inclusion mode
Z-Wave controller included module: 015 - Notification Sensor
Z-Wave stopped controller inclusion mode
Z-Wave Syncing - started for "015 - Notification Sensor"
Z-Wave Syncing - retrieved module neighbors list: 2, 3
Z-Wave Syncing - assigning return route to "015 - Notification Sensor"
Z-Wave Syncing - assigned return route
Z-Wave Syncing - retrieved manufacture and model names: FortrezZ - 0084, Water/Temperature Sensor (FTS05) - 0073000C
Z-Wave Syncing - retrieved protocol version 4.38, app version 0.12
Z-Wave Syncing - retrieved class hierarchy: Routing Slave : Notification Sensor : Notification Sensor (04 : 07 : 01, base 00)
Z-Wave Syncing - retrieved command classes: 20v1 80v1 84v2 85v1 86v1 71v1 70v1 31v9 72v1 73v1 98v1 59v1 5Av1 5Ev1
Z-Wave Syncing - retrieved encrypt commands: - none -
Z-Wave Syncing - retrieved capabilities: routing, battery, beaming, security, waking
Z-Wave Syncing - retrieved wake interval of 240 minutes
Z-Wave Syncing - device "015 - Notification Sensor" wake interval changed to 60 minutes
Z-Wave Syncing - retrieved group 1 associations: []
Z-Wave Syncing - retrieved group 2 associations: []
Z-Wave Syncing - retrieved group 3 associations: []
Z-Wave Syncing - retrieved group 4 associations: []
Z-Wave Syncing - retrieved group 5 associations: []
Z-Wave Syncing - retrieved group 6 associations: []
Z-Wave Syncing - retrieved group 7 associations: []
Z-Wave Syncing - retrieved group 8 associations: []
Z-Wave Syncing - added group 1 association to interface
Z-Wave Syncing - retrieved parameter 1 "Low trigger" is 4 °C
Z-Wave Syncing - retrieved parameter 2 "High trigger" is 70 °C
Z-Wave Syncing - retrieved battery level of 83%
Z-Wave Syncing - created device "015 - Temperature"
Z-Wave Syncing - created device "015 - Water/Temp Alarm"
Z-Wave Syncing - complete

Nov 2, 2017, 6:19:09 PM
Z-Wave received "015 - Temperature" sensor update to 28 °C
Z-Wave received "015 - Temperature" units changed to °C
Z-Wave received "015 - Temperature" status update battery level 83%
Z-Wave received "015 - Temperature" status update battery level 83%

Posted on
Thu Nov 02, 2017 5:47 pm
matt (support) offline
Site Admin
User avatar
Posts: 18419
Joined: Jan 27, 2003
Location: Texas

Re: Fortrezz Flood and Temperature Sensor

Can you turn on the debug logging checkbox via the Interfaces->Z-Wave->Configure... menu item, then place the contacts in the water? I'd like to see exactly what messages the module is sending. After tripping it, dry off the contacts and let it sit for a few minutes so it also captures any "off/reset" messages it might send.

Image

Posted on
Thu Nov 02, 2017 8:42 pm
jenwill1 offline
Posts: 150
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: Fortrezz Flood and Temperature Sensor

Matt, here is the debug information. I let it alarm twice in water and then dried it off....

Thanks !

Z-Wave Debug RCVD requestAlarmSensorStatus: 01 10 00 04 00 0F 0A 71 05 00 00 00 FF 05 02 00 00 62
Z-Wave Debug . . requestAlarmSensorStatus: node 015, endpoint None, cmdClass 71, type 0, value 0, classSubKey 710000
Z-Wave Debug . . requestAlarmSensorStatus: typeExt 5, valueExt 2, classSubKeyExt 7100000502

Nov 2, 2017, 9:40:14 PM
Z-Wave Debug RCVD requestAlarmSensorStatus: 01 10 00 04 00 0F 0A 71 05 00 00 00 FF 05 00 00 00 60
Z-Wave Debug . . requestAlarmSensorStatus: node 015, endpoint None, cmdClass 71, type 0, value 0, classSubKey 710000
Z-Wave Debug . . requestAlarmSensorStatus: typeExt 5, valueExt 0, classSubKeyExt 7100000500

Nov 2, 2017, 9:40:29 PM
Z-Wave Debug RCVD requestAlarmSensorStatus: 01 10 00 04 00 0F 0A 71 05 00 00 00 FF 05 02 00 00 62
Z-Wave Debug . . requestAlarmSensorStatus: node 015, endpoint None, cmdClass 71, type 0, value 0, classSubKey 710000
Z-Wave Debug . . requestAlarmSensorStatus: typeExt 5, valueExt 2, classSubKeyExt 7100000502
Z-Wave Debug RCVD requestAlarmSensorStatus: 01 10 00 04 00 0F 0A 71 05 00 00 00 FF 05 00 00 00 60
Z-Wave Debug . . requestAlarmSensorStatus: node 015, endpoint None, cmdClass 71, type 0, value 0, classSubKey 710000
Z-Wave Debug . . requestAlarmSensorStatus: typeExt 5, valueExt 0, classSubKeyExt 7100000500

Posted on
Tue Nov 07, 2017 9:13 pm
matt (support) offline
Site Admin
User avatar
Posts: 18419
Joined: Jan 27, 2003
Location: Texas

Re: Fortrezz Flood and Temperature Sensor

Indigo 7.1.1 is now available for download and should work correctly with this FortrezZ module.

Image

Posted on
Thu Nov 16, 2017 8:12 am
jenwill1 offline
Posts: 150
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: Fortrezz Flood and Temperature Sensor

Matt,

I have five of these sensors now...

I first bought two for the house and this batch is where I sent the information above to add the device to Indigo, These sensors will include and sync easily with the version 7.1.1. But after I sync the water alarm quits working and I only get battery and temperature updates in the event log, no update of the alarm state. When these sensors are included, two devices are created, a temperature and a water/temperature alarm. Appears the water/temperature alarm is for low temp, high temp and water, where a parameter 4 turns the water alarm on or off.

I purchased another three and tested the water alarms, all ok.. tried to include using the start inclusion mode on the controller, none would include with one or more button presses. Then I tried a manual inclusion with the stick and got one to include. However in did manage to get one to include using the Zstick manual inclusion process. However in trying to sync it, I get the following no matter if I hit the program button or not...

Z-Wave Syncing - started for "022 - Notification Sensor"
Z-Wave Debug SENT getNodeNeighbors: 01 06 00 80 16 01 01 6F
Z-Wave Debug RCVD getNodeNeighbors: 01 20 01 80 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 5E
Z-Wave Debug . . getNodeNeighbors: nodeId 022, neighbors: - none -
Z-Wave Syncing - retrieved module neighbors list: - none -
Z-Wave Syncing - assigning return route to "022 - Notification Sensor"
Z-Wave Debug SENT assignReturnRoute: 01 05 00 46 16 01 AB
Z-Wave Debug RCVD assignReturnRoute: 01 04 01 46 01 BD
Z-Wave Debug RCVD assignReturnRoute: 01 05 00 46 01 01 BC
Z-Wave Debug . . assignReturnRoute: node 022, success 0
Z-Wave Error Syncing - failed to assign return route
Z-Wave Debug SENT requestNodeInfo: 01 06 00 60 16 24 AA 01
Z-Wave Debug RCVD requestNodeInfo: 01 06 00 49 81 00 00 31
Z-Wave Debug RCVD requestNodeInfo: failed (module asleep or doesn't support command)
Z-Wave Error Syncing - failed
Z-Wave Error No response from "022 - Notification Sensor". Module might be asleep, or is unreachable.

Not sure where to go with this... back to Home Controls, Fortrezz ? Is there a different version of the firmware that won't include the same way ? Is the sync in Indigo turning off the water alarm parameter on the ones that will include ? I am going to fire off a question to Fortrezz on the firmware...

May have to return all back to Home Controls and try something else !

Thanks

Posted on
Fri Nov 17, 2017 11:37 pm
matt (support) offline
Site Admin
User avatar
Posts: 18419
Joined: Jan 27, 2003
Location: Texas

Re: Fortrezz Flood and Temperature Sensor

The log above shows the module not responding at all – as if it isn't awake despite the button presses. Try removing the battery for a few seconds, re-inserting, then re-syncing (some modules stay awake for a while after the battery is removed and reinserted). If that doesn't work, try excluding/re-including it again and then immediately try syncing it (hoping it will still be awake...).

I don't know what firmware or even model ID the module is because it isn't getting far enough into the sync process to extract out that information from the module.

Image

Posted on
Thu Nov 23, 2017 6:06 pm
jenwill1 offline
Posts: 150
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: Fortrezz Flood and Temperature Sensor

Not sure what to do Matt. If I pull the stick out and include, I can eventually get the devices to include. Out of the four devices I've tried to sync, two behave and include, the other immediately time out still. Battery insertion does nothing to keep them awake. Here is the info in the controller from the include.... Not sure what to do next except send them all back to home Controls or send one your way. Thanks

Z-Wave Debug SENT getNodeProtocolInfo: 01 04 00 41 16 AC
Z-Wave Debug RCVD getNodeProtocolInfo: 01 09 01 41 53 9C 01 04 07 01 7A
Z-Wave Debug . . getNodeProtocolInfo: node 022, class name: Notification Sensor
Z-Wave Debug . . getNodeProtocolInfo: class hierarchy: Routing Slave : Notification Sensor : Notification Sensor (04 : 07 : 01)
Z-Wave Debug . . getNodeProtocolInfo: base class command: 00
Z-Wave Debug . . getNodeProtocolInfo: supported class commands: 20
Z-Wave Debug . . getNodeProtocolInfo: encrypt class commands:
Z-Wave Debug . . getNodeProtocolInfo: features: routing, beaming
Z-Wave found module included in controller with no matching device (missing or disabled): 022 - Notification Sensor
Z-Wave Debug SENT getNodeProtocolInfo: 01 04 00 41 18 A2
Z-Wave Debug RCVD getNodeProtocolInfo: 01 09 01 41 53 9C 01 04 07 01 7A
Z-Wave Debug . . getNodeProtocolInfo: node 024, class name: Notification Sensor
Z-Wave Debug . . getNodeProtocolInfo: class hierarchy: Routing Slave : Notification Sensor : Notification Sensor (04 : 07 : 01)
Z-Wave Debug . . getNodeProtocolInfo: base class command: 00
Z-Wave Debug . . getNodeProtocolInfo: supported class commands: 20
Z-Wave Debug . . getNodeProtocolInfo: encrypt class commands:
Z-Wave Debug . . getNodeProtocolInfo: features: routing, beaming
Z-Wave found module included in controller with no matching device (missing or disabled): 024 - Notification Sensor

Posted on
Sun Nov 26, 2017 4:15 pm
matt (support) offline
Site Admin
User avatar
Posts: 18419
Joined: Jan 27, 2003
Location: Texas

Re: Fortrezz Flood and Temperature Sensor

Did FortrezZ ever get back to you (or did you contact them)? They might be able to provide a tip on getting it to stay awake long enough for the sync. I have some much older versions of their modules and have never had these problems before, so I'm not sure if they changed something or if you just got some marginal ones.

Image

Posted on
Fri Jan 05, 2018 12:47 pm
jenwill1 offline
Posts: 150
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: Fortrezz Flood and Temperature Sensor

Matt here is my last correspondence with Fortrezz...
Sent.....
[Subject: FTS05
Message: I have purchased a total of 5 of these sensors to associate with your water valve WV-01. I bought the sensors in a batch of three, returned one because it would not include. I received a replacement and I purchased another two after that.
I am using Indigo for the automation software and the Zstick gen 5 zwave controller. Only two of the first batch I purchased would sync and none of the other three I received will sync. Has there been different firmware issued for these ? Or anything that would cause different behavior ? I am about ready to return all five.

Reply....
Hey William, the FTS05 is still a fairly new device that controllers are still implementing support into their systems. Indigo is not a platform that we have tested those sensors with, so I cannot say how they will behave in these controllers. But here are a few tips that will help ensure they are added in correctly. Firstly, it is recommended that when pairing or unpairing the device be brought within 5ft of the hub. When pressing the program button on the sensor you will notice a certain amount of blinks on the LED after the first inital flash when pressing the button. If the device is in a network, you will notice 2 quick blinks. If the device is not in a network, you will notice 4 quick blinks after approx 30 seconds. Also, inorder to remove the sensor from the network, you must hold the program button down for ~3 seconds. For joining a network, it will be a quick press.

I can include one of the three but can never get it to sync (asleep). Can I mail one of these to you guys to play with ??

Thanks

Posted on
Fri Jan 05, 2018 6:56 pm
matt (support) offline
Site Admin
User avatar
Posts: 18419
Joined: Jan 27, 2003
Location: Texas

Re: Fortrezz Flood and Temperature Sensor

Have you asked Fortrezz specifically how to keep the module awake so that Indigo can query information from it? I wonder if there is some trick to keep it from going to sleep.

Image

Posted on
Fri Jan 05, 2018 7:15 pm
jenwill1 offline
Posts: 150
Joined: Mar 22, 2009
Location: Boerne, Texas

Re: Fortrezz Flood and Temperature Sensor

Matt, this is the first query to Fotrezz...
Subject: Associations using water valve and new water sensors
Message: I am looking for instructions on associating the water valve to the leak detectors. When I try to do this in Indigo, the sensor is asleep and does not accept the association. is there a wake mode and what are the proper parameters and values to associate ? Thanks for your help.

Hey William, setting an association requires the sensor to wake up, this can be done through a quick press on the program button on the sensor. Usually the controller asks the users to wake up the device immediately after the association process is started, so once this occurs a single press usually does the job, if not then multiple presses might be required. The association groups will be different on different devices. You can refer to the user manual, or technical appendix on which group this might be, for sensors it's usually group 1.


This was regarding the sensors I was able to include and sync and was trying to assign associations to the water valve. I have tried this in the initial sync as
well. I tried to push the program button just before I hit sync, during, after and the device asleep error comes up right away.

Thanks Matt

Posted on
Fri Jan 05, 2018 7:28 pm
matt (support) offline
Site Admin
User avatar
Posts: 18419
Joined: Jan 27, 2003
Location: Texas

Re: Fortrezz Flood and Temperature Sensor

I'm going to email them offline to see if we can get them to try it out on their end.

Image

Who is online

Users browsing this forum: No registered users and 0 guests