Player shows as disconnected

Posted on
Sat Jul 29, 2017 9:15 am
pocster offline
User avatar
Posts: 223
Joined: Nov 15, 2014

Player shows as disconnected

I have some Raspberry Pi's linked up via this plugin on my mac.

They seem to stream from the squeezebox player no issue. The devices though in the indigo window always show as disconnected; though the MAC address is correct.
Any ideas?

ta

Posted on
Sat Jul 29, 2017 9:22 am
autolog offline
Posts: 2955
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1]

Re: Player shows as disconnected

pocster wrote:
I have some Raspberry Pi's linked up via this plugin on my mac.

They seem to stream from the squeezebox player no issue. The devices though in the indigo window always show as disconnected; though the MAC address is correct.
Any ideas?

ta

Where is the Squeezebox server running?

Posted on
Sat Jul 29, 2017 9:23 am
pocster offline
User avatar
Posts: 223
Joined: Nov 15, 2014

Re: Player shows as disconnected

Hey!

Everything is running on the same mac.

Cheers

Posted on
Sat Jul 29, 2017 9:29 am
autolog offline
Posts: 2955
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1]

Re: Player shows as disconnected

So you are running the Raspberry Pi's as Players?

Posted on
Sat Jul 29, 2017 9:29 am
pocster offline
User avatar
Posts: 223
Joined: Nov 15, 2014

Re: Player shows as disconnected

Yep exactly

Posted on
Sat Jul 29, 2017 9:49 am
autolog offline
Posts: 2955
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1]

Re: Player shows as disconnected

Not sure why that would be. :?

Presumably the plugin detected the players in the first place. What does the Notes field say it found?
Do you have an ordinary (hardware) players?
What status does the Squeezebox Server show?

What version of the Squeezebox Server are you running?

Posted on
Sat Jul 29, 2017 9:55 am
pocster offline
User avatar
Posts: 223
Joined: Nov 15, 2014

Re: Player shows as disconnected

Notes field?; where's that?

No ordinary players.
Squeezebox server found pi and seems perfectly happy.
Attachments
Screen Shot 2017-07-29 at 16.51.36.png
Screen Shot 2017-07-29 at 16.51.36.png (43.47 KiB) Viewed 1693 times
Screen Shot 2017-07-29 at 16.51.36.png
Screen Shot 2017-07-29 at 16.51.36.png (43.47 KiB) Viewed 1693 times

Posted on
Sat Jul 29, 2017 10:02 am
autolog offline
Posts: 2955
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1]

Re: Player shows as disconnected

Notes field is in the Device List - you might need to right click on the Device List headings to reveal it.

I can't see the Mac address in your images. If you edit one of the devices, what does it show as the Address under Type and Mode?

The Mac Address should be in the format 11:22:33:AA:BB:CC

Posted on
Sat Jul 29, 2017 11:55 am
pocster offline
User avatar
Posts: 223
Joined: Nov 15, 2014

Re: Player shows as disconnected

Still can't see any notes

There is no mac address listed in indigo. But opening the squeezebox player device and doing edit shows the correct MAC address.

Type and model are I assume correct Autolog Squeezebox , squeezebox player

It all looks good; apart from it's like the plugin can't see the players

Posted on
Sat Jul 29, 2017 2:20 pm
autolog offline
Posts: 2955
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1]

Re: Player shows as disconnected

So did you manually add the players or did the plugin discover them when it started and connected to the server?

There may be a problem in the plugin if you manually enter the MAC address - I am not sure.
If the address is not showing then that is probably the problem. :?

I am currently working my way through a change to the Squeezebox plugin to update it for Indigo 7.
However this is taking a back seat while I am working on an update to the Alexa-Hue Bridge plugin.
I won't be able to fix anything with it (if it needs fixing) until I have done that update. :|

Posted on
Sat Jul 29, 2017 2:29 pm
pocster offline
User avatar
Posts: 223
Joined: Nov 15, 2014

Re: Player shows as disconnected

Appreciate your help
Yeah I had to add them manually they didn't auto discover .
Cheers

Posted on
Sun Jul 30, 2017 7:09 am
pocster offline
User avatar
Posts: 223
Joined: Nov 15, 2014

Re: Player shows as disconnected

Rebooted everything; including pi's works like a charm :D

Posted on
Sun Jul 30, 2017 8:01 am
autolog offline
Posts: 2955
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1]

Re: Player shows as disconnected

Thanks for letting me know and glad it is working for you. :)

Posted on
Mon Jul 31, 2017 5:32 am
pocster offline
User avatar
Posts: 223
Joined: Nov 15, 2014

Re: Player shows as disconnected

Yeah it was very strange!

Everything seemed 'right; i.e. no errors or anything ; but didn't connect.

I did reboot practically everything in my electronic universe though 8)

It's a TOP plugin!

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests