Restore speakers isn't working

Posted on
Wed Apr 19, 2017 1:48 pm
mgolden50 offline
Posts: 78
Joined: Jan 29, 2007
Location: Sedona, AZ

Restore speakers isn't working

Hi,

I can't seem to get the Save and Restore Speaker settings function of the Airfoil Pro plugin to work.
Everything else works fine.

I have created to Action Groups. One excuses the command to save the settings and the other is suppose to restore them but does not.

Any help much appreciated.

Mike

Posted on
Wed Apr 19, 2017 4:17 pm
jay (support) offline
Site Admin
User avatar
Posts: 14156
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Restore speakers isn't working

So, you execute the action group to save the speaker states, change the speaker configuration in Airfoil, then run the restore action group and nothing happens? What shows up in the event log? Are you sure you have the same Airfoil instance selected for both actions?

[MODERATOR NOTE] moved to a new topic since the post didn't appear to have any connection to the original post on the previous topic

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Wed Apr 19, 2017 4:48 pm
mgolden50 offline
Posts: 78
Joined: Jan 29, 2007
Location: Sedona, AZ

Re: Restore speakers isn't working

Hi Jay,

The name of the Action Group shows up in the log but no indication from the Airfoil plug-in itself.
When I select the Airfoil device commands for save an restore in settings button asks for which device an only offers the computer name on which Indigo is running.

Thx

Mike

Posted on
Wed Apr 19, 2017 4:51 pm
mgolden50 offline
Posts: 78
Joined: Jan 29, 2007
Location: Sedona, AZ

Re: Restore speakers isn't working

Jay,

Also when I use the plugin to change volume of a speaker etc. That seems to work just fine. So that would indicated I'm connected to the correct Airfoil instance.

Mike

Posted on
Thu Apr 20, 2017 9:15 am
jay (support) offline
Site Admin
User avatar
Posts: 14156
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Restore speakers isn't working

Take screenshots of the action configuration for each action group and attach them to a reply. Also, do a couple of save/restore attempts, then email me (support@indigodomo.com) the log file located here:

Code: Select all
/Library/Application Support/Perceptive Automation/Indigo 7/Logs/indigoplugin.airfoilpro/plugin.log


I've tested here and can't reproduce your error so I'm not sure what's going on.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Apr 20, 2017 6:12 pm
mgolden50 offline
Posts: 78
Joined: Jan 29, 2007
Location: Sedona, AZ

Re: Restore speakers isn't working

Hi Jay,

Here are the screen shots and log file.

Thx

Mike
Attachments
Screen Shot 2017-04-20 at 5.09.25 PM.png
Screen Shot 2017-04-20 at 5.09.25 PM.png (80.75 KiB) Viewed 1099 times
Screen Shot 2017-04-20 at 5.09.01 PM.png
Screen Shot 2017-04-20 at 5.09.01 PM.png (93.03 KiB) Viewed 1099 times
plugin.log
(337.59 KiB) Downloaded 40 times

Posted on
Fri Apr 21, 2017 9:26 am
jay (support) offline
Site Admin
User avatar
Posts: 14156
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Restore speakers isn't working

Email your database file to me (support@indigodomo.com) and reference this thread.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Apr 21, 2017 11:28 am
jay (support) offline
Site Admin
User avatar
Posts: 14156
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Restore speakers isn't working

Got it. So, the saved states for the Bentley instance are (I added the names):

Code: Select all
<Item type="vector">
   <Item type="integer">264640194</Item> "Computer (Bentley computer)"
   <Item type="bool">false</Item>
</Item>
<Item type="vector">
   <Item type="integer">230052898</Item> "Living Room Audio (Bentley speaker)"
   <Item type="bool">true</Item>
</Item>
<Item type="vector">
   <Item type="integer">84032930</Item> "Guest Room Apple TV (Bentley speaker)"
   <Item type="bool">false</Item>
</Item>
<Item type="vector">
   <Item type="integer">18053306</Item> "Living Room TV (Bentley speaker)"
   <Item type="bool">false</Item>
</Item>
<Item type="vector">
   <Item type="integer">764935546</Item> "Audio Kitchen (Bentley speaker)"
   <Item type="bool">true</Item>
</Item>
<Item type="vector">
   <Item type="integer">1720884594</Item> "Auio/Video Office (Bentley speaker)"
   <Item type="bool">true</Item>
</Item>
<Item type="vector">
   <Item type="integer">278912722</Item> "Audio Patio (Bentley speaker)"
   <Item type="bool">true</Item>
</Item>
<Item type="vector">
   <Item type="integer">1405125662</Item> "Audio/Video Bedroom (Bentley speaker)"
   <Item type="bool">false</Item>
</Item>
<Item type="vector">
   <Item type="integer">698982196</Item> "Audio/Video Guest Room (Bentley speaker)"
   <Item type="bool">false</Item>
</Item>
<Item type="vector">
   <Item type="integer">769444582</Item> "Apple TV Guest Room (Bentley speaker)"
   <Item type="bool">false</Item>
</Item>
<Item type="vector">
   <Item type="integer">1393587362</Item> "Apple TV Bedroom"
   <Item type="bool">false</Item>
</Item>


true indicates it should be connected, false disconnected. This is the saved set from the last time you issued the save and what would be restored the next time you restore. (I'd highly recommend deleting all those other speakers to make debugging easier).

So, your database looks fine. It has a saved set, the restore should restore the speakers to the above state (I can't test it since I don't actually have any of those). I can say I don't see any reason why it shouldn't be working (and, again, I can't reproduce your issue).

Make sure Airfoil is running, disconnect all the speakers in the Airfoil interface, then switch back to Indigo and execute the "Alexa Speaks-- Restore Previous Music Settings" action group. These devices should connect:

  • Living Room Audio (Bentley speaker)
  • Audio Kitchen (Bentley speaker)
  • Auio/Video Office (Bentley speaker)
  • Audio Patio (Bentley speaker)

Assuming you haven't done a save since you sent me your DB. If you did, then get the DB from the email you sent me (message should be in the Sent folder), open it, then do the steps above again.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Apr 21, 2017 12:26 pm
mgolden50 offline
Posts: 78
Joined: Jan 29, 2007
Location: Sedona, AZ

Re: Restore speakers isn't working

Hi Jay,

As always, thanks for your incredible support and a fantastic product.

As it turns out, I had a significant misunderstanding about what the Airfoil Pro plug-in did with the save and restore function. I thought in saved volume levels for all speakers as well as on/off status.
so the restore function was indeed working as designed. I'll implement a script that will save and restore the volume settings and audio source to use in conjunction with Airfoil's functionality.

Another issue I have with the plugin is that when I use it to create an Airfoil action like selecting a speaker, the list of available speakers that shows up to choose from contains not only current speakers in my system but speakers i removed long ago from my Airport router's list of speakers. How do I cause that list of available speakers to get cleaned up. The list is correct in the Airfoil app but not when presented by Indigo.

Thanks,

Mike

Posted on
Fri Apr 21, 2017 1:29 pm
jay (support) offline
Site Admin
User avatar
Posts: 14156
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Restore speakers isn't working

http://wiki.indigodomo.com/doku.php?id= ... ro#speaker

Use the Plugins->Airfoil Pro->Permanently Delete Speaker... menu item.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests