LED Simple Effects Plugin

Posted on
Fri Jun 05, 2020 10:19 am
jltnol offline
Posts: 492
Joined: Oct 15, 2013

Re: LED Simple Effects Plugin

Hey Glenn

This is the info on the Fibro device from the "define and sync" tab in Devices:

RGBW Controller (FGRGBWM441), firmware 25.25

didn't even think if this device is supported... as I think I might have had this working at one point, but it's been a year or two, and I honestly don't remember.

Posted on
Fri Jun 05, 2020 5:05 pm
GlennNZ offline
Posts: 747
Joined: Dec 07, 2014
Location: Central Coast, Australia

LED Simple Effects Plugin

jltnol wrote:
Hey Glenn

This is the info on the Fibro device from the "define and sync" tab in Devices:

RGBW Controller (FGRGBWM441), firmware 25.25

didn't even think if this device is supported... as I think I might have had this working at one point, but it's been a year or two, and I honestly don't remember.


Hmmm. That is the same as mine - when you ‘write device details to event log’ can you copy and paste what you get?

Seems to be same as my model but is reporting its name as something different, in the device model bit.

Found it - updated device at my end and indigo has renamed the model - presumably because now the 442 one as well - easy fix for this one.

There is a seemingly newer version - 442 model - which has a different altogether mechanism for selecting built in colours/different parameter value. This 441 seems to be the same.

Will do best to add support for both shortly, once know what is different, and update store.

Glenn


Sent from my iPad using Tapatalk

Posted on
Fri Jun 05, 2020 5:52 pm
GlennNZ offline
Posts: 747
Joined: Dec 07, 2014
Location: Central Coast, Australia

Re: LED Simple Effects Plugin

New version 0.2.2 in Pluginstore

Updates indigo device name changes.
Supports 441 version.
Add support for 442 version - which is untested.
Code tidy/Remove update github code


Sent from my iPad using Tapatalk

Posted on
Sat Jun 06, 2020 10:41 am
jltnol offline
Posts: 492
Joined: Oct 15, 2013

Re: LED Simple Effects Plugin

Busy weekend. Will post results very soon.

THANK YOU for your attention to this. I know nothing about coding, but more than appreciate those who do, and take time to make Indigo what it is.

Posted on
Wed Jun 10, 2020 7:34 pm
jltnol offline
Posts: 492
Joined: Oct 15, 2013

Re: LED Simple Effects Plugin

Hey Glenn

Sorry for the late reply. The plugin update worked! The preset effect now work as expected. I vaguely seem to recall a lot more parameters in the plugin to set such as time and fade/on-off, that don't show up here.... not that it matters

Just curious if there are/were any more built in effects just not implemented. The log shows the parameter changes, so could do that from Indigo easily enough...

Posted on
Wed Jun 10, 2020 7:41 pm
GlennNZ offline
Posts: 747
Joined: Dec 07, 2014
Location: Central Coast, Australia

Re: LED Simple Effects Plugin

jltnol wrote:
Hey Glenn

Sorry for the late reply. The plugin update worked! The preset effect now work as expected. I vaguely seem to recall a lot more parameters in the plugin to set such as time and fade/on-off, that don't show up here.... not that it matters

Just curious if there are/were any more built in effects just not implemented. The log shows the parameter changes, so could do that from Indigo easily enough...
No problem.

All the built in effects are included. The Aeotec, aeon labs RGB bulbs have some timing/colour/complicated options.

All the plugin does is change the correct parameter - so is very simple, hence the name. (although the parameter settings for the other rgb bulbs are a bit harder to work out)

Glenn


Sent from my iPad using Tapatalk

Posted on
Thu Jun 11, 2020 10:33 am
jltnol offline
Posts: 492
Joined: Oct 15, 2013

Re: LED Simple Effects Plugin

it's perfect!

Thanks again for your help!

Posted on
Tue Jun 23, 2020 11:17 am
ELWOOD offline
Posts: 227
Joined: Feb 11, 2007
Location: Ramsey, NJ

Re: LED Simple Effects Plugin

Hi Glen
Trying to get your plugin to work with the newest version of the Fibaro RGBW controller 2 FGRGBW-442. Have your newest ver V0.2.2 that you list as untested. When setting up set LED Mode the "LED Effect" is grayed.

Could this be just a naming problem, on define and sync I get the following model name:


Z-Wave Syncing - retrieved manufacture and model names: Fibaro System - 010F, RGBW Controller (FGRGBW442) - 09022000
Z-Wave Syncing - retrieved protocol version 6.04, app version 5.00

Let me know if you need any additional info. Hope we can get this to work

Thanks
Elwood

Posted on
Wed Jun 24, 2020 4:02 am
GlennNZ offline
Posts: 747
Joined: Dec 07, 2014
Location: Central Coast, Australia

LED Simple Effects Plugin

ELWOOD wrote:
Hi Glen
Trying to get your plugin to work with the newest version of the Fibaro RGBW controller 2 FGRGBW-442. Have your newest ver V0.2.2 that you list as untested. When setting up set LED Mode the "LED Effect" is grayed.

Could this be just a naming problem, on define and sync I get the following model name:


Z-Wave Syncing - retrieved manufacture and model names: Fibaro System - 010F, RGBW Controller (FGRGBW442) - 09022000
Z-Wave Syncing - retrieved protocol version 6.04, app version 5.00

Let me know if you need any additional info. Hope we can get this to work

Thanks
Elwood

Quite likely. (Last naming issue was made easier because I discovered my devices were the 441 just needed to define and sync to face the same issue)
Nothing obvious - code seems to use same name.

Can you post debug log from the plugin (turn on all debug options) and create action group, select LED etc. then either post or PM.

That will let us know model name and firmware - which might be naming issue.

Thanks


Sent from my iPad using Tapatalk

Who is online

Users browsing this forum: No registered users and 0 guests