Errors when running

Posted on
Mon Nov 14, 2016 6:13 am
CelticWebs offline
Posts: 14
Joined: Mar 05, 2016

Errors when running

I've just installed the latest plugin and it's installed on the latest version 7 Indigo on my Mac mini server.

I can pull my EvoHome Device Id's and add each device as I'd expect.

The problem arrises when I try and use one, I get the following errors

14 Nov 2016, 12:10:47
Honeywell [Glass Radiators]: Setting HVAC Mode to: Heat
Honeywell Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 67, in actionControlThermostat
File "/Library/Application Support/Perceptive Automation/Indigo 7/Plugins/Honeywell.indigoPlugin/Contents/Server Plugin/Honeywell.py", line 915, in actionControlThermostat
KeyError: key setpointHeat not found in dict

Is there a problem with the plugin or my setup please?

Posted on
Mon Nov 14, 2016 7:40 am
nlagaros offline
Posts: 1585
Joined: Dec 20, 2010

Re: Errors when running

Would you post all log entries please from plugin startup. Also turn on debug mode - that will help isolate the issue. Thanks.

CelticWebs wrote:
I've just installed the latest plugin and it's installed on the latest version 7 Indigo on my Mac mini server.

I can pull my EvoHome Device Id's and add each device as I'd expect.

The problem arrises when I try and use one, I get the following errors

14 Nov 2016, 12:10:47
Honeywell [Glass Radiators]: Setting HVAC Mode to: Heat
Honeywell Error Error in plugin execution ExecuteAction:

Traceback (most recent call last):
File "plugin.py", line 67, in actionControlThermostat
File "/Library/Application Support/Perceptive Automation/Indigo 7/Plugins/Honeywell.indigoPlugin/Contents/Server Plugin/Honeywell.py", line 915, in actionControlThermostat
KeyError: key setpointHeat not found in dict

Is there a problem with the plugin or my setup please?

Posted on
Thu Dec 22, 2016 9:55 am
mjannusch offline
Posts: 5
Joined: Jul 07, 2016

Re: Errors when running

I was previously on 0.4.4 and would get five errors in the log on each device refresh. On 0.5.0 I now only get one, so that's a big improvement for me as far as not spamming the log as much. Thanks!

0.4.4:

Dec 22, 2016, 9:45:54 AM
Honeywell Error [Thu Dec 22 09:45:54 2016] No value found for device: Back Garage Thermostat, field: thermostatMode
Honeywell Error [Thu Dec 22 09:45:54 2016] No value found for device: Back Garage Thermostat, field: setpointCool
Honeywell Error [Thu Dec 22 09:45:54 2016] No value found for device: Back Garage Thermostat, field: setpointStatus
Honeywell Error [Thu Dec 22 09:45:54 2016] No value found for device: Back Garage Thermostat, field: nextTime
Honeywell Error [Thu Dec 22 09:45:54 2016] No value found for device: Back Garage Thermostat, field: fanMode

0.5.0:

Starting plugin "Honeywell 0.5.0" (pid 77517)
Started plugin "Honeywell 0.5.0"
Honeywell Your plugin version, v0.5.0, is current.
Honeywell [Thu Dec 22 09:52:09 2016] Authenticated to TCC Web API.
Honeywell [Thu Dec 22 09:52:09 2016] Processed plugin preferences.
Honeywell Debug Starting device: Back Garage Thermostat
Honeywell Debug [Thu Dec 22 09:52:09 2016] Thermostat: Back Garage Thermostat, Enabled: True
Honeywell Initializing thermostat device: Back Garage Thermostat
Honeywell Debug Updating Device: Back Garage Thermostat, State: temperatureInput1, Value: 0
Honeywell Debug Updating Device: Back Garage Thermostat, State: indoorHumidityStatus, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: indoorTemperatureStatus, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: macID, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: maxCoolSetpoint, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: maxHeatSetpoint, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: minCoolSetpoint, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: minHeatSetpoint, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: name, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: nextTime, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: outdoorHumidity, Value: 0
Honeywell Debug Updating Device: Back Garage Thermostat, State: outdoorHumidityStatus, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: scheduleCapable, Value: False
Honeywell Debug Updating Device: Back Garage Thermostat, State: scheduleCoolSp, Value: 0
Honeywell Debug Updating Device: Back Garage Thermostat, State: scheduleHeatSp, Value: 0
Honeywell Debug Updating Device: Back Garage Thermostat, State: setpointStatus, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: thermostatAllowedModes, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: thermostatMode, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: thermostatModelType, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: thermostatVersion, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: lastUpdate, Value:
Honeywell Debug Updating Device: Back Garage Thermostat, State: lastUpdate, Value: 1482421930.31
Honeywell Debug Updating Device: Back Garage Thermostat, State: macID, Value: 00D02D603602
Honeywell Debug Updating Device: Back Garage Thermostat, State: name, Value: Back Garage
Honeywell Debug Updating Device: Back Garage Thermostat, State: thermostatModelType, Value: FOCUS_PRO_WIFI_RETAIL
Honeywell Debug Updating Device: Back Garage Thermostat, State: thermostatVersion, Value: 02.01.03.01
Honeywell Debug Updating Device: Back Garage Thermostat, State: thermostatAllowedModes, Value: Heat,Off
Honeywell Debug Updating Device: Back Garage Thermostat, State: thermostatMode, Value: Heat
Honeywell Debug Updating Device: Back Garage Thermostat, State: setpointStatus, Value: Scheduled
Honeywell Debug Updating Device: Back Garage Thermostat, State: nextTime, Value: 2000-01-01T22:00:00
Honeywell Debug Updating Device: Back Garage Thermostat, State: temperatureInput1, Value: 45.0
Honeywell Debug Updating Device: Back Garage Thermostat, State: indoorTemperatureStatus, Value: Measured
Honeywell Debug Updating Device: Back Garage Thermostat, State: indoorHumidityStatus, Value: NotAvailable
Honeywell Error [Thu Dec 22 09:52:10 2016] No value found for device: Back Garage Thermostat, field: fanMode
Honeywell Debug Updating Device: Back Garage Thermostat, State: maxCoolSetpoint, Value: 99.0
Honeywell Debug Updating Device: Back Garage Thermostat, State: maxHeatSetpoint, Value: 90.0
Honeywell Debug Updating Device: Back Garage Thermostat, State: minCoolSetpoint, Value: 50.0
Honeywell Debug Updating Device: Back Garage Thermostat, State: minHeatSetpoint, Value: 40.0
Honeywell Debug Updating Device: Back Garage Thermostat, State: outdoorHumidity, Value: 128.0
Honeywell Debug Updating Device: Back Garage Thermostat, State: outdoorHumidityStatus, Value: NotAvailable
Honeywell Debug Updating Device: Back Garage Thermostat, State: scheduleCapable, Value: True
Honeywell Debug Updating Device: Back Garage Thermostat, State: scheduleCoolSp, Value: 78.0
Honeywell Debug Updating Device: Back Garage Thermostat, State: scheduleHeatSp, Value: 45.0
Honeywell Debug Method: runConcurrentThread
Honeywell Debug Running Concurrent Thread

Dec 22, 2016, 9:52:40 AM
Honeywell Debug Updating Device: Back Garage Thermostat, State: lastUpdate, Value: 1482421960.83
Honeywell Error [Thu Dec 22 09:52:40 2016] No value found for device: Back Garage Thermostat, field: fanMode

Dec 22, 2016, 9:53:11 AM
Honeywell Debug Updating Device: Back Garage Thermostat, State: lastUpdate, Value: 1482421991.23
Honeywell Error [Thu Dec 22 09:53:11 2016] No value found for device: Back Garage Thermostat, field: fanMode

Posted on
Thu Dec 29, 2016 6:03 am
nlagaros offline
Posts: 1585
Joined: Dec 20, 2010

Re: Errors when running

Would you be able to run the Dump JSON action against this thermostat and send me the output. I'm working on smartening up the plugin to adapt to various thermostat models. Thanks.

Posted on
Tue Jan 03, 2017 4:41 pm
mjannusch offline
Posts: 5
Joined: Jul 07, 2016

Re: Errors when running

PM with JSON dump sent. Thanks!

Posted on
Wed Jan 04, 2017 6:48 pm
nlagaros offline
Posts: 1585
Joined: Dec 20, 2010

Re: Errors when running

Thanks. This will help. Will try to get an update out over the weekend.

Posted on
Wed Feb 01, 2017 9:43 pm
mjannusch offline
Posts: 5
Joined: Jul 07, 2016

Re: Errors when running

Nick, is there anything you needed tested or any additional information? Thanks!

Posted on
Wed Jul 05, 2017 10:19 am
nlagaros offline
Posts: 1585
Joined: Dec 20, 2010

Re: Errors when running

I just posted an update. Check it out: http://vulture:8000/wordpress/home/honeywell-thermostats/

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests