Timers not starting.

Posted on
Wed Sep 14, 2016 3:23 pm
gsades offline
Posts: 18
Joined: Aug 17, 2016

Timers not starting.

Timers have become an important part of my implementation. First timers worked well, but now they don't want to cooperate anymore. Whenever a trigger is supposed to start a timer, 80% of times it won't.
The typical use is very simple:

1. A motion sensor calls a trigger.
2. Trigger checks if conditions are met.
3. Trigger runs a series of tasks which include setting certain time in a timer and turning it on.

Most of the times, the trigger runs the required actions (what let me know the conditions are indeed met), but fails to start the timer without showing any error in the log. Such actions include activating a group, changing one or more variables, typing some feedback to the log, setting time for a timer and starting it. The lights turn on, the variables are updated, the feedback is typed but the timer will not respond.

When working properly, there were 0-4 timers running at once. Now, from time to time, a single one is activated. I have not installed any new plugins recently; the only change I've made is to include different (not simultaneous) triggers to activate the same timer. For example:

-Trigger 1: When S1 detects motion, if time is between 10 and 12, set 10 minutes in timer X and start it (among other actions).
-Trigger 2: When S1 detects motion, if time is between 12 and 14, set 5 minutes in timer X and start it (among other actions).
-Trigger n: When S1 detects motion, if time is between 14 and 16... and so on.

I decided to make a test deleting a timer, creating a new one and updating all related triggers to call the new one. It worked a couple of times, buy failed again in the same way.

Is there any known bug that could explain this? Is there any restriction about timers which I could be missing?

Posted on
Wed Sep 14, 2016 4:56 pm
jay (support) offline
Site Admin
User avatar
Posts: 15149
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Timers not starting.

We've had no reports of this behavior, and there isn't any theoretical limit to the number of timers though if you have over, say, 25 running at the same time they might have some issues.

Are you absolutely sure that you're getting past your conditions? That's the most common reason for actions not firing. Also, make sure you don't have something else that's firing and either causing the timer to stop before you expect it to or makes a change (like the amount of time on a timer). This last one is important: if you're changing the amount of time on a timer in one step and starting it in the next, it's (slightly) possible that the order will be reversed and the start will happen first followed by setting the start time (which would stop the timer). Add a short delay before starting the timer after setting the time and see if that helps.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Wed Sep 14, 2016 10:40 pm
gsades offline
Posts: 18
Joined: Aug 17, 2016

Re: Timers not starting.

Jay,

A 1 second delay in the timer made the trick! Thanks a lot.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests

cron