Not connecting to Indigo server

Posted on
Sun Mar 06, 2016 5:44 pm
gtreece offline
Posts: 168
Joined: Sep 26, 2011

Not connecting to Indigo server

Anyone else having issues getting the 3.0 version to connect to the Indigo Server (with the Indigo action type)? The HR app finds the server when it searches for it, but it's not connecting, and not giving me any messages or anything. The Indigo logs are not showing a connection attempt through the web server.

I'm not new to Indigo, and the web server is working fine. Browser connects are working fine.

I'll try setting up some URL based actions to see what that does. Just wondering if anyone else is having any connectivity problems with HR to Indigo.

Posted on
Sun Mar 06, 2016 6:13 pm
tatrog offline
Posts: 25
Joined: Nov 16, 2013

Re: Not connecting to Indigo server

Just checked and my HR is working fine from iPhone ,apple watch, and Apple TV.


Sent from my iPad using Tapatalk

Posted on
Sun Mar 06, 2016 10:41 pm
gtreece offline
Posts: 168
Joined: Sep 26, 2011

Re: Not connecting to Indigo server

A URL action to trigger an action in Indigo works. Same server address and credentials. So it seems to be something with the Indigo action type in Home Remote, at least as it relates to my server somehow (6.1.6 Pro).

Posted on
Mon Mar 07, 2016 7:42 am
Gary_BBGames offline
Posts: 146
Joined: Sep 14, 2015

Re: Not connecting to Indigo server

I have checked, and my version is 6.1.6 too.
If it was bad username or password it would say, and if it was bad data it would say.
If it failed to connect it would say too.
This leads me to believe the data format is "correct", but it's maybe the format is not what I am expecting or have seen before.
If you could send me your actions.son and devices.json I will load it up and have a look.

Posted on
Mon Mar 07, 2016 9:51 pm
gtreece offline
Posts: 168
Joined: Sep 26, 2011

Re: Not connecting to Indigo server

Gary, I responded to your email, with some json output.

Posted on
Mon Mar 14, 2016 5:11 pm
gtreece offline
Posts: 168
Joined: Sep 26, 2011

Re: Not connecting to Indigo server

Anything yet? I'm still not having any success.

Posted on
Tue Mar 15, 2016 12:42 am
Gary_BBGames offline
Posts: 146
Joined: Sep 14, 2015

Re: Not connecting to Indigo server

Apologies for not getting back to you yet. The whole family came down with something terrible so we've all been out of action. I will endeavour to check today.

Have you upgraded Indigo to tr new 1.7 release?

Posted on
Tue Mar 15, 2016 10:41 am
gtreece offline
Posts: 168
Joined: Sep 26, 2011

Re: Not connecting to Indigo server

Yes, I did update to the 6.1.7 release, and I am seeing the same behavior.

I have tested on iOS 9.2.1 as well as 9.3 beta versions on a separate device. Same results across both.

Posted on
Tue Apr 05, 2016 10:50 pm
gtreece offline
Posts: 168
Joined: Sep 26, 2011

Re: Not connecting to Indigo server

Any ideas yet, as to what might be going on with my setup? I've re-checked periodically, and am continuing to see the same behavior.

Posted on
Tue Apr 05, 2016 11:55 pm
howartp offline
Posts: 3271
Joined: Jan 09, 2014
Location: West Yorkshire, UK

Re: Not connecting to Indigo server

I don't know where you are so this might be a silly question - do you use any foreign or Unicode characters in your device or action names?


Sent from my iPhone using Tapatalk

Posted on
Wed Apr 06, 2016 11:22 pm
gtreece offline
Posts: 168
Joined: Sep 26, 2011

Re: Not connecting to Indigo server

howartp wrote:
I don't know where you are so this might be a silly question - do you use any foreign or Unicode characters in your device or action names?


No, I have not intentionally used any, and have not found any unintentional instances either. I sent my devices and actions json to Gary to look at a while back, and was hoping he found something to explain the behavior.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests