Autolog LIFX Controller Discussion

Posted on
Mon Jun 19, 2017 5:31 pm
kelmk offline
Posts: 73
Joined: May 17, 2017

Re: Autolog LIFX Controller Discussion

Sounds awesome. Can’t wait to try it out after I get back from holiday :)


Sent from my iPhone using Tapatalk

Posted on
Mon Jul 03, 2017 1:40 pm
geoffosler1 offline
Posts: 5
Joined: Jul 03, 2017

Re: Autolog LIFX Controller Discussion

First - love the plugin! Thanks very much for making this happen.

Sadly however, despite having upgraded to the most recent version, my LIFX devices keep disappearing from Indigo. Currently running Indigo 7.0.3 and Autologic v4.1.0

When I disable and reload the plugin, devices will be available and work fine for between 1-5 minutes, after which they'll switch to 'no ack' and stay that way until I reload the plugin.

I have tried factory resetting one of the devices and re-adding it to Indigo, but no luck; same thing.

I'm running 5 A19s, 4 BR30s, 1 Color 1000 and 1 Z LED strip all of which are running the latest firmware (which caused the problem to begin with)

Any advice?

Thanks!

Posted on
Mon Jul 03, 2017 2:05 pm
autolog offline
Posts: 2319
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

geoffosler1 wrote:
First - love the plugin! Thanks very much for making this happen.

Sadly however, despite having upgraded to the most recent version, my LIFX devices keep disappearing from Indigo. Currently running Indigo 7.0.3 and Autologic v4.1.0

When I disable and reload the plugin, devices will be available and work fine for between 1-5 minutes, after which they'll switch to 'no ack' and stay that way until I reload the plugin.

I have tried factory resetting one of the devices and re-adding it to Indigo, but no luck; same thing.

I'm running 5 A19s, 4 BR30s, 1 Color 1000 and 1 Z LED strip all of which are running the latest firmware (which caused the problem to begin with)

Any advice?

Thanks!

Another user has identified something similar but not quite as quick AFAIR. It has happened to me (maybe once a day) and reloading the plugin resolves it.
It has almost got to the top of my list to sort out. :)

Presumably you can still control the LIFX devices from the iOS App?

What is your polling time set to ?

If you turn on all debugging and then reload the plugin and attach the log of the output after the problem occurs and I will see if I can spot anything.

I believe there is a new firmware version coming out in the next week or so that is meant to improve LAN connectivity which may help? :)

Posted on
Mon Jul 03, 2017 5:29 pm
geoffosler1 offline
Posts: 5
Joined: Jul 03, 2017

Re: Autolog LIFX Controller Discussion

Thanks for looking into this, Jon.

Yes - the LIFX iOS app has been working just fine throughout. Polling time is set to 10 sec.

Attached is the log file; hopefully something will catch your eye.

Best,

Geoff.
Attachments
plugin.log
(101.46 KiB) Downloaded 24 times

Posted on
Tue Jul 04, 2017 2:08 am
autolog offline
Posts: 2319
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

I have a suspicion (not yet confirmed) that there might be something adrift in the polling logic. :?

I have my polling set to 5 minutes. Can you try that value and see if the situation improves?

The polling is only to handle the situation where the LIFX lamps might have been altered outside of Indigo e.g. by the iOS App, the aim being to get Indigo back in sync with the state of the lamps.

Thanks for the log. :)

Posted on
Tue Jul 04, 2017 6:56 am
autolog offline
Posts: 2319
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

Looks like it is a bug in the polling logic (not yet resolved) - I switched one of eleven LIFX lamps off and they all went no ack - Definitely not what is intended. :oops:

I'll start work now on trying to resolve it. :)

Posted on
Tue Jul 04, 2017 12:44 pm
geoffosler1 offline
Posts: 5
Joined: Jul 03, 2017

Re: Autolog LIFX Controller Discussion

Tried resetting polling to 5 minutes, but this seemed just to delay the lamps switching to 'no ack' by, well, five minutes. ;)

Thanks again for working on this - also, I feel work of this quality should be at least acknowledged somehow... it's great stuff. Do you have a tip jar or something on Github?

Cheers.

Posted on
Wed Jul 05, 2017 8:02 am
autolog offline
Posts: 2319
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

geoffosler1 wrote:
Tried resetting polling to 5 minutes, but this seemed just to delay the lamps switching to 'no ack' by, well, five minutes. ;)


See the announcement post for version 4.1.3 - hopefully this version will fix the issue - it does for me AFAICS. :)

geoffosler1 wrote:
Thanks again for working on this - also, I feel work of this quality should be at least acknowledged somehow... it's great stuff. Do you have a tip jar or something on Github?


Thanks for the kind words and no I don't have a "tip jar". :)

I am just happy to contribute to the Indigo "ecosystem" and to be able to share my plugins with support on a best endeavours basis with no strings attached. :)

Posted on
Wed Jul 05, 2017 2:12 pm
geoffosler1 offline
Posts: 5
Joined: Jul 03, 2017

Re: Autolog LIFX Controller Discussion

Well, it's been about 5 hours since I installed v4.1.3 and so far, so good! All lamps are online and none have dropped off.

I'll keep you posted if anything changes - and thanks again for all your help!

Posted on
Wed Jul 05, 2017 3:26 pm
autolog offline
Posts: 2319
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

geoffosler1 wrote:
Well, it's been about 5 hours since I installed v4.1.3 and so far, so good! All lamps are online and none have dropped off.

I'll keep you posted if anything changes - and thanks again for all your help!

Thanks for the update. :)

Posted on
Tue Jul 11, 2017 10:51 am
geoffosler1 offline
Posts: 5
Joined: Jul 03, 2017

Re: Autolog LIFX Controller Discussion

Several days in now, and happy to report everything is rock stable. Cheers.

Posted on
Tue Jul 11, 2017 2:04 pm
autolog offline
Posts: 2319
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

That's good news - thanks for the follow-up update. :)

Posted on
Tue Jul 11, 2017 3:10 pm
karlg offline
Posts: 6
Joined: Nov 10, 2010

Re: Autolog LIFX Controller Discussion

I'm probably the other person who had previously reported the problem. I reverted to version 4.0.5, but have been running 4.1.3 for a few days now, and am happy to report not seeing any no acks with that version.

Well done, and thanks Jon!!

Karl

Posted on
Fri Jul 14, 2017 6:42 am
jltnol offline
Posts: 291
Joined: Oct 15, 2013

Re: Autolog LIFX Controller Discussion

So I updated to the latest version of the plugin, but still have one light strip that goes offline occasionally. While in the No Ack mode in Indigo, I can still control it from the iOS app, so its still connected to the network. It does drift on and offline in Indigo.. but it is never off the network.

Otherwise, the other LIFX lights, one bulb, one more strip, works great....

Posted on
Fri Jul 14, 2017 7:54 am
autolog offline
Posts: 2319
Joined: Sep 10, 2013
Location: West Sussex

Re: Autolog LIFX Controller Discussion

That's useful info. :)

What do you have your polling time set to?

Who is online

Users browsing this forum: No registered users and 0 guests