Authentication issue

Posted on
Sun Jun 05, 2022 2:02 pm
t-star offline
Posts: 91
Joined: Oct 26, 2007

Authentication issue

Late on 6/4 I started getting an authentication error.

Code: Select all
 NetatmoWelcome Error            runConcurrentThread() - authentication failed.  Will keep trying.


when I restart the plugin I get the following:

Code: Select all
Started plugin "NetatmoWelcome 2022.0.1"
   NetatmoWelcome                  Starting Netatmo Multi plugin
   NetatmoWelcome                  Renewing expired tokens
   NetatmoWelcome Error            Authentication failed in createDevices
   NetatmoWelcome Error            400 Client Error:  for url: https://api.netatmo.com/oauth2/token
   NetatmoWelcome                  ********************************************************************
   NetatmoWelcome                  Starting Netatmo Multi monitoring thread
   NetatmoWelcome                  New Access and Refresh Tokens will be requested on startup
   NetatmoWelcome                  Weather station(s) will be polled
   NetatmoWelcome                  ********************************************************************


I went out and generated a new client and secret code and pasted that in. Didn't seem to help.
I tried to request a new token in the plugin menu. - didn't help.

I updated to this version a week or two ago and had to have it rebuild my netatmo devices. it seemed to work fine until yesterday.



Any ideas?

Posted on
Sun Jun 12, 2022 12:58 am
racarter offline
User avatar
Posts: 320
Joined: Jun 18, 2016
Location: North Yorkshire, UK

Re: Authentication issue

If the servers are rejecting your authentication credentials it usually means one of four things is wrong: your Netatmo user name, password, client ID or client secret. If these are all OK I can only guess that it’s a temporary issue with the Netatmo servers. If it persists more than a few hours send me a DM and I’ll add some debug code to investigate.

Posted on
Fri Jun 17, 2022 7:15 pm
t-star offline
Posts: 91
Joined: Oct 26, 2007

Re: Authentication issue

Thanks!

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests

cron