Phidgets Plugin Discussion

Posted on
Mon Sep 30, 2019 4:37 am
landry offline
Posts: 32
Joined: Jul 30, 2017

Re: Phidgets Plugin Discussion

Hi Brkinet

I have a apogee barometric sensor connected to phidgets 2/2/2 interface that is plugged int a fidgets SBC3 .
The sensor is configured as a as generic 0-5 volt device. I have tested this several times and it does not update voltage if there is a change unless i unplug the 2/2/2 usb connection and then replug it in. The pressure device changes are very small deltas. The values I get are as expected since I compare to external barometric pressure sensors used as controls. Before I talk to Phidget.com com do have any suggestions?

Thanks for all your support!!!


Dave

Posted on
Mon Sep 30, 2019 8:35 am
berkinet offline
User avatar
Posts: 3404
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

landry wrote:
...The pressure device changes are very small deltas. The values I get are as expected since I compare to external barometric pressure sensors used as controls. Before I talk to Phidget.com com do have any suggestions

The only thing I can think of is the threshold. try setting it to 1, or even 0. Though 0 might change far too often.

Posted on
Tue Oct 01, 2019 5:11 am
landry offline
Posts: 32
Joined: Jul 30, 2017

Re: Phidgets Plugin Discussion

Hi Berkinet

Lowered threshold value to 1 and it worked!!
i guess no change was being posted since barometric trends in changes are very small unless you have a strong storm front. Changes in the volt are in the 0.020 to 0.030 range.

I bought the epogee since I never really got the Phidget absolute pressure to work. Went back and looked at and that now works.!

I recommend to users to apply the 15-115kp pn 1141 (and not the 20-400 kp; changes in voltage would be smaller) for barometric measurements.
Now writing python scripts to report barometric pressure trends.


You are the best Berkinet!

Posted on
Tue Oct 01, 2019 8:25 pm
landry offline
Posts: 32
Joined: Jul 30, 2017

Re: Phidgets Plugin Discussion

Hi Berkinet

After reading the Data Interval/ChangeTriggers section of the phidgets website, your suggestion to change the trigger threshold to 1 makes a lot of sense.

The sensor I am using was configured as a 0-5 volt sensor corresponding 150 Mpacal to 1150 Mpascals.
The barometric range is roughly 950 Mpascals to 1030 Mpascals which approximately corresponds to 4.1 volt to 4.47 volt signal range.
The ChangeTrigger property of a channel enables a filter that only passes data when that data has changed by an amount greater than or equal to the ChangeTrigger. for example, a value of one will pass any signal greater than 1 volt up to the sensor limit which in my case is 5 volts. In other words any signal greater than 1 volt will be recieved when the threshold set at 1. Given the bsrometric range, the thresh old value set a 3 or lower pass all useful data for my sensor.

With threshold defaults set at 10 no signal was ever detected during the data intervals since that setting filters out all signals less than 10 volts.
If the sensor was configured as aaw data 0-1000, that threshold value of 10 will pass any value greater than 10 which is greater than 99% of the raw signal range.

You may want to have minimum threshold set automatically at 0.01 when the user configures the sensor as as a 0-5volt sensor.

I went through this exercise so i could understand the difficulties I was having when setting up a 0-5 volt sensor.

Thanks again for a great plug in.

Posted on
Fri Oct 04, 2019 10:41 am
loafbread offline
Posts: 136
Joined: May 25, 2009

Re: Phidgets Plugin Discussion

Any thought to making the Phidgets22 plugin an MQTT client?
Might make the whole Phidgets interface more flexible or universal.

Posted on
Fri Oct 04, 2019 10:55 am
berkinet offline
User avatar
Posts: 3404
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

loafbread wrote:
Any thought to making the Phidgets22 plugin an MQTT client? ...

No plans at this time. Maybe later.

Posted on
Sun Oct 06, 2019 9:10 pm
hamw offline
Posts: 1199
Joined: Mar 31, 2008

Re: Phidgets Plugin Discussion

I'd like to monitor a wine fridge for temp/humidity. Do you think the best way is to get an SBC and several TH units? Do you think an SBC is easy to setup, even for the marginally technically able? Also I saw the VINT discussion... no reason to go down that path, and it is not supported by the plugin, right?

Posted on
Fri Oct 25, 2019 5:16 am
berkinet offline
User avatar
Posts: 3404
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

hamw wrote:
I'd like to monitor a wine fridge for temp/humidity. Do you think the best way is to get an SBC and several TH units? Do you think an SBC is easy to setup, even for the marginally technically able? Also I saw the VINT discussion... no reason to go down that path, and it is not supported by the plugin, right?

Sorry for the long delay in responding... vacation in Italy :D

Essentially, you need an interfaceKit (like the 1018) and a computer. The SBC3 does that in one package, but it is no longer available. The new SBC4 is a VINT device, though you could connect a 1018 to it. However, the good news is you can achieve the same end with a Raspberry-Pi, a USB hub and a 1018. There are several guides to setting up the R-Pi. Take a look at Instructable for one.

However, rather than using the 1018, you may wish to use a 1048 4-Input temperature sensor and some thermocouples. The 4106 and 4107 would work well for your application. Insert the probe into a wine cork, then fill a wine bottle with water and place the cork firmly into the bottle. You are now measuring the actual temperature of the liquid rather than the air. Or, just buy something like this. You could have up to for bottles placed around the cabinet, plus the one on-board sensor. (BTW, this is exactly what I have done.)

Posted on
Fri Jan 17, 2020 8:01 pm
hamw offline
Posts: 1199
Joined: Mar 31, 2008

Re: Phidgets Plugin Discussion

Hi Berkinet,

Got a new computer and have successfully moved most stuff. By assumption I installed Phidgets v22. No luck so I RTFM and installed Phidgets 21. However while the plugin sees the devices as well as the v21, for some reason my devices are not updating, being stuck on Jan 10 2020.

Do I need to uninstall v22? or are you making progress on V22 and I should wait a bit? How would I uninstall v22 if necessary?

Thanks,

Ham

Posted on
Sat Jan 18, 2020 8:32 am
berkinet offline
User avatar
Posts: 3404
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

hamw wrote:
...Got a new computer and have successfully moved most stuff. By assumption I installed Phidgets v22. No luck so I RTFM and installed Phidgets 21. However while the plugin sees the devices as well as the v21, for some reason my devices are not updating, being stuck on Jan 10 2020.

Do I need to uninstall v22? or are you making progress on V22 and I should wait a bit? How would I uninstall v22 if necessary?

You can leave there v22 libs installed They can co-exist alongside the v21 without problems. I don't hasher any specific idea why the devices are not updating on your new computer. Is this all devices, just interfaceKit sensor, stand-alone Phidgets, or? And how are they attached, and to what? In general, a restart of the plugin should do the trick. Did you try a plugin restart with debugging set at a high level?

Posted on
Sat Jan 18, 2020 10:57 am
hamw offline
Posts: 1199
Joined: Mar 31, 2008

Re: Phidgets Plugin Discussion

I bought a new mini running the latest operating system. Turns out after I re-installed the lib21 I thought I had started the bonjour service but had not. Since enabling Bonjour all appears well now. That said, it seems the Phidgets boards do not run on USB 3 ports? I was trying different things and it all came back together when plugged into USB 2.

I do now get this error:

Code: Select all
   Started plugin "Phidgets Plugin 0.7.4"
   Phidgets Plugin                 Plugin Startup.
   Phidgets Plugin                 Your plugin version, v0.7.4, is current.
   Phidgets Plugin ifKit Error     inferfaceKitAttached error '1650378619'
   Phidgets Plugin ifKit           Setup for InterfaceKit "Phidgets 8/8/8 TempHumidity" complete, device Available
   Phidgets Plugin ifKit           Setup for InterfaceKit "Phidgets 8/8/8 Water Valves" complete, device Available
Last edited by hamw on Sat Jan 18, 2020 4:11 pm, edited 1 time in total.

Posted on
Sat Jan 18, 2020 11:12 am
berkinet offline
User avatar
Posts: 3404
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

hamw wrote:
I bought a new mini running the latest operating system. Turns out after I re-installed the lib21 I thought I had started the bonjour service but had not. Since enabling Bonjour all appears well now. That said, it seems the Phidgets boards do not run on USB 3 ports? I was trying different things and it all came back together when plugged into USB 2.

I do now get this error:
    Started plugin "Phidgets Plugin 0.7.4"
    Phidgets Plugin Plugin Startup.
    Phidgets Plugin Your plugin version, v0.7.4, is current.
    Phidgets Plugin ifKit Error inferfaceKitAttached error '1650378619'
    Phidgets Plugin ifKit Setup for InterfaceKit "Phidgets 8/8/8 TempHumidity" complete, device Available
    Phidgets Plugin ifKit Setup for InterfaceKit "Phidgets 8/8/8 Water Valves" complete, device Available
...
Glad you got it working. The error you note seems to happen only at plugin startup and may be caused by the plugin trying to do something out-of-order. I see it here as well and have never found the cause. If everything else seems to be working, just ignore it.

The interfaceKits should work on a USB-3 port. If they don't, I'd contact Phidgets.

The v2.2 plugin is moving slowly. We have a core plugin running, but not enough functionality or device support to share yet. I am hoping it will be done by summer.

Posted on
Sat Jan 18, 2020 4:12 pm
hamw offline
Posts: 1199
Joined: Mar 31, 2008

Re: Phidgets Plugin Discussion

Thanks very much. Would be interested in the VINT compatible plugin when available.

Posted on
Sun Feb 16, 2020 11:05 pm
hamw offline
Posts: 1199
Joined: Mar 31, 2008

Re: Phidgets Plugin Discussion

Phidgets Web Service stopped starting automatically when I got my new computer with 14.6. I wrote this external script that will start the WebService automatically when run. Hopefully it will continue to work down the road.

Code: Select all
tell application "System Preferences"
   activate
   set current pane to pane "Phidgets"
   activate current pane
end tell

delay 1
try
tell application "System Events"
   if UI elements enabled then
      click radio button "Web Service" of tab group 1 of window "Phidgets" of application process "System Preferences"
      tell tab group 1 of window ¬
         "Phidgets" of process "System Preferences"
         click button "Start WebService"
      end tell
   end if
end tell
end try  -- this will keep it from throwing an error and hanging if the WebService is already running.

delay 1

tell application "System Preferences" to quit

Posted on
Mon Feb 17, 2020 2:17 am
berkinet offline
User avatar
Posts: 3404
Joined: Nov 18, 2008
Location: Berkeley, CA, USA & Mougins, France

Re: Phidgets Plugin Discussion

hamw wrote:
Phidgets Web Service stopped starting automatically when I got my new computer with 14.6. I wrote this external script that will start the WebService automatically when run. Hopefully it will continue to work down the road. ...

Interesting approach. However, I had no problems on Mojave or Catalina. So, I suspect there is something amiss on your machine. Have you scanned the console logs to see if there are any clues?

Who is online

Users browsing this forum: No registered users and 1 guest