[Errno 64] Host is down [Errno 32] Broken pipe NO devices

Posted on
Wed Sep 04, 2019 9:25 am
johnnyrt offline
Posts: 7
Joined: Feb 06, 2014

[Errno 64] Host is down [Errno 32] Broken pipe NO devices

Alexa never seems to discover any devices. I'm having an been trying to fix this for an embarrassing amount of time now.

Here's my log:

Sep 4, 2019 at 1:14:02 AM
Disabling plugin "Alexa-Hue Bridge 3.0.32"
Stopping plugin "Alexa-Hue Bridge 3.0.32" (pid 915)
Alexa-Hue Bridge Alexa-Hue Bridge shutdown requested
Alexa-Hue Bridge HTTP server stopping...
Alexa-Hue Bridge HTTP server stopped
Alexa-Hue Bridge HTTP server stopping...
Alexa-Hue Bridge HTTP server stopped
Stopped plugin "Alexa-Hue Bridge 3.0.32"
Enabling plugin "Alexa-Hue Bridge 3.0.32"
Starting plugin "Alexa-Hue Bridge 3.0.32" (pid 1002)
Alexa-Hue Bridge Alexa-Hue Bridge initialising . . .
Alexa-Hue Bridge Plugin Host IP Address is discovered as: '192.168.1.2'
Alexa-Hue Bridge Alexa discovery request logging enabled
Alexa-Hue Bridge Warning Debugging enabled for Alexa-Hue Bridge: General, Server, Broadcaster, Responder, non-Echo Network Filter, Method Trace
Started plugin "Alexa-Hue Bridge 3.0.32"
Alexa-Hue Bridge Alexa-Hue Bridge initialization complete
Alexa-Hue Bridge 'ALEX Test bridge' has one Alexa Device published
Alexa-Hue Bridge Starting Hue Bridge 'ALEX Test bridge' web server thread
Alexa-Hue Bridge Starting Hue Bridge 'ALEX Test bridge' discovery thread as 'Auto Start Discovery' requested
Alexa-Hue Bridge Alexa-Hue Bridge 'ALEX Test bridge' started: Host: 192.168.1.2 Port: 8178
Alexa-Hue Bridge 'ALEXA BRIDGE 1' has u3 Alexa Devices published
Alexa-Hue Bridge Starting Hue Bridge 'ALEXA BRIDGE 1' web server thread
Alexa-Hue Bridge Starting Hue Bridge 'ALEXA BRIDGE 1' discovery thread as 'Auto Start Discovery' requested
Alexa-Hue Bridge Alexa-Hue Bridge 'ALEXA BRIDGE 1' started: Host: 192.168.1.2 Port: 8180
Alexa-Hue Bridge Alexa-Hue Bridge checking network access by attempting to access 'www.google.com'
Alexa-Hue Bridge Alexa-Hue Bridge network access check to http://www.google.com successfully completed.

Sep 4, 2019 at 1:15:28 AM
Alexa-Hue Bridge Error 'ALEXA BRIDGE 1' Responder.run: socket error: [Errno 64] Host is down
Alexa-Hue Bridge Error 'ALEX Test bridge' Responder.run: socket error: [Errno 64] Host is down

Sep 4, 2019 at 1:23:43 AM
Alexa-Hue Bridge Error plugin does not define method checkRateLimit

Sep 4, 2019 at 1:33:11 AM
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='[Errno 32] Broken pipe'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'ALEXA BRIDGE 1'. Line '185' has error='[Errno 32] Broken pipe'


Does anyone have any ideas on what could be causing "Responder.run: socket error: [Errno 64] Host is down"
I have edited the hosts file,
Reinstalled the plugin.
Forgetting all devices on alexa.amazon.com
UpnP is on.
lsof -i :1900
Port forwarded set (just in case)
many many tests
My bridge logs are all turned on, however I don't think my echos are communicating in bound.

Thanks for any help.

Posted on
Wed Sep 04, 2019 9:26 am
johnnyrt offline
Posts: 7
Joined: Feb 06, 2014

Re: [Errno 64] Host is down [Errno 32] Broken pipe NO devic

Now I also have this:
Sep 4, 2019 at 3:08:23 AM
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='[Errno 32] Broken pipe'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'ALEXA BRIDGE 1'. Line '185' has error='[Errno 32] Broken pipe'

Sep 4, 2019 at 3:38:13 AM
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='[Errno 32] Broken pipe'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'ALEX Test bridge'. Line '185' has error='[Errno 32] Broken pipe'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='[Errno 32] Broken pipe'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'ALEXA BRIDGE 1'. Line '185' has error='[Errno 32] Broken pipe'

Sep 4, 2019 at 4:13:18 AM
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='[Errno 32] Broken pipe'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'ALEXA BRIDGE 1'. Line '185' has error='[Errno 32] Broken pipe'

Sep 4, 2019 at 4:45:24 AM
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='[Errno 32] Broken pipe'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'ALEXA BRIDGE 1'. Line '185' has error='[Errno 32] Broken pipe'

Sep 4, 2019 at 5:50:19 AM
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='[Errno 32] Broken pipe'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'ALEX Test bridge'. Line '185' has error='[Errno 32] Broken pipe'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='[Errno 32] Broken pipe'

Posted on
Fri Sep 06, 2019 2:46 am
autolog offline
Posts: 3243
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: [Errno 64] Host is down [Errno 32] Broken pipe NO devic

What version Echo or Echo Dots are you running and what is their firmware version?

Can you also update to the latest version of the plugin 3.0.34 @ http://www.indigodomo.com/pluginstore/13/ and then try again and post the errors. :)

Posted on
Sat Sep 07, 2019 11:28 am
johnnyrt offline
Posts: 7
Joined: Feb 06, 2014

Re: [Errno 64] Host is down [Errno 32] Broken pipe NO devic

I have several, Echo 1st gen, a first gen dot, 1st gen echo show, an Echo Show 5 (small one) and 3 echo dots 2nd gen.

I'm running the newest version alexa hue bridge on a mac mini that had osx server insalled before ( I already edited the HOSTS file)

I'm not 100% sure my HOSTS file is correct, can someone let me know:

Code: Select all
##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1   localhost
255.255.255.255   broadcasthost
::1             localhost
fe80::1%lo0   localhost

192.168.1.2 Thompson-Server
192.168.1.2 Thompson-Server.local

Posted on
Sat Sep 07, 2019 11:32 am
johnnyrt offline
Posts: 7
Joined: Feb 06, 2014

Re: [Errno 64] Host is down [Errno 32] Broken pipe NO devic

After reloading the plugin:
Code: Select all
   Enabling plugin "Alexa-Hue Bridge 3.0.34"
   Starting plugin "Alexa-Hue Bridge 3.0.34" (pid 41612)
   Alexa-Hue Bridge                Alexa-Hue Bridge initialising . . .
   Alexa-Hue Bridge                Plugin Host IP Address overridden and specified as: '192.168.1.2'
   Alexa-Hue Bridge                Alexa discovery request logging enabled
   Alexa-Hue Bridge Warning        Debugging enabled for Alexa-Hue Bridge: General, Server, Broadcaster, Responder, non-Echo Network Filter, Method Trace
   Started plugin "Alexa-Hue Bridge 3.0.34"
   Alexa-Hue Bridge                Alexa-Hue Bridge initialization complete
   Alexa-Hue Bridge                'ALEX Test bridge' has one Alexa Device published
   Alexa-Hue Bridge                Starting Hue Bridge 'ALEX Test bridge' web server thread
   Alexa-Hue Bridge                Starting Hue Bridge 'ALEX Test bridge' discovery thread as 'Auto Start Discovery' requested
   Alexa-Hue Bridge                Alexa-Hue Bridge 'ALEX Test bridge' started: Host: 192.168.1.2 Port: 8178
   Alexa-Hue Bridge                'ALEXA BRIDGE 1' has u3 Alexa Devices published
   Alexa-Hue Bridge                Starting Hue Bridge 'ALEXA BRIDGE 1' web server thread
   Alexa-Hue Bridge                Starting Hue Bridge 'ALEXA BRIDGE 1' discovery thread as 'Auto Start Discovery' requested
   Alexa-Hue Bridge                Alexa-Hue Bridge 'ALEXA BRIDGE 1' started: Host: 192.168.1.2 Port: 8180
   Alexa-Hue Bridge                Alexa-Hue Bridge checking network access by attempting to access 'www.google.com'
   Alexa-Hue Bridge                Alexa-Hue Bridge network access check to www.google.com successfully completed.

Sep 7, 2019 at 10:31:37 AM
   Alexa-Hue Bridge Error          'ALEXA BRIDGE 1' Responder.run: socket error: [Errno 65] No route to host
   Alexa-Hue Bridge Error          'ALEX Test bridge' Responder.run: socket error: [Errno 64] Host is down




Terminal sudo lsof -i :1900:
Code: Select all
Thompson-Server:~ johnthompson$ sudo lsof -i :1900
COMMAND     PID         USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME
IndigoPlu 20910 johnthompson   10u  IPv4 0x9f9e407f7df7d3ff      0t0  UDP *:ssdp
IndigoPlu 20910 johnthompson   13u  IPv4 0x9f9e407f7df7be3f      0t0  UDP *:ssdp
Thompson-Server:~ johnthompson$


Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest