uniFiAP restarting

Posted on
Thu May 23, 2019 4:59 am
evansgo offline
Posts: 203
Joined: Nov 29, 2013

uniFiAP restarting

Hi, looking in the logs I'm getting a regular (every 2 mins to 6 mins) restart of the plugin with the following message

    uniFiAP runConcurrentThread stopping plugin due to: ::::: new devices :::::
    Reloading plugin "uniFiAP 7.26.163"
    Stopping plugin "uniFiAP 7.26.163" (pid 96079)
    uniFiAP Error plugin runConcurrentThread function returned or failed (will attempt again in 10 seconds)
    Stopped plugin "uniFiAP 7.26.163"
    Starting plugin "uniFiAP 7.26.163" (pid 96552)
    uniFiAP initializing ...
    uniFiAP path To files: =================
    uniFiAP indigo /Library/Application Support/Perceptive Automation/
    uniFiAP installFolder /Library/Application Support/Perceptive Automation/Indigo 7.3/
    uniFiAP plugin.py /Library/Application Support/Perceptive Automation/Indigo 7.3/Plugins/uniFiAP.indigoPlugin/Contents/Server Plugin/
    uniFiAP Plugin params /Library/Application Support/Perceptive Automation/Indigo 7.3/Preferences/Plugins/com.karlwachs.uniFiAP/
    uniFiAP Error logger enabled for ERROR ==> TEST ONLY
    uniFiAP Critical Error logger enabled for CRITICAL ==> TEST ONLY
    uniFiAP check /Library/Application Support/Perceptive Automation/Indigo 7.3/Logs/com.karlwachs.uniFiAP/plugin.log <<<< for detailed logging
    uniFiAP Plugin short Name UniFi
    uniFiAP my PID 96552
    uniFiAP set params 4 indigo V 7.3
    Started plugin "uniFiAP 7.26.163"
    uniFiAP testing if variable enableTimeTracking_UniFi is == on/off/print-option to enable/end/print time tracking of all functions and methods (option:'',calls,cumtime,pcalls,time)
    uniFiAP myLogSet setting parameters -- logFileActive= indigo; logFile= /Library/Application Support/Perceptive Automation/Indigo 7.3/Logs/com.karlwachs.uniFiAP/plugin.log; debugLevel= ['Logic', 'Log', 'LogDetails']
    uniFiAP start runConcurrentThread, initializing loop settings and threads ..
    utilities versionCheck for com.karlwachs.utilities installed: 1.18.25
    utilities the version of the plugin is up to date; version on server:1.18.25
    Z-Wave received "Living room - PIR" status update is off
    uniFiAP initialized ... looping

I have added a new USG and a new switch and started the process of setting up the VLAN's, but at the moment have only defined them and not activated any. As far as I can tell I have added the IP's of the devices correctly in the configuration. Any ideas what I may have done?
Thanks...

Oh in case it makes a difference I have firmware 4.0.30.10217 on the switch. Thinking about it, this may have started around this time. I put that firmware on it as I was getting a lot of WPA Authentication Timeout/Failures, and this firmware has a fix for it.

Posted on
Thu May 23, 2019 5:20 am
kw123 offline
User avatar
Posts: 6650
Joined: May 12, 2013
Location: Dallas, TX

Re: uniFiAP restarting

Set discover new devices to off in config

The latest version should fix this though.


Sent from my iPhone using Tapatalk

Posted on
Thu May 23, 2019 6:00 am
evansgo offline
Posts: 203
Joined: Nov 29, 2013

Re: uniFiAP restarting

Thats calmed it down, thanks and double thanks for the plug-in. It is really useful

Posted on
Thu May 23, 2019 6:01 am
kw123 offline
User avatar
Posts: 6650
Joined: May 12, 2013
Location: Dallas, TX

Re: uniFiAP restarting

Are u using the latest version? It should have fixed that. If not I would like to see some more details.


Sent from my iPhone using Tapatalk

Posted on
Thu May 23, 2019 6:05 am
evansgo offline
Posts: 203
Joined: Nov 29, 2013

Re: unuFiAP restarting

Not sure I understand. latest version of what? If its the plugin the number is in the log above, but I'm sure you know that...
Happy to send details.

Posted on
Thu May 23, 2019 6:06 am
kw123 offline
User avatar
Posts: 6650
Joined: May 12, 2013
Location: Dallas, TX

Re: uniFiAP restarting

Yes plugin. But I am traveling + have only phone and I don’t recall all
Numbers by heart.


Sent from my iPhone using Tapatalk

Posted on
Thu May 23, 2019 6:10 am
evansgo offline
Posts: 203
Joined: Nov 29, 2013

Re: unuFiAP restarting

Ah I see. :)
Yes it is the latest version.

Posted on
Thu May 23, 2019 6:21 am
kw123 offline
User avatar
Posts: 6650
Joined: May 12, 2013
Location: Dallas, TX

unuFiAP restarting

Then it is a bug.

Could you email me the printout: menu print config ?
It’s in plugin.log

Karlwachs me com.


Sent from my iPhone using Tapatalk

Posted on
Thu May 23, 2019 10:36 am
kw123 offline
User avatar
Posts: 6650
Joined: May 12, 2013
Location: Dallas, TX

Re: uniFiAP restarting

its a logic challenge:

1. accept new AP is on
2. Ap w ip is defined, but disabled
3. when the new devices is discovered the plugin restarts (it is to start the listeners properly)
4. but the IP number is disabled, so that AP does not go active.
5. it will rediscover the new device and restart after 5+ minutes

have to think about the priority of the settings
accept new devices = on, but disable the ip number that is the new IP device ..

so just in case you run into this problem:
disable discover new devices or undefine the ip number (eg 192.168.1.x)
then it should be ok.. at least thats my understanding


Karl

Posted on
Thu May 23, 2019 10:55 am
evansgo offline
Posts: 203
Joined: Nov 29, 2013

Re: unuFiAP restarting

All that makes sense apart from the fact that I did undefine the number and it still resets itself. Here's the relevant bit, as you're away I'd not worry about it at the moment, I'm sure it'll make more sense once you can test at home. For me, I've just got disable discover set for now and that's fine.

-AP ip# enabled / disabled
20:51:03 -192.168.10.4 True
20:51:03 -192.168.10.5 True
20:51:03 -192.168.10.6 True
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -SW ip#
20:51:03 -192.168.10.3 True
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False
20:51:03 -192.168.1.x False

Posted on
Thu May 23, 2019 11:48 am
kw123 offline
User avatar
Posts: 6650
Joined: May 12, 2013
Location: Dallas, TX

Re: uniFiAP restarting

Yes there is some logic the menu to check for valid ip#. If not valid reject the changes ... or something like that.


Sent from my iPhone using Tapatalk

Posted on
Sun Jun 16, 2019 12:33 pm
kw123 offline
User avatar
Posts: 6650
Joined: May 12, 2013
Location: Dallas, TX

Re: uniFiAP restarting

the new version .165 posted should mange this better.

Will adopt / add an unify --> indigo device if
- a sw / ap / gw slot (in config) is "disabled and the ip number is NOT a valid one"
- it assumes that if there is a valid IP number and you have disabled it might be temporary setting by the user and will not change that
==> when editing the IP number in config, you MUST edit the field then click on another text field. otherwise it will not save that field (that's from indigo)
so when eg you edit the ip number and click on enable/disable, the ip textfield contents will not be saved.


Karl

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests