Alexa issue

Posted on
Fri Feb 15, 2019 11:18 am
rgspb offline
Posts: 195
Joined: Apr 24, 2009
Location: Florida

Alexa issue

I'm getting a strange log from the Alexa-Hue bridge plugin. I'm also not getting updates to the Alexa app, I'm guessing this is the cause. The only thing that has changed is that I added one device to the Alexa setup.

Alexa-Hue Bridge Error getHueDeviceJSON exception:
Traceback (most recent call last):
File "/Library/Application Support/Perceptive Automation/Indigo 7/Plugins/Alexa-Hue Bridge.indigoPlugin/Contents/Server Plugin/hue_listener.py", line 331, in getHueDeviceJSON
self.alexaDeviceNameKey = PLUGIN.globals['alexaHueBridge'][p1_ahbDevId]['hashKeys'][p3_alexaDeviceHashedKey]
KeyError: 'a46e5d2bbe2d3b05b2d28b6054d98c18046bce28893d04e050724168116d5587'

Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='must be string or buffer, not None'
Alexa-Hue Bridge Error getHueDeviceJSON exception:
Traceback (most recent call last):
File "/Library/Application Support/Perceptive Automation/Indigo 7/Plugins/Alexa-Hue Bridge.indigoPlugin/Contents/Server Plugin/hue_listener.py", line 331, in getHueDeviceJSON
self.alexaDeviceNameKey = PLUGIN.globals['alexaHueBridge'][p1_ahbDevId]['hashKeys'][p3_alexaDeviceHashedKey]
KeyError: 'f06e825b7ef05927c8095049d20089dcac9a403cbdd481d139bc8ab38e8846bf'

Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='must be string or buffer, not None'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'Alexa'. Line '185' has error='must be string or buffer, not None'
Alexa-Hue Bridge Error getHueDeviceJSON exception:
Traceback (most recent call last):
File "/Library/Application Support/Perceptive Automation/Indigo 7/Plugins/Alexa-Hue Bridge.indigoPlugin/Contents/Server Plugin/hue_listener.py", line 331, in getHueDeviceJSON
self.alexaDeviceNameKey = PLUGIN.globals['alexaHueBridge'][p1_ahbDevId]['hashKeys'][p3_alexaDeviceHashedKey]
KeyError: '5c996ab43a5a6add6f25af505dd970429824c98a4e511ef62b70dfca0ba6a5f0'

Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'self.ahbDev.name'. Line '185' has error='must be string or buffer, not None'
Alexa-Hue Bridge Error StandardError detected in HttpdRequestHandler for 'Alexa'. Line '185' has error='must be string or buffer, not None'

Posted on
Fri Feb 15, 2019 2:44 pm
autolog offline
Posts: 3243
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: Alexa issue

Not sure what is going on here :?

Looks like the plugin can't find the hash key for the Indigo device - this is the mechanism that ties up the Alexa device with the Indigo device.

A potential work-around is to delete all the devices on Alexa via the Alexa website and then do a re-discovery so that everything gets reset. :)

Posted on
Fri Feb 15, 2019 4:26 pm
rgspb offline
Posts: 195
Joined: Apr 24, 2009
Location: Florida

Re: Alexa issue

The Alexa app isn't deleting items I delete on Indigo and not adding items I add.

Posted on
Fri Feb 15, 2019 5:26 pm
autolog offline
Posts: 3243
Joined: Sep 10, 2013
Location: West Sussex, UK [GMT+1 aka UTC+1]

Re: Alexa issue

Deleting devices on Indigo won't delete them from the Alexa App - You have to do that via the alexa.amazon.com via a web browser.

When you say it doesn't add them, are you doing a discovery and Alexa is not finding anything?

I'll be back online tomorrow morning at some point (UK time). :)

Posted on
Sat Feb 16, 2019 11:34 am
rgspb offline
Posts: 195
Joined: Apr 24, 2009
Location: Florida

Re: Alexa issue

One thing is for sure, Alexa is no longer communicating with Indigo. No idea why. There is no way in Indigo to force a discovery, not that I can see.

Posted on
Sat Feb 16, 2019 2:30 pm
rgspb offline
Posts: 195
Joined: Apr 24, 2009
Location: Florida

Re: Alexa issue

Now, all of a sudden, discovery is working in Indigo and Alexa is cooperating. I'm so confused, but things are working so I'll take it!

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests