Can someone send me the plugin

Posted on
Wed Aug 01, 2018 3:18 pm
Sevilsivle offline
Posts: 103
Joined: Jan 11, 2013

Re: Can someone send me the plugin

http://www.automatedhome.co.uk/vbulleti ... aintenance

Perhaps this explains the error message?

Posted on
Fri Aug 03, 2018 7:14 am
kidney offline
Posts: 211
Joined: Jul 15, 2007

Re: Can someone send me the plugin

I wish it was that, but it never worked for me....

Posted on
Fri Nov 23, 2018 4:01 pm
kidney offline
Posts: 211
Joined: Jul 15, 2007

Re: Can someone send me the plugin

Anyone can help me with this, still hoping to connect to my Honeywell account

Honeywell [Wed Aug 1 06:22:14 2018] Token Error: {"error":"invalid_grant"}


What does invalid grant mean?

Posted on
Fri Nov 23, 2018 4:26 pm
FlyingDiver offline
Posts: 3436
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Can someone send me the plugin

kidney wrote:
Anyone can help me with this, still hoping to connect to my Honeywell account

Honeywell [Wed Aug 1 06:22:14 2018] Token Error: {"error":"invalid_grant"}


What does invalid grant mean?


It means the authentication to the Honeywell servers is failing.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Fri Nov 23, 2018 4:35 pm
kidney offline
Posts: 211
Joined: Jul 15, 2007

Re: Can someone send me the plugin

Thanks found the login problem.... Now if I could get it to read my Prestige IAQ thermostat.

Posted on
Wed Nov 28, 2018 2:03 pm
kidney offline
Posts: 211
Joined: Jul 15, 2007

Re: Can someone send me the plugin

RogueProeliator wrote:
How are you doing that?
I have the Prestige IAQ Thermostat..

So I just noticed this post, over a month late, while digging in to something else... I really do apologize for that.

Setup was actually fairly simple - I purchased the RedLink Gateway, included it in the A/C's wireless communications network via the thermostat and created a login on the internet. Obviously if your thermostat can talk directly you are one up on mine... then just configured the plugin with login credentials and was off.

FWIW, I bought the gateway on eBay for much lower than the cost they want from the distributor.

Adam

Where did you find you MAC address on the RedLink bridge?

Posted on
Wed Nov 28, 2018 2:23 pm
kidney offline
Posts: 211
Joined: Jul 15, 2007

Re: Can someone send me the plugin

This is what I'm getting now when it's time to retrieve the info from my thermostat...
Code: Select all
Nov 28, 2018 at 3:21:34 PM
   Honeywell Debug                 Stopping device: Thermostat
   Honeywell Debug                 Starting device: Thermostat
   Honeywell Debug                 [Wed Nov 28 15:21:34 2018] Thermostat: Thermostat, Enabled: True
   Honeywell                       Initializing thermostat device: Thermostat
   Honeywell Debug                 Updating Device: Thermostat, State: maxCoolSetpoint, Value:
   Honeywell Debug                 Updating Device: Thermostat, State: maxHeatSetpoint, Value:
   Honeywell Debug                 Updating Device: Thermostat, State: minCoolSetpoint, Value:
   Honeywell Debug                 Updating Device: Thermostat, State: minHeatSetpoint, Value:
   Honeywell Debug                 [Wed Nov 28 15:21:34 2018] Cannot read device data for: Thermostat
   Honeywell Debug                 [Wed Nov 28 15:21:36 2018] Cannot read device data for: Thermostat
   Honeywell Error                 [Wed Nov 28 15:21:36 2018] Failed to retrieve thermostat status for: Thermostat

Posted on
Wed Jun 26, 2019 3:51 am
AndyVirus offline
Posts: 249
Joined: Mar 18, 2014
Location: Newport Pagnell, UK

Re: Can someone send me the plugin

Hello,

I have been getting invalid grant since 26 June 2018 now. I keep meaning to post for help but life...

Anyway i have tried deleting the plugin and prefs file then setting up again. still invalid grant. I have change the password so no special characters, invalid grant.
I am choosing TCC Europe from the plugin. from TCC site i use United Kingdom. There is a option for Ireland. could it be where the plugin is communicating to TCC Europe that is the issue.
I have no idea why it stopped working. Works on the site, works in the iOS app. Just the Indigo Plugin can not communicate. No idea how to troubleshoot as debug gives nothing more either.
Any help to get this working again would be appreciated.

26 Jun 2019 at 10:48:34
Honeywell [Wed Jun 26 10:48:34 2019] Token Error: {"error":"invalid_grant"}
Honeywell Error [Wed Jun 26 10:48:34 2019] Error: Cannot authenticate to TCC EMEA API. Retrying in 60...

(Posing here as i can see that somone had the same error and was able to fix it. How did you fix it @kidney ?)

Posted on
Wed Jun 26, 2019 4:38 am
AndyVirus offline
Posts: 249
Joined: Mar 18, 2014
Location: Newport Pagnell, UK

Re: Can someone send me the plugin

Never mind. Resolved Invalid grant by deleting all the devices created by the plugin and reloading. Authenticated again and re-created.

Who is online

Users browsing this forum: No registered users and 0 guests

cron