Page 1 of 1

Error when attempting to reconfigure to iTunes

PostPosted: Mon May 22, 2017 11:41 pm
by gregconnors
Hello.

I've just upgraded to 7. I copied my v6 database and mostly good. The iTunes plugin is not connecting. I 'edit device settings', then click the remote button and enter 0000, OK. However when I click Save button I get message "Error validating fields. Hover over the red field labels above to see the error reason" (see attachment)
Screen Shot 2017-05-23 at 15.26.37 .png
Screen Shot 2017-05-23 at 15.26.37 .png (90.3 KiB) Viewed 689 times

I cancel out of the dialogs. I have tried a new iTunes device, but I'm getting the same result.
The log shows an "Error in plugin execution UiValidate" (see attachment)

Screen Shot 2017-05-23 at 15.32.53 .png
Screen Shot 2017-05-23 at 15.32.53 .png (15.85 KiB) Viewed 689 times

I assume I've messed up the copying of the v6 database or something else. iTunes plugin is currently v2.0.4.
I believe I followed the recommended instructions. I have since re-installed v7 to correct my mistakes but still no joy.

Thanks for your support.
Greg

Re: Error when attempting to reconfigure to iTunes

PostPosted: Tue May 23, 2017 8:46 am
by jay (support)
The error in your event log indicates that your Mac didn't respond when we tried to get the IP address. This usually means that you have some unusual network configuration on your Mac - if you have two network interfaces enabled that might be it, and if you have macOS server installed it also messes with the network settings such that reliably getting the IP address is problematic. I've never seen it happen in the iTunes plugin before, but we've seen it in other plugins that try to get IP addresses.