iTunes plugin disabling itself

Posted on
Tue May 08, 2018 6:17 am
mbordas offline
Posts: 8
Joined: Dec 28, 2016

iTunes plugin disabling itself

Has anyone else been having trouble with the iTunes plugin recently? This just started a few week ago, it randomly disables itself sometimes, maybe every few days.

Code: Select all
   iTunes Error                    iTunes stopped due to the following error (will attempt to recover in 10 seconds):

Traceback (most recent call last):
  File "statusThread.py", line 134, in run
  File "itunes.py", line 59, in iTunesLogin
UnknownError: 'ITunesController.iTunesLogin() Error getting initial cache update: Traceback (most recent call last):\n  File "itunes.py", line 57, in iTunesLogin\n  File "itunes.py", line 181, in updateCache\n  File "dacp.py", line 586, in send_cmd\n  File "dacp.py", line 581, in send_raw\nDACPException: 403 - unknown response status code\n'


   iTunes Error                    iTunes has an unknown error - disabling

Posted on
Tue May 08, 2018 9:08 am
jay (support) offline
Site Admin
User avatar
Posts: 14246
Joined: Mar 19, 2008
Location: Austin, Texas

Re: iTunes plugin disabling itself

That seems to imply that iTunes is randomly deciding to fail the authentication request (which really shouldn't be possible since the pairing process is what does that authentication), and in a very unexpected way. More information: Indigo version, macOS version, iTunes version, is it a local or remote iTunes instance, etc.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Jul 06, 2018 10:55 am
t-star offline
Posts: 40
Joined: Oct 26, 2007

Re: iTunes plugin disabling itself

I didn't get that one. I got a different one yesterday.
2018-07-05 14:02:18.984 iTunes Error iTunes - House MacMini stopped due to the following error (will attempt to recover in 10 seconds):

Traceback (most recent call last):
File "statusThread.py", line 253, in run
DACPException: 500 - unknown response status code

2018-07-05 14:02:19.322 iTunes Error iTunes - House MacMini has an unknown error - disabling


But I can't seem to re-enable the plugin. It continues to show the iTunes device as unavailable. Have rebooted, disabled etc..

Any ideas on getting it working?

When I try to play iTunes via the plugin I get:
Action Group iTunes: Play
Ignored device "iTunes - House MacMini" action request (communication is disabled)


itunes 12.7.5.9 on the same computer as Indigo 7.1.1. Running MacOS 10.10.5

Side note: I was getting errors with the airfoil plugin shortly before this error. so not sure what was going on at the time.

2018-07-05 14:02:00.853 Airfoil Pro Error Error in plugin execution runConcurrentThread:

Traceback (most recent call last):
File "plugin.py", line 533, in runConcurrentThread
StandardError: ServerCommunicationError -- timeout waiting for response

Posted on
Fri Jul 06, 2018 11:23 am
jay (support) offline
Site Admin
User avatar
Posts: 14246
Joined: Mar 19, 2008
Location: Austin, Texas

Re: iTunes plugin disabling itself

Have you rebooted both the Indigo server Mac and the Mac that's running iTunes (assuming they are different)?

Is the plugin disabled on only the iTunes Server device? Make sure the Communication Enabled checkbox is checked in the device list for that device or edit it and make sure the Enable Indigo Communication checkbox is checked.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Jul 06, 2018 11:23 am
t-star offline
Posts: 40
Joined: Oct 26, 2007

Re: iTunes plugin disabling itself

I found how to re-establish the plugin device talking with iTunes. I right clicked on the device and selected "Enable Indigo Communication".

Seems to have me back up and running.

Posted on
Fri Jul 06, 2018 11:30 am
t-star offline
Posts: 40
Joined: Oct 26, 2007

Re: iTunes plugin disabling itself

Thanks Jay. Good to note on the additional columns . I hardly ever scroll to the right in the main Indigo display to see those additional columns. I have the columns sized and arranged to what I need most and I forgot they were out there. I just don't have that many issues. This is the first time in 5+ years that I remember having an issue like this. Keep up the good work!

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest