Page 1 of 1

[SOLVED]Airfoil Pro Issue

PostPosted: Mon Feb 06, 2017 8:01 am
by difficultrun
I'm wondering if anyone can help me with this issue ...
I'm using Airfoil 5.5.2
Airfoil Pro plugin 1.0.7
Indigo 7.0.3

I've set up a scheduled action every morning to turn on my amplifier, open Safari and open a webpage at to stream their live classical music program and then another action to shut things off in the evening. I am using Airfoil Pro to stream the music to my home speakers using an airport express connected to the amp. However, I get the following error message from Airfoil:

Please include the following information when contacting Rogue Amoeba Support.

Domain: AudioHijackKitErrorDomain

Code: 5416

NSLocalizedDescription: Duplicate Application Running

NSLocalizedRecoverySuggestion: Safari cannot be launched, because a duplicate copy is already running.

You selected this version:

However, another version is already running:

Two versions of the same application cannot run at once.

I've checked and can't find more than one instance of Safari on my computer. However, I do use a backup program called SuperDuper to clone my hard drive to an external hard drive. Could Airfoil think that's the other Safari instance?

I use an apple script to open Safari, which seems to work fine:

tell application "Safari"
open location ""
end tell

Then I use another script at the end of the day to close Safari:

tell application "Safari" to close every window
tell application "Safari"
end tell

Sorry for the long post, but I hope one of the experts can help this amateur. Thanks.

Re: Airfoil Pro Issue

PostPosted: Mon Feb 06, 2017 10:42 am
by jay (support)
Have you reported that to Rogue Amoeba? Seems like they could shed some light on that error.

Re: Airfoil Pro Issue

PostPosted: Mon Feb 06, 2017 11:24 am
by difficultrun
Thanks Jay. Yes, I did send them a contact report on the issue. However, I haven't heard back from them.

Re: Airfoil Pro Issue

PostPosted: Mon Feb 06, 2017 1:55 pm
by difficultrun
Rogue Amoeba did get back to me and suggested the following:

Thanks for getting in touch with us. Let's see if performing a Factory Reset helps. To do this:

1) Quit Airfoil, then relaunch it while holding down the option key. This will bring up the debugging window.

2) Click the "Factory Reset" button, then click "Done".

This will reset the program to its default settings. You'll need to re-enter your license key, but that should get you all set. If not, let us know and we'll take it from there.

I tried it and it appears to have fixed the issue.

Thanks again.

Re: Airfoil Pro Issue

PostPosted: Mon Feb 06, 2017 2:56 pm
by jay (support)
Good news, and good information if someone else runs across the issue.