[SOLVED]Error when creating Virtual Device

Posted on
Fri Apr 03, 2015 2:51 pm
Turribeach offline
Posts: 220
Joined: Feb 06, 2015
Location: London, UK

[SOLVED]Error when creating Virtual Device

Hi,

I am trying to create a new Virtual Device => Device Group but I get the following error when I create it. The device gets created anyway but it's pretty much useless since I get similar errors if I try to Edit Device Settings. A similar error happens when I try to create a Virtual Device => Virtual On/Off Device. Any ideas?


3 Apr 2015 21:48:18
Error (client) _setCurrentPluginDeviceType() caught exception: PacketTargetNotConnectedError -- client target com.perceptiveautomation.indigoplugin.devicecollection not found for message CalcDeviceFunc
Error device "new device" state key onOffState not defined
Error device "new device" state key onOffState not defined
Error (client) getConfigUiValuesFromPlugin2() caught exception: PacketTargetNotConnectedError -- client target com.perceptiveautomation.indigoplugin.devicecollection not found for message UiGetValues2
Error (client) getXmlFromPlugin() caught exception: PacketTargetNotConnectedError -- client target com.perceptiveautomation.indigoplugin.devicecollection not found for message CallPluginFunc
Error (client) runDialogForDevice() caught exception: NSInvalidArgumentException -- *** -[__NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil object from objects[0]
Error device "new device" state key onOffState not defined
Error device "new device" state key onOffState not defined
Error device "new device" state key onOffState not defined
Error device "new device" state key onOffState not defined
Error device "new device" state key onOffState not defined
Error device "new device" state key onOffState not defined

Posted on
Fri Apr 03, 2015 3:03 pm
kw123 offline
User avatar
Posts: 5739
Joined: May 12, 2013
Location: Dallas, TX

Re: Error when creating Virtual Device

could you post the screen shot where you enter the device parameters.. that would help to diagnose the problem.

Posted on
Sat Apr 04, 2015 1:02 pm
Turribeach offline
Posts: 220
Joined: Feb 06, 2015
Location: London, UK

Re: Error when creating Virtual Device

The error disappeared after I disabled and re-enabled the Virtual Devices interface. The logs suggests there is a separate process started for Virtual Devices so I am guessing the process was not responding or died. Still it looks like this error should be caught by the software rather than throwing the ones I posted above which make no sense unless you are an Indigo developer.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest