Virtual Devices Error in Event Log

Posted on
Wed Dec 04, 2013 9:54 pm
jheddings offline
User avatar
Posts: 108
Joined: Dec 01, 2013
Location: Denver, CO

Virtual Devices Error in Event Log

Hello-

Using Indigo 6.0.5 Pro... After duplicating a virtual device group, the following errors show up in the event log when I attempt to edit an actual device from the group (not the group itself):

Code: Select all
Virtual Devices Error           Error #943: Device '1480200676' not found in active map. Report  to support.
Virtual Devices Error           Error #943: Device '606275728' not found in active map. Report  to support.
Virtual Devices Error           Error #943: Device '1736705550' not found in active map. Report  to support.


Per the instructions, I'm reporting the error :)

Posted on
Thu Dec 05, 2013 9:11 am
jay (support) offline
Site Admin
User avatar
Posts: 14656
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Virtual Devices Error in Event Log

A couple of questions:

  1. Did the new (duplicated) scene work despite those errors?
  2. When you say "edit an actual device", what exactly did you mean (exact steps to reproduce)?
  3. Was the device group that you duplicated active/enabled and working correctly?

Thanks for the report.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Dec 05, 2013 11:12 am
jheddings offline
User avatar
Posts: 108
Joined: Dec 01, 2013
Location: Denver, CO

Re: Virtual Devices Error in Event Log

The virtual groups all seem to work, despite the errors, both before and after duplicating the group. I am trying to figure out the steps to reproduce the error reliably, but I haven't found the exact mix. By "edit the actual device" I just mean to say that the errors display in the log file when I make changes (i.e. name) to the physical device that is a part of the original group. The best of my recollection is the following:

- Create a virtual group V1 with any two devices (A & B)
- Use settings "on when all lights on" / "on when bright > 0" / "on/off when on" for V1
- Check "update all device states" and close V1 dialog
- Duplicate virtual device group V1 as V2
- Edit V2, select two different devices (C & D) - can't remember if this must be two different devices or just a subset of V1 devices
- Use settings "on when all lights on" / "on when bright > 0" / "on/off when on" for V2
- Check "update all device states" and close V2 dialog
- Edit device A properties, change the title or a non-functional value

I will try to confirm the steps to reproduce when I get home tonight. Hope this is helpful.

Posted on
Fri Oct 02, 2015 12:31 pm
ac4lt offline
Posts: 72
Joined: Sep 20, 2015

Re: Virtual Devices Error in Event Log

I was seeing this as well.

Initially I created a virtual device group called "all lights" with all of my hue and wave light switches. Later I duplicated this device to make subset groups (family room, kitchen, etc.). I noticed the errors posted above. I was also seeing this error:

Code: Select all
  Virtual Devices Error           Error in plugin execution ExecuteAction:

Traceback (most recent call last):
  File "plugin.py", line 588, in actionControlDimmerRelay
<type 'exceptions.KeyError'>: (144257953,)


when I turned on the "all lights" group after creating duplicates from it. I went the all lights group in the devices and did a 'send status request' and not it and all the other groups are behaving properly.

There may be some state that isn't being cleaned up during duplication but the status update appeared to clear it out.

Posted on
Fri Oct 02, 2015 2:41 pm
jay (support) offline
Site Admin
User avatar
Posts: 14656
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Virtual Devices Error in Event Log

Do you know what kind of device is id 144257953? And what Indigo version are you using?

I have no luck recreating any issues while duplicating groups unfortunately.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Oct 02, 2015 2:55 pm
ac4lt offline
Posts: 72
Joined: Sep 20, 2015

Re: Virtual Devices Error in Event Log

Sorry, I should have included that. It's a hue light, from Hue Lights v1.3.13 in Indigo 6.1.4. Perhaps there's something odd about the hue light plugin's interactions with the virtual device.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests