Trigger not executed

Posted on
Tue Nov 12, 2019 4:22 pm
Turribeach offline
Posts: 264
Joined: Feb 06, 2015
Location: London, UK

Trigger not executed

Just had an interesting event on my custom bell ring where it failed to execute a trigger. Here is a normal execution from earlier today:

Code: Select all
2019-11-12 20:52:43.615   Z-Wave   received "Bell Front" status update is on
2019-11-12 20:52:43.615   Trigger   Door Bell On


But later today this happened:

Code: Select all
2019-11-12 21:59:45.061   Z-Wave   received "Bell Front" status update is on
2019-11-12 21:59:47.190   Z-Wave   received "Bell Front" status update is off


And the trigger Door Bell On did not get executed. The trigger is defined as Device State Changed / On/Off State / Becomes On for the Bell Front device. There are no conditions and it executes a Python script action and a Hue Light Control action. Why did it not execute in the second instance? Even though it went back to off there was more than 2 seconds between the events, plenty of time for the trigger to execute. There were no other server activity executed around that time (4 seconds each side of the above commands).

Posted on
Tue Nov 12, 2019 5:21 pm
jay (support) offline
Site Admin
User avatar
Posts: 15884
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Trigger not executed

If the state was already on, then Indigo won't fire the trigger again until the state actually changes to off first, then back on. Is there an off event between 2019-11-12 20:52:43.615 and 2019-11-12 21:59:45.061 in your event log?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Thu Nov 14, 2019 4:59 pm
Turribeach offline
Posts: 264
Joined: Feb 06, 2015
Location: London, UK

Re: Trigger not executed

That's it Jay, good catch, I checked the logs Indigo never got the Off event after the first On. This custom Bell runs on top of a Fibaro Door/Window Sensor (FGK10x), firmware 3.02. Why would it not send the Off event? Or was it perhaps lost in Z-Wave somehow? The "delayed off" parameter was set to the default (0). I have now set it to 1 second, not sure if that will make it more reliable. I will search in my logs to see if I find more occurrences of this problem but I am thinking in adding a delayed action of say 60 seconds in the trigger to send the Off command to the device but I don't find the Door/Window Sensor under Device Actions. Also not sure if that will work since this is battery operated device so it will not be awake by then...

Posted on
Thu Nov 14, 2019 5:06 pm
Turribeach offline
Posts: 264
Joined: Feb 06, 2015
Location: London, UK

Re: Trigger not executed

Checked the logs and in the last 3 months this has only happened this one time so seems like a one off glitch...

Posted on
Thu Nov 14, 2019 5:58 pm
matt (support) offline
Site Admin
User avatar
Posts: 19455
Joined: Jan 27, 2003
Location: Texas

Re: Trigger not executed

Yeah, probably just a glitch in that case. If it is sent while your Mac is rebooting or the Indigo Server isn't running then it will be lost as well.

Image

Posted on
Thu Nov 14, 2019 6:41 pm
Turribeach offline
Posts: 264
Joined: Feb 06, 2015
Location: London, UK

Re: Trigger not executed

How can I get it to turn off when it gets stuck?

Posted on
Fri Nov 15, 2019 2:38 pm
jay (support) offline
Site Admin
User avatar
Posts: 15884
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Trigger not executed

Doing a status request should force it to report it's current state back to Indigo.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Sat Nov 16, 2019 6:18 am
Turribeach offline
Posts: 264
Joined: Feb 06, 2015
Location: London, UK

Re: Trigger not executed

There is no Send Status Request button on Indigo for this device. I tried doing it on a Python Script but got nothing back. I am guessing this is due to the device being battery powered? Actually I am running it with a power supply so while the device is originally battery powered it is not at the moment. I have set the Wake Interval to be 5mins to see if that helps.

Posted on
Sat Nov 16, 2019 11:41 am
jay (support) offline
Site Admin
User avatar
Posts: 15884
Joined: Mar 19, 2008
Location: Austin, Texas

Re: Trigger not executed

I suppose if it's battery powered that might be the issue. Some Z-Wave battery powered devices can have status requests queued up, so lowering the reporting interval may help.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest