Batch Sync Confusion

Posted on
Mon Oct 02, 2017 4:46 pm
HFTobeason offline
Posts: 274
Joined: Nov 07, 2003

Batch Sync Confusion

I replaced a device. Got a message re syncing. Went to "Start Sync Device links". Got a whole lot of this (15 times total):

    PowerLinc Linking - . changing: INSTEON plc link to responder 0C.C8.DE, flags 02, group 02, data FE 1F 00
    PowerLinc Linking - . . . . to: INSTEON plc link to responder 0C.C8.DE, flags 02, group 02, data 03 1F 00
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error ManageAllLinkRecord failed to modify link record
    PowerLinc Linking - . changing: INSTEON plc link to responder 12.91.E5, flags 02, group 02, data FE 1F 00
    PowerLinc Linking - . . . . to: INSTEON plc link to responder 12.91.E5, flags 02, group 02, data 03 1F 00
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error ManageAllLinkRecord failed to modify link record
    PowerLinc Linking - . changing: INSTEON plc link to responder 06.7F.D1, flags 02, group 02, data FE 1F 00
    PowerLinc Linking - . . . . to: INSTEON plc link to responder 06.7F.D1, flags 02, group 02, data 03 1F 00
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error ManageAllLinkRecord failed to modify link record

I have no idea what this means, nor what to do. Any ideas appreciated. TIA.

Posted on
Mon Oct 02, 2017 5:33 pm
matt (support) offline
Site Admin
User avatar
Posts: 19460
Joined: Jan 27, 2003
Location: Texas

Re: Batch Sync Confusion

What version of Indigo are you running?

Image

Posted on
Mon Oct 02, 2017 5:35 pm
HFTobeason offline
Posts: 274
Joined: Nov 07, 2003

Re: Batch Sync Confusion

Sorry, should have mentioned:

Indigo 7.0.3
macOS 10.13 (17A365)
iMac (Retina 5K, 27-inch, 2017)

Posted on
Wed Oct 04, 2017 8:31 am
matt (support) offline
Site Admin
User avatar
Posts: 19460
Joined: Jan 27, 2003
Location: Texas

Re: Batch Sync Confusion

Do any of the modules complete their sync? Are you able to control any modules (that is, is it just syncing that is failing)?

What about if you try the Define and Sync operation for an individual device (double-click the device to bring up its edit dialog, and press Define & Sync)?

A couple of other things to try:

1) Unplug the PowerLinc from the wall and your Mac for a few minutes. Does that help?
2) Plug the PowerLinc into different outlets (on different circuits) using an extension cord. Any luck with it on a different circuit?

Image

Posted on
Wed Oct 04, 2017 1:11 pm
HFTobeason offline
Posts: 274
Joined: Nov 07, 2003

Re: Batch Sync Confusion

Thank you for your reply.

Do any of the modules complete their sync? Are you able to control any modules (that is, is it just syncing that is failing)?


Yes, well over half the modules sync successfully. And, overall, Indigo seems to be working just fine - including the modules that are "failing" to sync.

What about if you try the Define and Sync operation for an individual device (double-click the device to bring up its edit dialog, and press Define & Sync)?


This happens (on device 0C.C8.DE - see attached screenshot for that device's details):

    PowerLinc Linking - entered discovery linking mode (240 seconds)
    Trigger NOAA Wind Direction
    PowerLinc Linking - syncing PowerLinc links (address 1E.4B.71)
    PowerLinc Linking - . . adding: INSTEON plc link to controller 0C.C8.DE, flags 03, group 01, data 00 00 FF
    PowerLinc Linking - . . adding: (not added -- probably already exists)
    PowerLinc Linking - sync complete
    PowerLinc Linking - PowerLinc links updated
    PowerLinc Linking - sending engine version request to 0C.C8.DE
    PowerLinc Linking - received engine version 00 from 0C.C8.DE
    PowerLinc Linking - sending id request for device information to 0C.C8.DE
    PowerLinc Linking - received id request response from 0C.C8.DE
    PowerLinc Linking - initializing remote device "Laundry Bathroom" (address 0C.C8.DE, firmware version 2C)
    PowerLinc Linking - initialize complete
    PowerLinc Linking - syncing remote device "Laundry Bathroom" (address 0C.C8.DE, firmware version 2C)
    PowerLinc Linking - syncing all links
    PowerLinc Linking - . . . read: INSTEON dev link to controller 1E.4B.71, flags A2, group 02, data FF 1F 01
    PowerLinc Linking - . . . read: INSTEON dev link to controller 1E.4B.71, flags A2, group 02, data FF 1F 01
    PowerLinc Linking - . . . read: INSTEON dev link (empty record at 0FE8)
    PowerLinc Linking - . . . read: INSTEON dev link (empty record at 0FE0)
    PowerLinc Linking - . . . read: INSTEON dev link to responder 1E.4B.71, flags E2, group 01, data 03 1F 00
    PowerLinc Linking - . . found: PowerLinc responder for group 1
    PowerLinc Linking - comparing local and remote links
    PowerLinc Linking - . . match: remote link is identical to persistent link 1E.4B.71, flags A2, group 02
    PowerLinc Linking - . . found: link with duplicate address and group number 1E.4B.71 group 02 (deleting remote link)
    PowerLinc Linking - compare complete
    PowerLinc Linking - . deleting: INSTEON dev link to controller 1E.4B.71, flags A2, group 02, data FF 1F 01
    PowerLinc Linking - sync complete
    PowerLinc Linking - device "Laundry Bathroom" links updated
    PowerLinc Linking - exited linking mode

1) Unplug the PowerLinc from the wall and your Mac for a few minutes. Does that help?


Same problem. Still seeing this on ~15 devices:

    PowerLinc Linking - compare complete
    PowerLinc Linking - . changing: INSTEON plc link to responder 0C.C8.DE, flags 02, group 02, data FE 1F 00
    PowerLinc Linking - . . . . to: INSTEON plc link to responder 0C.C8.DE, flags 02, group 02, data 03 1F 00
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error resending previous command (failure response)
    Error ManageAllLinkRecord failed to modify link record

2) Plug the PowerLinc into different outlets (on different circuits) using an extension cord. Any luck with it on a different circuit?


No change.
Attachments
Screen Shot 2017-10-04 at 12.09.11.png
Screen Shot 2017-10-04 at 12.09.11.png (291.11 KiB) Viewed 896 times

Posted on
Wed Oct 04, 2017 1:42 pm
roussell offline
User avatar
Posts: 1108
Joined: Aug 18, 2008
Location: Alabama

Re: Batch Sync Confusion

This might be a stretch, but since you're running High Sierra, could this be related to any of the stuff others are seeing with USB devices? Have you tried Jay's suggestions mentioned in this thread to rule out 10.13?

Terry

Posted on
Wed Oct 04, 2017 5:44 pm
matt (support) offline
Site Admin
User avatar
Posts: 19460
Joined: Jan 27, 2003
Location: Texas

Re: Batch Sync Confusion

roussell wrote:
This might be a stretch, but since you're running High Sierra, could this be related to any of the stuff others are seeing with USB devices? Have you tried Jay's suggestions mentioned in this thread to rule out 10.13?

Terry is right – that might be the problem. Definitely try the suggestions on the thread above.

Image

Posted on
Sat Nov 30, 2019 11:53 am
jaj737@gmail.com offline
User avatar
Posts: 19
Joined: Mar 20, 2010
Location: Dallas, Texas

Re: Batch Sync Confusion

Just wondering why batch syncing occurs every time that I want to add or delete a controller or responder from one device. The batch sync takes a very long time to accomplish. I have about 140 Insteon controlled devices.

Posted on
Sat Nov 30, 2019 11:57 am
matt (support) offline
Site Admin
User avatar
Posts: 19460
Joined: Jan 27, 2003
Location: Texas

Re: Batch Sync Confusion

The batch sync only syncs devices it thinks aren't in-sync with Indigo. If it consistently is taking that long, then it sounds like the sync isn't completing successfully or something. If you need help troubleshooting it then copy/paste the Event Log window contents showing the sync and describe what you are doing (which links you added/edited/deleted before the sync).

Image

Posted on
Sat Nov 30, 2019 12:25 pm
jaj737@gmail.com offline
User avatar
Posts: 19
Joined: Mar 20, 2010
Location: Dallas, Texas

Re: Batch Sync Confusion

thanks so much, I will give that a try.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest