Moving Indigo to a new User Space and More

Posted on
Wed Apr 07, 2021 1:32 pm
jltnol offline
Posts: 625
Joined: Oct 15, 2013

Moving Indigo to a new User Space and More

For a variety of reasons, I'm moving my Indigo set up from a Mini to an iMac. Another task is to move Indigo to a different user space since it appears absolutely impossible to log out of my AppleID in the user space Indigo is in. (you should try to log out of your AppleID... make sure you have a few days, and even then. you won't be able to... but I digress)

So back to moving user space. I do have some files for Indigo in User Space #1, including my main database for Indigo, so moving them wasn't really a problem. I'm now logged into User Space #2, but Indigo isn't working exactly right, so I re-installed 7.5, and all is well. I had some issues with HomeKit, but they were of my own making, and now even that is working as expected..

So I grab an external USB drive, de-activiate the Indigo server, quit Indigo, fire up carbon Copy cloner, and clone my internal drive with my new User Space #2 to my external drive. Once that is done, I boot from the external drive, authorize the Indigo Server, but still some things aren't quite right. So I stop the server, re-install 7.5 on the external drive, reboot, re-start Indigo, but still some things aren't working. All of the plug-ins "Show In Plugin Store" are grayed out. And at least one plugin that should have a "Configuration" option, doesn't have it and isn't working even after I've re-installed it. I have no firewalls on this computer, so am at a loss as to why my computer can reach the plugin store, but Indigo can not..

Ultimately, I want to clone my external drive to a different computer, but I've spent too many hours in the last 2 days trying to do that to no avail. So what would cause my copy of Indigo to not be able to reach the Store? And I also can't authenticate to the Indigodomo.com server as well. And given what I've done, why would some plugins balk at operating from my external drive?

Any ideas?

Posted on
Wed Apr 07, 2021 2:25 pm
jltnol offline
Posts: 625
Joined: Oct 15, 2013

Re: Moving Indigo to a new User Space and More

Quick Update

So I FINALLY got more stuff... most stuff working. Plugins can now reach the store, and the Indigo authentication server can also be reached. But still one plugin isn't responding.

Posted on
Wed Apr 07, 2021 3:57 pm
matt (support) offline
Site Admin
User avatar
Posts: 20568
Joined: Jan 27, 2003
Location: Texas

Re: Moving Indigo to a new User Space and More

I'm curious what steps you took that got it working?

Image

Posted on
Wed Apr 07, 2021 4:18 pm
jltnol offline
Posts: 625
Joined: Oct 15, 2013

Re: Moving Indigo to a new User Space and More

Hey Matt

I've taken 2 billion steps... at least I think so.
What I THINK I did was to create the clone while the server was "authorized". The server on the clone did run, but could not reach the store. So I booted back into the original drive, and un-authorized the server, re-cloned the external drive, booted from the clone, authorized the server, and all was well. Not sure why that might make a difference, but AFAIK, those were the exact steps I took to get from Point A to Point LMNOP. It's been a journey.

I even tried to get the server running on BigSur, but had problems with the HomeKit Plugin not being authorized to run(although I'm thinking I might try again using a different tact). I'm not so in a rush for Big Sur, but honestly, aside from the HomeKit issue, everything seemed to be working.... although I didn't run it very long so there may have been issues I just hadn't run across yet.

I still have one plugin... Beacon... that I can't get working on the clone. I had posted a thread in that forum yesterday, but partially got around that.... but I'm back to having that plugin not working.

LASTLY, don't even get me started with signing out of my Apple ID. Honestly, I just don't think Apple will let you.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 5 guests