MacOS 13 / Ventura Compatability ?

Posted on
Tue Jun 07, 2022 8:45 am
SearchCz offline
Posts: 122
Joined: Sep 18, 2019

MacOS 13 / Ventura Compatability ?

Any idea if Indigo 2022.1 is going to run under Monterey?

Oops, I meant Ventura. I'm already running under Monterey.
Last edited by SearchCz on Wed Jun 08, 2022 7:26 am, edited 2 times in total.

Posted on
Tue Jun 07, 2022 9:11 am
dduff617 offline
Posts: 599
Joined: Jul 05, 2006
Location: Massachusetts, USA

Re: MacOS 13 / Ventura Compatability ?

I'm running it under Monterey and it is working fairly well for me. I recently (~1 month ago) migrated from an older mac that would not support anything beyond Catalina.

Posted on
Tue Jun 07, 2022 9:27 am
DaveL17 offline
User avatar
Posts: 6264
Joined: Aug 20, 2013
Location: Chicago, IL, USA

Re: MacOS 13 / Ventura Compatability ?

I'm a bit confused. The title says "Ventura" but the post says "Monterey". Indigo runs fine on Monterey.

Users SHOULD NOT upgrade to Ventura until Indigo Corporate says it's okay.

I came here to drink milk and kick ass....and I've just finished my milk.

[My Plugins] - [My Forums]

Posted on
Tue Jun 07, 2022 10:18 am
FlyingDiver offline
User avatar
Posts: 6193
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: MacOS 13 / Ventura Compatability ?

DaveL17 wrote:
I'm a bit confused. The title says "Ventura" but the post says "Monterey". Indigo runs fine on Monterey.

Users SHOULD NOT upgrade to Ventura until Indigo Corporate says it's okay.


Which won't be until sometime after the official release later this year. If you want to try it out on a "spare" system, go ahead. But don't bother reporting issues. ;)

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Jun 07, 2022 10:40 am
jay (support) offline
Site Admin
User avatar
Posts: 17551
Joined: Mar 19, 2008
Location: Austin, Texas

Re: MacOS 13 / Ventura Compatability ?

Assuming you mean Ventura, it will (once macOS Ventura FINAL ships from Apple later this year). We support all macOS releases and this one will be no different (the firedrill earlier this year is an example - it took us by surprise and it took longer, but we did update to support 12.3).

HOWEVER - you should not expect it to run on beta macOS releases. It may, it may not, but we don't support beta releases.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Wed Jun 08, 2022 7:27 am
SearchCz offline
Posts: 122
Joined: Sep 18, 2019

Re: MacOS 13 / Ventura Compatability ?

DaveL17 wrote:
I'm a bit confused. The title says "Ventura" but the post says "Monterey". Indigo runs fine on Monterey.

Users SHOULD NOT upgrade to Ventura until Indigo Corporate says it's okay.

My mistake, corrected. Any admins who would like to implement the [s] BBCode?

Posted on
Fri Aug 05, 2022 8:58 am
boisy offline
User avatar
Posts: 207
Joined: Jun 25, 2013

Re: MacOS 13 / Ventura Compatability ?

I went ahead and took the risk of upgrading my Mac mini M1 to Ventura Developer Beta 4. Everything "seemed" to be running fine, but then I noticed multiple entries in my Indigo log:

Code: Select all
Aug 5, 2022 at 9:50:32 AM
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Trigger                         Westgate - Process MQTT Shop Message
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Temperature" sensor update to 47.3 °F
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Humidity" sensor update to 55%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%
   Z-Wave                          received "030 - Temperature" status update battery level 40%


This is for a brand new Zoom ZSE44 Temperature and Humidity sensor that I deployed only two days ago, and already the battery is at 40%. I deployed a second one yesterday and the battery is at 5%.

It's not just this device. Other Z-Wave devices are coming in with multiple rapid log entries:

Code: Select all
Aug 5, 2022 at 9:29:46 AM
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux
   Z-Wave                          received "Westgate - Shop Illuminance" sensor update to 250 lux


I'm not sure if this signals some type of issue with Z-Wave devices as a whole with Indigo 2022.1.2 and my Aeotech Z-Wave USB adapter, but something is definitely wrong.

Posted on
Fri Aug 05, 2022 1:21 pm
jay (support) offline
Site Admin
User avatar
Posts: 17551
Joined: Mar 19, 2008
Location: Austin, Texas

Re: MacOS 13 / Ventura Compatability ?

Did you have any of those deployed before the upgrade? I can't see any reason why an OS upgrade would cause this, but I suppose anything is possible.

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Fri Aug 05, 2022 4:41 pm
matt (support) offline
Site Admin
User avatar
Posts: 21023
Joined: Jan 27, 2003
Location: Texas

Re: MacOS 13 / Ventura Compatability ?

Try unplugging your Z-Wave controller from the Mac for a bit, and also try a Mac reboot to see if that changes the behavior.

Image

Posted on
Tue Aug 09, 2022 7:59 am
boisy offline
User avatar
Posts: 207
Joined: Jun 25, 2013

Re: MacOS 13 / Ventura Compatability ?

Thanks for the suggestions. I've done those things, and also updated to developer beta 5 yesterday. The issue has abated somewhat, but in certain cases I'm seeing multiple Z-Wave messages of the same type in series in a short time.

I'll keep an eye on this.

Posted on
Tue Aug 09, 2022 9:36 am
jay (support) offline
Site Admin
User avatar
Posts: 17551
Joined: Mar 19, 2008
Location: Austin, Texas

Re: MacOS 13 / Ventura Compatability ?

I don't believe you answered my question: did you have any of those in use before you updated to Ventura? And did they exhibit the same behavior before the upgrade?

Jay (Indigo Support)
Twitter | Facebook | LinkedIn

Posted on
Tue Aug 09, 2022 1:42 pm
boisy offline
User avatar
Posts: 207
Joined: Jun 25, 2013

Re: MacOS 13 / Ventura Compatability ?

Apologies, Jay.

No, I didn't see this behavior prior to updating to Ventura beta. I did deploy the Zoom temperature sensor a few days before upgrading and it was working without issue or duplication before the upgrade.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest