Pushover v2022.0.0 Invalid Token problems

Posted on
Mon Oct 17, 2022 8:20 pm
haychess offline
Posts: 22
Joined: Dec 21, 2015

Pushover v2022.0.0 Invalid Token problems

Hi

I have followed all the instructions, but no matter what I do the plugin gives me an error:

Post Error - Result: {"token":"invalid","errors":["application token is invalid"],"status":0,"request":"xxxxxxxxxxxxxxxx"}

How can I get this working?

Posted on
Tue Oct 18, 2022 2:19 am
FlyingDiver offline
User avatar
Posts: 6340
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Pushover v2022.0.0 Invalid Token problems

Enable debug logging, restart the plugin, try to send a notification, post the log output.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Oct 18, 2022 12:38 pm
haychess offline
Posts: 22
Joined: Dec 21, 2015

Re: Pushover v2022.0.0 Invalid Token problems

Starting plugin "Pushover 2022.0.0" (pid 15283)
Pushover Debug logLevel = 5
Started plugin "Pushover 2022.0.0"
Pushover Debug startup called
Pushover Debug Sounds = OrderedDict([('pushover', 'Pushover (default)'), ('bike', 'Bike'), ('bugle', 'Bugle'), ('cashregister', 'Cash Register'), ('classical', 'Classical'), ('cosmic', 'Cosmic'), ('falling', 'Falling'), ('gamelan', 'Gamelan'), ('incoming', 'Incoming'), ('intermission', 'Intermission'), ('magic', 'Magic'), ('mechanical', 'Mechanical'), ('pianobar', 'Piano Bar'), ('siren', 'Siren'), ('spacealarm', 'Space Alarm'), ('tugboat', 'Tug Boat'), ('alien', 'Alien Alarm (long)'), ('climb', 'Climb (long)'), ('persistent', 'Persistent (long)'), ('echo', 'Pushover Echo (long)'), ('updown', 'Up Down (long)'), ('vibrate', 'Vibrate Only'), ('none', 'None (silent)')])
Trigger TEST
Pushover Debug send pluginAction.props = io.thechad.indigoplugin.pushover : (dict)
msgAttachment : (string)
msgBody : TEST (string)
msgDevice : (string)
msgPriority : 0 (string)
msgSound : (string)
msgSupLinkTitle : (string)
msgSupLinkUrl : (string)
msgTags : TEST (string)
msgTitle : TEST (string)
msgUser : xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx (string)
Pushover Error Post Error - Result: {"user":"invalid","errors":["user identifier is not a valid user, group, or subscribed user key"],"status":0,"request":"b2cca014-4a48-4749-a2e9-702e12014a17"}

I blocked out my msgUser number (hence the "xxxxxxx")

Posted on
Tue Oct 18, 2022 12:41 pm
FlyingDiver offline
User avatar
Posts: 6340
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Pushover v2022.0.0 Invalid Token problems

Well, that's a different error.

Try it without the user key in the action dialog, so it just uses the API token and user key from the plugin config dialog.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Thu Oct 20, 2022 9:48 pm
haychess offline
Posts: 22
Joined: Dec 21, 2015

Re: Pushover v2022.0.0 Invalid Token problems

That fixed it. Thanks so much.

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests