Pushover Plugin - push notifications

Posted on
Mon Sep 20, 2021 6:18 pm
FlyingDiver offline
User avatar
Posts: 5538
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Pushover Plugin - push notifications

At this point I would delete the preferences file and re-configure the plugin from scratch.

Also, make sure it works using the built-in actions before you try scripting it. I've never attempted to script it, so something might have changed to break the script. If you get it all working using the plugin actions, post your script and I'll see if something might have broken it.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Tue Sep 21, 2021 8:35 am
SearchCz offline
Posts: 82
Joined: Sep 18, 2019

Re: Pushover Plugin - push notifications

Did those steps .. still have a weird glitch. Weird glitch - the plugin will only send a notification successfully if I specify the app token. With the app token omitted, the plugs throws an error message.

Pushover Error Post Error - Result: {"token":"invalid","errors":["application token is invalid"],"status":0,"request":"a5a79376-b297-45df-95b4-59bfa057eff5"}

I currently have only one app token, and that's not it. I *might* have had this app token in the past and deleted it on pushover.net. It is not in my current list of app tokens, neither on pushover.net nor reported in my plugin. I'm in the process of locating all my calls to this plugin in order to add the specification of an app token. Seems to be addressing the problem so far, but I thought an app token was supposed tone optional?

Posted on
Tue Sep 21, 2021 10:43 am
FlyingDiver offline
User avatar
Posts: 5538
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Pushover Plugin - push notifications

Are you using a standard action from the UI to send the notification, or a script?

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Sep 22, 2021 8:41 am
SearchCz offline
Posts: 82
Joined: Sep 18, 2019

Re: Pushover Plugin - push notifications

FlyingDiver wrote:
Are you using a standard action from the UI to send the notification, or a script?


Either/both. They want that app token. Otherwise I get an error like this:

Pushover Error Post Error - Result: {"token":"invalid","errors":["application token is invalid"],"status":0,"request":"0ea47462-6dea-4546-beb7-5816b2f76617"}

Posted on
Wed Sep 22, 2021 8:43 am
FlyingDiver offline
User avatar
Posts: 5538
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Pushover Plugin - push notifications

Clearly something unintentional happened when I added support for multiple app tokens. Not sure when or if I'll find time to revert it to the previous behavior. You could always go back to the version before the multiple token support was added.

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Sep 22, 2021 3:19 pm
SearchCz offline
Posts: 82
Joined: Sep 18, 2019

Re: Pushover Plugin - push notifications

FlyingDiver wrote:
Clearly something unintentional happened when I added support for multiple app tokens. Not sure when or if I'll find time to revert it to the previous behavior. You could always go back to the version before the multiple token support was added.


No worries. It is working for me as long as I specify an app token, which is easy enough to do.

Have you ever heard of a problem where the same pushover message gets sent repeatedly, even though the triggering event is not repeating? I had that happening a while back and couldn't figure out where the hiccup was.

Posted on
Wed Sep 22, 2021 3:27 pm
FlyingDiver offline
User avatar
Posts: 5538
Joined: Jun 07, 2014
Location: Southwest Florida, USA

Re: Pushover Plugin - push notifications

Honestly, I don't use Pushover, except when testing the plugin. ;)

joe (aka FlyingDiver)
my plugins: http://forums.indigodomo.com/viewforum.php?f=177

Posted on
Wed Sep 22, 2021 4:13 pm
jcs offline
Posts: 4
Joined: Dec 13, 2017

Re: Pushover Plugin - push notifications

SearchCz wrote:
FlyingDiver wrote:
Clearly something unintentional happened when I added support for multiple app tokens. Not sure when or if I'll find time to revert it to the previous behavior. You could always go back to the version before the multiple token support was added.


No worries. It is working for me as long as I specify an app token, which is easy enough to do.

Have you ever heard of a problem where the same pushover message gets sent repeatedly, even though the triggering event is not repeating? I had that happening a while back and couldn't figure out where the hiccup was.


You are probably sending with a priority of 2, which repeats until you acknowledge it.

https://support.pushover.net/i19-receiv ... iple-times

Posted on
Wed Sep 22, 2021 9:58 pm
SearchCz offline
Posts: 82
Joined: Sep 18, 2019

Re: Pushover Plugin - push notifications

jcs wrote:
SearchCz wrote:
FlyingDiver wrote:
Clearly something unintentional happened when I added support for multiple app tokens. Not sure when or if I'll find time to revert it to the previous behavior. You could always go back to the version before the multiple token support was added.


No worries. It is working for me as long as I specify an app token, which is easy enough to do.

Have you ever heard of a problem where the same pushover message gets sent repeatedly, even though the triggering event is not repeating? I had that happening a while back and couldn't figure out where the hiccup was.


You are probably sending with a priority of 2, which repeats until you acknowledge it.

https://support.pushover.net/i19-receiv ... iple-times


I am not.

Who is online

Users browsing this forum: No registered users and 3 guests