Unable to pair with TV

Posted on
Sun Feb 05, 2017 11:47 pm
keith.henrickson offline
Posts: 12
Joined: Oct 24, 2016

Unable to pair with TV

So, I've got an XBR-65x930c, if that helps.

If I just enable the plugin and create the device in indigo, nothing shows up in the dropdown. I attached the UPnP logs below:
Code: Select all
  Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceUPNPSeachCacheTime
   Sony Bravia Network Remote Plugin Debug Performing uPnP search for: ssdp:all
   Sony Bravia Network Remote Plugin Debug Found 4 devices
   Sony Bravia Network Remote Plugin Debug Found uPnP Device: <SSDPResponse(http://192.168.1.178:45464/dd.xml, urn:dial-multiscreen-org:service:dial:1, uuid:0d35ffd6-529f-4475-9654-f5d6c9f6d134::urn:dial-multiscreen-org:service:dial:1, FedoraCore/2 UPnP/1.0 MINT-X/1.8.1)>[('usn', 'uuid:0d35ffd6-529f-4475-9654-f5d6c9f6d134::urn:dial-multiscreen-org:service:dial:1'), ('server', 'FedoraCore/2 UPnP/1.0 MINT-X/1.8.1'), ('ext', ''), ('location', 'http://192.168.1.178:45464/dd.xml'), ('cache-control', 'max-age=1800'), ('st', 'urn:dial-multiscreen-org:service:dial:1')]</SSDPResonse>
   Sony Bravia Network Remote Plugin Debug Found uPnP Device: <SSDPResponse(http://192.168.1.198:80/description.xml, urn:schemas-upnp-org:device:basic:1, uuid:2f402f80-da50-11e1-9b23-00178812ed7e, FreeRTOS/7.4.2 UPnP/1.0 IpBridge/1.16.0)>[('usn', 'uuid:2f402f80-da50-11e1-9b23-00178812ed7e'), ('ext', ''), ('hue-bridgeid', '001788FFFE12ED7E'), ('host', '239.255.255.250:1900'), ('location', 'http://192.168.1.198:80/description.xml'), ('st', 'urn:schemas-upnp-org:device:basic:1'), ('cache-control', 'max-age=100'), ('server', 'FreeRTOS/7.4.2 UPnP/1.0 IpBridge/1.16.0')]</SSDPResonse>
   Sony Bravia Network Remote Plugin Debug Found uPnP Device: <SSDPResponse(http://192.168.1.178:52323/MediaRenderer.xml, urn:schemas-rvualliance-org:service:StreamSplicing:1, uuid:23456789-1234-1010-8000-ac9b0a5b982a::urn:schemas-rvualliance-org:service:StreamSplicing:1, Android/1.6 UPnP/1.0 Huey Sample DMR/0.1)>[('usn', 'uuid:23456789-1234-1010-8000-ac9b0a5b982a::urn:schemas-rvualliance-org:service:StreamSplicing:1'), ('server', 'Android/1.6 UPnP/1.0 Huey Sample DMR/0.1'), ('ext', ''), ('location', 'http://192.168.1.178:52323/MediaRenderer.xml'), ('cache-control', 'max-age=1800'), ('x-av-server-info', 'av=5.0; hn=""; cn="Sony Corporation"; mn="Huey Sample DMR"; mv="0.1";'), ('st', 'urn:schemas-rvualliance-org:service:StreamSplicing:1')]</SSDPResonse>
   Sony Bravia Network Remote Plugin Debug Found uPnP Device: <SSDPResponse(http://192.168.1.178:26768/sony/webapi/ssdp/dd.xml, urn:schemas-sony-com:service:IRCC:1, uuid:0d3a9b6f-8806-481c-a914-92ff53962b51::urn:schemas-sony-com:service:IRCC:1, FedoraCore/2 UPnP/1.0 MINT-X/1.8.1)>[('usn', 'uuid:0d3a9b6f-8806-481c-a914-92ff53962b51::urn:schemas-sony-com:service:IRCC:1'), ('server', 'FedoraCore/2 UPnP/1.0 MINT-X/1.8.1'), ('ext', ''), ('location', 'http://192.168.1.178:26768/sony/webapi/ssdp/dd.xml'), ('cache-control', 'max-age=1800'), ('st', 'urn:schemas-sony-com:service:IRCC:1')]</SSDPResonse>


Figuring that the TV was probably 192.168.1.178, I tried entering that address manually, and creating a TV OFF action.

When I ran the action in Indigo 7, I got the following logs and a message on the TV saying "Please enter code 7837 in the device.". There's nowhere in the plugin settings to enter a code, other than maybe "Auth Token", which is greyed out for me.

Code: Select all
Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
   Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
   Sony Bravia Network Remote Plugin Threaddebug Returning default GUIConfigValue for sonyTvRemoteDevice:deviceIsChildDevice
   Sony Bravia Network Remote Plugin Threaddebug Command queue has 1 command(s) waiting
   Sony Bravia Network Remote Plugin Threaddebug Received SOAP/JSON command request:
                  /sony/IRCC
                  urn:schemas-sony-com:service:IRCC:1#X_SendIRCC
                  <?xml version="1.0" encoding="UTF-8"?>
                  <SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
                     <SOAP-ENV:Body>
                        <m:X_SendIRCC xmlns:m="urn:schemas-sony-com:service:IRCC:1">
                           <IRCCCode xmlns:dt="urn:schemas-microsoft-com:datatypes" dt:dt="string">AAAAAQAAAAEAAAAvAw==</IRCCCode>
                        </m:X_SendIRCC>
                     </SOAP-ENV:Body>
                  </SOAP-ENV:Envelope>
                  
   Sony Bravia Network Remote Plugin Debug Processing SOAP/JSON operation to http://192.168.1.178:80/sony/IRCC
   Sony Bravia Network Remote Plugin Threaddebug Sending SOAP/JSON request:
<?xml version="1.0" encoding="UTF-8"?>
                  <SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
                     <SOAP-ENV:Body>
                        <m:X_SendIRCC xmlns:m="urn:schemas-sony-com:service:IRCC:1">
                           <IRCCCode xmlns:dt="urn:schemas-microsoft-com:datatypes" dt:dt="string">AAAAAQAAAAEAAAAvAw==</IRCCCode>
                        </m:X_SendIRCC>
                     </SOAP-ENV:Body>
                  </SOAP-ENV:Envelope>
   Sony Bravia Network Remote Plugin Threaddebug Using headers:
{'SOAPAction': 'urn:schemas-sony-com:service:IRCC:1#X_SendIRCC', 'Host': u'192.168.1.178', 'Content-type': 'text/xml; charset="UTF-8"', 'User-Agent': 'DuncanwareRemote (IndigoPlugin)'}
   Sony Bravia Network Remote Plugin Received an authentication request, attempting now...
   Sony Bravia Network Remote Plugin Threaddebug Command queue has 1 command(s) waiting
   Sony Bravia Network Remote Plugin Threaddebug Received an authentication command, attempting connection
   Sony Bravia Network Remote Plugin Threaddebug Sending Auth Request: {"id":13, "method":"actRegister", "version":"1.0", "params": [{"clientid":"DuncanwareRemote:34c43339-af3d-40e7-b1b2-743331375368c", "nickname":"DuncanwareRemote (IndigoPlugin)"}, [{"clientid":"DuncanwareRemote:34c43339-af3d-40e7-b1b2-743331375368c", "value":"yes", "nickname":"DuncanwareRemote (IndigoPlugin)", "function":"WOL"}]]}
   Sony Bravia Network Remote Plugin Threaddebug Response to Auth Request: [401] [('content-length', '38'), ('content-type', 'application/json'), ('connection', 'close'), ('www-authenticate', 'Basic realm="Private Page"')]

{"error":[401,"Unauthorized"],"id":13}
   Sony Bravia Network Remote Plugin Error This device (1850737625) must be paired in order for the plugin to act as a remote.



By the way, the TV and the computer are on different floors, so I'm hoping a limited amount of running up and down the stairs is required.

Posted on
Mon Feb 06, 2017 12:04 am
RogueProeliator offline
User avatar
Posts: 2244
Joined: Nov 13, 2012
Location: Baton Rouge, LA

Re: Unable to pair with TV

When I ran the action in Indigo 7, I got the following logs and a message on the TV saying "Please enter code 7837 in the device.". There's nowhere in the plugin settings to enter a code, other than maybe "Auth Token", which is greyed out for me.

You need to perform the pairing before any actions will work - on the menu go to the Plugins -> Sony Bravia Network Remote Plugin -> Pair to Sony Device. You will get the number on your TV as you previously saw and need to enter that info into the dialog. (It will generate a new number each time, so don't enter the old one which you already have).

Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest